Opérations communes sur les VLAN: changement du type de lien d'une interface

46 0 0 0


Le type de lien d’une interface peut être un accès, une jonction, un hybride ou un tunnel Dot1q. Les méthodes utilisées pour changer le type de lien d'une interface dans différentes versions sont différentes.
Dans les versions V200R005 et supérieures, exécutez la commande port link-type { access | trunk | hybrid | dot1q-tunnel } et entrez y ou n à l'invite. Lorsque l'interface utilise la configuration VLAN par défaut, le système n'affiche aucun message. Le type de lien de l'interface est changé directement.
Lorsque vous entrez y et appuyez sur Entrée, le périphérique supprime automatiquement la configuration de VLAN autre que celle par défaut de l'interface et définit le type de lien de l'interface sur celui spécifié.
Lorsque vous entrez n et appuyez sur Entrée, le périphérique conserve le type de lien actuel et la configuration VLAN de l'interface.
Changez le type de lien de l'interface en hybride.

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
Warning: This command will delete VLANs on this port. Continue?[Y/N]:y 
Info: This operation may take a few seconds. Please wait for a moment...done.
Dans les versions antérieures de V200R005, une interface rejoint le VLAN 1 par défaut et le PVID d'une interface est le VLAN 1. Vous pouvez exécuter la commande port link-type { access | trunk | hybrid | dot1q-tunnel } pour changer le type de lien de l'interface.
Modifiez le type de lien de l'interface à access.

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type access
[HUAWEI-GigabitEthernet0/0/1] port default vlan 10   // Définissez le PVID de l'interface sur VLAN 10.

Changez le type de lien de l'interface en trunk.
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type trunk
[HUAWEI-GigabitEthernet0/0/1] port trunk pvid vlan 10  // Définissez le PVID de l'interface sur VLAN 10.
[HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 10 20 // Ajouter l'interface au VLAN 2, au VLAN 10 et au VLAN 20.

Changez le type de lien de l'interface en hybride.
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 10   // Définissez le PVID de l'interface sur VLAN 10.
[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 10 // Ajouter l'interface au VLAN 2 et au VLAN 10 en mode sans étiquette. [HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 20 // Ajouter l'interface au VLAN 20 en mode étiquetté.

Changez le type de lien de l'interface en Dot1q-tunnel.
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[HUAWEI-GigabitEthernet0/0/1] port default vlan 10   // Définissez le PVID de l'interface sur VLAN 10. L'interface ajoute le VLAN 10 à tous les paquets de données reçus.

Lorsque vous modifiez le type de lien d'une interface qui n'utilise pas la configuration VLAN par défaut, le système affiche le message "Error: Please renew the default configurations."
Vous devez restaurer la configuration par défaut de l'interface, puis modifier le type de lien de l'interface.
Restaurez la configuration VLAN par défaut d'une interface d'accès ou d'une interface tunnel Dot1q.
  • <HUAWEI> system-view
    [HUAWEI] interface gigabitethernet0/0/1
    [HUAWEI-GigabitEthernet0/0/1] undo port default vlan
  • Restaurez la configuration VLAN par défaut d'une interface de ligne de réseau.
    <HUAWEI> system-view
    [HUAWEI] interface gigabitethernet0/0/1
    [HUAWEI-GigabitEthernet0/0/1] undo port trunk pvid vlan
    [HUAWEI-GigabitEthernet0/0/1] undo port trunk allow-pass vlan all
    [HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 1
  • Restaurez la configuration par défaut d'une interface hybride.
    <HUAWEI> system-view
    [HUAWEI] interface gigabitethernet0/0/1
    [HUAWEI-GigabitEthernet0/0/1] undo port hybrid pvid vlan
    [HUAWEI-GigabitEthernet0/0/1] undo port hybrid vlan all
    [HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 1


Informations complémentaires: Guide de fonctionnement commun des commutateurs de la série S

  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.
Connectez-vous pour participer à la communication et au partage

Connectez-vous pour participer à la communication et au partage

S'identifier