Exemple de connexion de téléphones IP à des commutateurs via le PVID de l'ID de VLAN vocal

Dernière réponse my. 27, 2019 12:31:21 125 1 10 0

Vue d'ensemble

Si un périphérique vocal envoie des paquets avec le tag 0 ou des paquets sans étiquette, le PVID d'une interface peut être ajouté aux paquets vocaux. 

Ensuite, la priorité des paquets vocaux est augmentée en fonction de l'ID de VLAN.

Note de configuration

  • Cet exemple s'applique sur toutes les versions de tous les commutateurs de la série S.

  • Les téléphones Cisco 7912, Cisco 7940G et Cisco 7960G sont des PDs non standard. Si un commutateur est requis pour fournir une PoE, exécutez la commande poe legacy enable sur les interfaces du commutateur connecté aux téléphones IP pour activer la détection de compatibilité pour les PDs sur le PSE.

  • Les téléphones Cisco SPA 303 et Linksys SPA 921 ne prennent pas en charge PoE. Vous devez donc connecter les téléphones Cisco SPA 303 et Linksys SPA 921 à des sources d'alimentation externes, puis les connecter à des commutateurs.

  • Pour les téléphones Mitel 5212, les options 128, 129, 130 et 131 doivent être configurées dans le plage d'adresses du serveur DHCP. sinon, les téléphones Mitel 5212 ne peuvent pas identifier les paquets de l'offre DHCP envoyés par le serveur DHCP ni se mettre en ligne. La configuration sur le commutateur est la suivante:

<HUAWEI> system-view 
[HUAWEI] ip pool ip-phone 
[HUAWEI-ip-pool-ip-phone] option 128 ip-address 10.20.20.1 
[HUAWEI-ip-pool-ip-phone] option 129 ip-address 11.20.20.1 
[HUAWEI-ip-pool-ip-phone] option 130 ascii MITEL IP PHONE 
[HUAWEI-ip-pool-ip-phone] option 131 ip-address 11.20.20.1 

Téléphones IP applicables

Voir "1.3 Modes d'interconnexion pris en charge par différents modèles de téléphones IP".

Configuration réseau requise

Dans la figure 1-11:


  • Les téléphones IP ne peuvent envoyer que des paquets vocaux sans étiquette.

  • La priorité des paquets vocaux doit être accrue pour assurer la qualité de la communication.

  • Les paquets vocaux sont transmis dans le VLAN 100.

  • Les adresses IP des téléphones IP et l'adresse IP du serveur DHCP se trouvent sur des segments de réseau différents.

  • Les téléphones IP doivent se connecter aux commutateurs via l'authentification par adresse MAC.

  • Connexion des téléphones IP aux commutateurs via le PVID de l'ID de VLAN vocal

Connexion de téléphones IP aux commutateurs via l'ID de VLAN vocal PVID

171402p6mmfsldoyzz64jf.png?19.png

Configuration Roadmap

La configuration roadmap est la suivante:

1. Ajoutez une interface à un VLAN en mode sans étiquette afin que les paquets vocaux soient transférés dans le VLAN.

2. Activez la fonction VLAN voix sur une interface et définissez le PVID de l'interface sur l'ID de VLAN voix.

3. Configurez les fonctions de relais DHCP et de serveur DHCP afin que les adresses IP soient attribuées aux téléphones IP.

4. Configurez l'authentification par adresse MAC pour les téléphones IP. (Cette étape peut être ignorée si l'authentification n'est pas requise.)

Procédure


Étape 1 Ajoutez une interface sur SwitchA à un VLAN.

# Créer un VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname SwitchA 
[SwitchA] vlan batch 100  //Configure VLAN 100 in which voice traffic is transmitted. 

# Ajouter une interface au VLAN 100 en mode sans étiquette.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid   //In V200R005C00 and later versions, the default link type of an interface is not hybrid, and needs to be manually configured. 
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100  //Packets sent by IP phones do not carry tags, so the interface must be join VLAN 100 in untagged mode. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100 
[SwitchA-GigabitEthernet1/0/2] quit 

Étape 2 : Activez la fonction VLAN voix sur une interface de SwitchA et définissez le PVID de l'interface sur l'ID de VLAN voix.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] voice-vlan 100 enable  //Enable the voice VLAN function on the interface. 
[SwitchA-GigabitEthernet1/0/1] voice-vlan remark-mode mac-address  //In V200R003 and later versions, the interface needs to be configured to identify voice packets based on MAC addresses. This configuration is not required in earlier versions of V200R003. 
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100  //Configure the PVID. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2  //The configuration of GE1/0/2 is similar to the configuration of GE1/0/1. 
[SwitchA-GigabitEthernet1/0/2] voice-vlan 100 enable 
[SwitchA-GigabitEthernet1/0/2] voice-vlan remark-mode mac-address 
[SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100 
[SwitchA-GigabitEthernet1/0/2] quit 
[SwitchA] voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
[SwitchA] voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000

Étape 3 : Configurez la fonction de relais DHCP et le serveur DHCP.

1. Configurez la fonction de relais DHCP sur SwitchA.

# Configurez la fonction de relais DHCP sur une interface.

[SwitchA] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled. 
[SwitchA] interface Vlanif 100  //Create VLANIF 100. 
[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Assign an IP address to VLANIF 100. 
[SwitchA-Vlanif100] dhcp select relay  //Enable the DHCP relay function on VLANIF 100. 
[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure the DHCP server address on the DHCP relay agent. 
[SwitchA-Vlanif100] quit 

# Créer un VLANIF 100.

[SwitchA] vlan batch 200 
[SwitchA] interface Vlanif 200 
[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure an IP address for VLANIF 200 for communication with SwitchB. 
[SwitchA-Vlanif200] quit 

# Ajoutez l'interface de liaison montante au VLAN 200.

[SwitchA] interface gigabitethernet 1/0/3 
[SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200 
[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200 
[SwitchA-GigabitEthernet1/0/3] quit 

# Configuration d'une route statique par defaut

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //The next hop address of the route corresponds to the IP address of VLANIF 200 on SwitchB. 

2. Configurez SwitchB en tant que serveur DHCP pour attribuer des adresses IP aux téléphones IP.

# Configurez un pool d'adresses.

<HUAWEI> system-view 
[HUAWEI] sysname SwitchB 
[SwitchB] ip pool ip-phone  //Create an address pool. 
[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure the gateway address on the DHCP server. 
[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure allocatable IP addresses in the IP address pool. 
[SwitchB-ip-pool-ip-phone] quit 

# Configurez la fonction du serveur DHCP.

[SwitchB] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled. 
[SwitchB] vlan batch 200 
[SwitchB] interface Vlanif 200  //Create VLANIF 200. 
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Assign an IP address to VLANIF 200. 
[SwitchB-Vlanif200] dhcp select global  //Configure SwitchB to allocate IP addresses from the global IP address pool to the IP phone. 
[SwitchB-Vlanif200] quit 

# Ajoutez l’interface de liaison descendante au VLAN 200.

[SwitchB] interface gigabitethernet 1/0/3 
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid 
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200 
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200 
[SwitchB-GigabitEthernet1/0/3] quit

# Configurez un route de retour.

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

Étape 4 Configurez un domaine d'authentification et une authentification par adresse MAC pour les téléphones IP.

1. Configurez un domaine d'authentification.

# Créer et configurer un modèle de serveur RADIUS.

[SwitchA] radius-server template cisco  //Create a RADIUS server template named cisco
[SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812  //Configure the IP address and port number of the RADIUS authentication server. 
[SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813  //Configure the IP address and port number of the RADIUS accounting server. 
[SwitchA-radius-cisco] quit 

# Configurez un schéma d'authentification.

[SwitchA] aaa 
[SwitchA-aaa] authentication-scheme radius  //Create an authentication scheme named radius
[SwitchA-aaa-authen-radius] authentication-mode radius  //Set the authentication mode to RADIUS. 
[SwitchA-aaa-authen-radius] quit 

# Créez un domaine d'authentification et liez le modèle de serveur RADIUS et le schéma d'authentification au domaine d'authentification.

[SwitchA-aaa] domain default  //Configure a domain named default
[SwitchA-aaa-domain-default] authentication-scheme radius  //Bind the authentication scheme radius to the domain. 
[SwitchA-aaa-domain-default] radius-server cisco  //Bind the RADIUS server template cisco to the domain. 
[SwitchA-aaa-domain-default] quit 
[SwitchA-aaa] quit 

2. Configurez l'authentification par adresse MAC pour les téléphones IP et le PC.

- V200R007C00 et versions antérieures, et V200R008C00

# Définissez le mode NAC sur unifié.

[SwitchA] authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

# Activer l'authentification d'adresse MAC sur une interface.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] authentication mac-authen  //Enable MAC address authentication. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] authentication mac-authen 
[SwitchA-GigabitEthernet1/0/2] quit 

- V200R009C00 et versions ultérieures

# Définissez le mode NAC sur unifié.

[SwitchA] authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

# Configurez un profil d’accès MAC.

[SwitchA] mac-access-profile name cisco  //Create a MAC access profile named cisco
[SwitchA-mac-access-profile-cisco] quit

# Configurez un profil d'authentification.

[SwitchA] authentication-profile name cisco  //Configure an authentication profile. 
[SwitchA-authen-profile-cisco] mac-access-profile cisco  //Bind the MAC access profile cisco to the authentication profile. 
[SwitchA-authen-profile-cisco] quit

# Appliquez le profil d'authentification à l'interface.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] authentication-profile cisco  //Bind the authentication profile and enable MAC address authentication. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] authentication-profile cisco 
[SwitchA-GigabitEthernet1/0/2] quit 

3. Configurez le contrôleur agile. L'affichage du contrôleur Agile varie selon les versions. V100R002C10SPC401 est utilisé à titre d'exemple.

a- Connectez-vous au contrôleur Agile.

Ouvrez Internet Explorer, entrez l'adresse d'accès à Agile Controller dans la barre d'adresse et appuyez sur Entrer.

Entrez le nom d'utilisateur et le mot de passe de l'administrateur. Si vous vous connectez au contrôleur Agile pour la première fois, utilisez le nom d'utilisateur super administrateur admin et le mot de passe Changeme123. Modifiez le mot de passe immédiatement après vous être connecté. Sinon, Agile Controller ne peut pas être utilisé.

Les modes d’accès suivants du contrôleur Agile peuvent être utilisés.

Access Mode

Description

https://Agile Controller-IP:8443

Agile Controller-IP  spécifie l'adresse IP du contrôleur Agile.

Adresse Ip du Controlleur Agil

Si le port 80 est activé lors de l'installation, vous pouvez accéder au contrôleur Agile en entrant son adresse IP sans le numéro de port. L'URL du contrôleur Agile passera automatiquement à https: // Agile Controller-IP: 8443.

 

b- Ajouter une adresse MAC

i.          Choisir Resource > User > User Management.
ii.        sélectionner All Accounts.
iii.       Cliquez sur Add pour créer un compte MAC. La valeur du MAC Account est l'adresse MAC du téléphone IP. 
20
c.         Ajouter SwitchA au controleur Agile.
i.          Choisir Resource > Device > Device Management.
ii.        Cliquez sur  Add. Dans Add Device page, Ajouter SwitchA utilisé pour authentifier les téléphones IP.
201

Ajoutez un téléphone IP au contrôleur Agile.
i.          Choisir Resource > Terminal > Terminal List.
ii.        Cliquez Add to access the Add Device Group page.
iii.      Dans Add Device Group page, ajouter un groupe de téléphones IP.
202
iv. Cliquez sur un groupe de périphériques, sélectionnez cisco_ipphone, sélectionnez Device List, puis cliquez sur Ajouter pour ajouter un téléphone IP.
203

e. Ajouter une règle d'authentification.
Choisir Policy > Permission Control > Authentication & Authorization > Authentication Rule et Cliquez Add pour cree une regle d'authetification.
204

F. Ajouter un résultat d'autorisation.
Choisir  Policy > Permission Control > Authentication & Authorization > Authorization Rule et cliquez sur Add pour cree un resultat d'autorisation.
205
Étape 5 Vérifiez la configuration.
  • Les téléphones IP peuvent obtenir l'ID et les adresses IP du VLAN vocal.
  • La sortie de la commande display access-user sur SwitchA affiche les informations de connexion des téléphones IP. 
----Fin

Fichiers de configuration
  • Fichier de configuration SwitchA (versions V200R007C00 et antérieures et V200R008C00)

# 
sysname SwitchA 
# 
voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000 
# 
vlan batch 100 200 
# 
dhcp enable 
# 
radius-server template cisco 
 radius-server authentication 192.168.6.182 1812 weight 80 
 radius-server accounting 192.168.6.182 1813 weight 80 
# 
aaa 
 authentication-scheme radius 
  authentication-mode radius 
 domain default 
  authentication-scheme radius 
  radius-server cisco 
# 
interface Vlanif100 
 ip address 10.20.20.1 255.255.255.0 
 dhcp select relay 
 dhcp relay server-ip 10.10.20.2 
# 
interface Vlanif200 
 ip address 10.10.20.1 255.255.255.0 
# 
interface GigabitEthernet1/0/1        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication mac-authen 
# 
interface GigabitEthernet1/0/2        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication mac-authen 
# 
interface GigabitEthernet1/0/3        
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 
# 
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2 
# 
return 

l   Fichier de configuration SwitchA (V200R009C00 and later versions)

# 
sysname SwitchA 
# 
voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000 
# 
vlan batch 100 200 
# 
authentication-profile name cisco 
 mac-access-profile cisco 
# 
dhcp enable 
# 
radius-server template cisco 
 radius-server authentication 192.168.6.182 1812 weight 80 
 radius-server accounting 192.168.6.182 1813 weight 80 
# 
aaa 
 authentication-scheme radius 
  authentication-mode radius 
 domain default 
  authentication-scheme radius 
  radius-server cisco 
# 
interface Vlanif100 
 ip address 10.20.20.1 255.255.255.0 
 dhcp select relay 
 dhcp relay server-ip 10.10.20.2 
# 
interface Vlanif200 
 ip address 10.10.20.1 255.255.255.0 
# 
interface GigabitEthernet1/0/1        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication-profile cisco 
# 
interface GigabitEthernet1/0/2        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication-profile cisco 
# 
interface GigabitEthernet1/0/3        
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 
# 
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2 
# 
mac-access-profile name cisco 
# 
return 

l   Fichier de configuration SwitchB

# 
sysname SwitchB 
# 
vlan batch 200 
# 
dhcp enable 
# 
ip pool ip-phone 
 gateway-list 10.20.20.1  
 network 10.20.20.0 mask 255.255.255.0  
# 
interface Vlanif200 
 ip address 10.10.20.2 255.255.255.0 
 dhcp select global 
# 
interface GigabitEthernet1/0/3 
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 
# 
ip route-static 10.20.20.0 255.255.255.0 10.10.20.1 
# 
return 



  • x
  • Standard:

publié il y a 2019-5-27 12:31:21 Utile(0) Utile(0)
Merci pour le partage
  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

Connectez-vous pour participer à la communication et au partage

S'identifier
Réponse rapide Accéder au haut de page