Exemple de connexion d'un seul périphérique à un cluster NLB (Utilisation de la boucle de liaison physique)

31 0 2 0

Vue d'ensemble

NLB est développé par Microsoft pour un cluster configuré par plusieurs serveurs Windows. Lorsqu'un commutateur est connecté à un cluster NLB, il doit envoyer des paquets destinés à l'adresse IP du cluster à chaque serveur NLB du cluster. Un serveur NLB peut fonctionner en mode monodiffusion, multidiffusion ou multidiffusion IGMP.

Actuellement, un commutateur peut être connecté au serveur NLB ne fonctionnant qu'en mode monodiffusion ou multidiffusion. Si le commutateur prend en charge le protocole ARP multi-interface, il est recommandé d'utiliser cette fonction pour implémenter la connexion entre le commutateur et le cluster NLB. Lorsque le commutateur ou la version ne prend pas en charge le protocole ARP multi-interfaces et que les ressources de périphérique sont insuffisantes, vous pouvez utiliser le bouclage de liaison physique pour connecter le commutateur au cluster NLB.

Notes de configuration

l    Lorsque le cluster NLB fonctionne en mode monodiffusion, il n'est pas nécessaire de configurer les entrées ARP statiques sur le commutateur. lorsque le cluster fonctionne en mode multidiffusion, les entrées ARP statiques doivent être configurées sur le commutateur.

l    Cet exemple s’applique à toutes les versions de tous les commutateurs de la série S.

Exigences de mise en réseau

Comme le montre la figure 1-1 , le commutateur se connecte à trois serveurs NLB via GE0 / 0/1, GE0 / 0/2 et GE0 / 0/3. Le cluster NLB fonctionne en mode monodiffusion, l'adresse IP du cluster est 10.128.246.252/24 et l'adresse MAC du cluster est 02bf-0a80-f6fc. Il existe des itinéraires accessibles entre le commutateur et le client.

Le client exige que le commutateur puisse envoyer les paquets du client destinés à l'adresse IP du cluster NLB à tous les serveurs NLB.

Figure 1-1 Connexion d'un seul périphérique à un cluster NLB en mode de monodiffusion

20170323143845125004.png

 

Feuille de route de configuration

La feuille de route de configuration est la suivante:

1.          Ajoutez les GE0 / 0/1 à GE0 / 0/3 directement connectés aux serveurs NLB au VLAN 100.

2          Désactivez STP, RSTP, VBST ou MSTP sur GE0 / 0/4 et GE0 / 0/5 et ajoutez les interfaces au VLAN 100 et au VLAN 200 respectivement en mode d'accès.

3          Configurez une adresse IP pour VLANIF 200 faisant office de passerelle du cluster NLB.

4          Connecter GE0 / 0/4 et GE0 / 0/5.

Procédure

                               Étape 1      Ajoutez les GE0 / 0/1 à GE0 / 0/3 directement connectés aux serveurs NLB au VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Switch 
[Switch] vlan batch 100 200 
[Switch] interface gigabitethernet 0/0/1 
[Switch-GigabitEthernet0/0/1] port link-type access 
[Switch-GigabitEthernet0/0/1] quit 
[Switch] interface gigabitethernet 0/0/2 
[Switch-GigabitEthernet0/0/2] port link-type access 
[Switch-GigabitEthernet0/0/2] quit 
[Switch] interface gigabitethernet 0/0/3 
[Switch-GigabitEthernet0/0/3] port link-type access 
[Switch-GigabitEthernet0/0/3] quit 
[Switch] vlan 100 
[Switch-vlan100] port gigabitethernet 0/0/1 to 0/0/3 
[Switch-vlan100] quit 

                               Étape 2      Configurez GE0 / 0/4 et GE0 / 0/5.

# Désactive STP, RSTP, VBST ou MSTP sur GE0 / 0/4 et GE0 / 0/5.

[Switch] interface gigabitethernet 0/0/4 
[Switch-GigabitEthernet0/0/4] undo stp enable   
[Switch-GigabitEthernet0/0/4] quit 
[Switch] interface gigabitethernet 0/0/5 
[Switch-GigabitEthernet0/0/5] undo stp enable   
[Switch-GigabitEthernet0/0/5] quit

# Ajoutez GE0 / 0/4 et GE0 / 0/5 aux VLAN 100 et VLAN 200 respectivement en mode d’accès.

[Switch] interface gigabitethernet 0/0/4 
[Switch-GigabitEthernet0/0/4] port link-type access 
[Switch-GigabitEthernet0/0/4] port default vlan 100 
[Switch-GigabitEthernet0/0/4] quit 
[Switch] interface gigabitethernet 0/0/5 
[Switch-GigabitEthernet0/0/5] port link-type access 
[Switch-GigabitEthernet0/0/5] port default vlan 200 
[Switch-GigabitEthernet0/0/5] quit

                               Étape 3      Configurez une adresse IP pour la passerelle du cluster NLB.

[Switch] interface vlanif 200 
[Switch-Vlanif200] ip address 10.128.246.250 24 
[Switch-Vlanif200] quit 

                               Étape 4      Connecter GE0 / 0/4 et GE0 / 0/5.

Après les configurations précédentes, connectez des liens physiques.

                               Étape 5      Vérifiez la configuration.

Vérifiez que Server_1 à Server_3 peut recevoir des paquets destinés au cluster NLB.

----End

Fichiers de configuration

Fichier de configuration du commutateur


sysname Switch 

vlan batch 100 200 
#                                                                                
interface Vlanif200                                                              
 ip address 10.128.246.250 255.255.255.0                                         
#                                                                                
interface GigabitEthernet0/0/1               
 port link-type access                                                           
 port default vlan 100                                                 
#  
interface GigabitEthernet0/0/2               
 port link-type access                                                           
 port default vlan 100                                                   
#                                                                                
interface GigabitEthernet0/0/3               
 port link-type access                                                           
 port default vlan 100                                                   
#                                                                                
interface GigabitEthernet0/0/4               
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5               
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
return  


  • x
  • Standard:

Commentaire

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.
Connectez-vous pour participer à la communication et au partage

Connectez-vous pour participer à la communication et au partage

S'identifier