Exemple de connexion d'un groupe VRRP à un cluster NLB (Utilisation de la boucle de liaison physique)

165 0 9 0

Exemple de connexion d'un groupe VRRP à un cluster NLB (Utilisation de la boucle de liaison physique)

Vue d'ensemble

NLB est développé par Microsoft pour un cluster configuré par plusieurs serveurs Windows. Lorsqu'un commutateur est connecté à un cluster NLB, il doit envoyer des paquets destinés à l'adresse IP du cluster à chaque serveur NLB du cluster. Un serveur NLB peut fonctionner en mode monodiffusion, multidiffusion ou multidiffusion IGMP.

Actuellement, un commutateur peut être connecté au serveur NLB ne fonctionnant qu'en mode monodiffusion ou multidiffusion. Si le commutateur prend en charge le protocole ARP multi-interface, il est recommandé d'utiliser cette fonction pour implémenter la connexion entre le commutateur et le cluster NLB. Lorsque le commutateur ou la version ne prend pas en charge le protocole ARP multi-interfaces et que les ressources de périphérique sont insuffisantes, vous pouvez utiliser le bouclage de liaison physique pour connecter le commutateur au cluster NLB.

Notes de configuration

  • Lorsque le cluster NLB fonctionne en mode monodiffusion, il n'est pas nécessaire de configurer les entrées ARP statiques sur le commutateur. lorsque le cluster fonctionne en mode multidiffusion, les entrées ARP statiques doivent être configurées sur le commutateur.

  • Le tableau 1 répertorie les produits et versions applicables.

Tableau 1 Modèles et versions de produits applicables

Produit

Model de produit

Version de logiciel

S1700

S1720GW and S1720GWR

V200R010C00, V200R011C00, V200R011C10

S1720GW-E and S1720GWR-E

V200R010C00, V200R011C00, V200R011C10

S1720X and S1720X-E

V200R011C00, V200R011C10

S2700

S2720EI

V200R011C10

S3700

S3700EI

V100R006C05

S3700HI

V200R001C00

S5700

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710HI

V200R003C00, V200R005(C00&C02&C03)

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S5720HI

V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10

S6720SI and S6720S-SI

V200R011C00, V200R011C10

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10

S7700

S7703, S7706, and S7712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10

S9700

S9703, S9706, and S9712

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005C00, V200R006C00, V200R007(C00&C10), V200R008C00, V200R009C00, V200R010C00, V200R011C10

 

170534xm12kbfxw223hmm3.jpg?ww.jpg

Pour plus d'informations sur les mappages de logiciels, voir Recherche de mappage de versions pour les commutateurs Huawei Campus.


Exigences de mise en réseau

Comme le montre la figure 1, Switch_1 et Switch_2 se connectent à l'aide de GE0/0/2 et forment un groupe VRRP via le lien Heartbeat. Switch_1 est le maître et Switch_2 est la sauvegarde. Les interfaces GE0/0/1 sur Switch_1 et Switch_2 sont directement connectées à deux serveurs NLB, respectivement. Le cluster NLB fonctionne en mode multidiffusion, l'adresse IP du cluster est 10.128.246.252/24 et l'adresse MAC du cluster est 03bf-0a80-f6fc. Il existe des itinéraires accessibles entre le commutateur et le client.

Le client exige que le groupe VRRP puisse envoyer les paquets du client destinés à l'adresse IP du cluster NLB à tous les serveurs NLB.

Figure 1 Connexion d'un groupe VRRP à un cluster NLB en mode multidiffusion

170905yq91mckrc622c2r1.png?21.png


Plan de données

Avant la configuration, vous avez besoin des données suivantes.


Item

Data

Description

Adresse IP

l  Switch_1's VLANIF 200: 10.128.246.10/24

l  Switch_2's VLANIF 200: 10.128.246.11/24

l  Adresse IP virtuelle: 10.128.246.250

-


Configuration Roadmap

La configuration roadmap est la suivante: 

1. Ajoutez GE0/0/1 au VLAN 100.

2. Ajoutez GE0/0/2 au VLAN 100. 

3. Désactivez STP, RSTP, VBST ou MSTP sur GE0/0/4 et GE0/0/5 et ajoutez les interfaces au VLAN 100 et au VLAN 200 respectivement en mode d'accès. 

4. Configurez une adresse IP virtuelle VRRP pour VLANIF 200 faisant office de passerelle du cluster NLB. 

5. Configurez une entrée ARP statique. Dans l'entrée ARP statique, l'adresse IP est l'adresse IP du cluster, l'adresse MAC est l'adresse MAC de multidiffusion du cluster et l'interface sortante est l'interface à laquelle le VLAN auquel appartient la passerelle du cluster NLB est configuré. 

6. Connectez GE0/0/4 et GE0/0/5.

Procédure


Étape 1 # Configurez GE0/0/1.

Ajoutez GE0/0/1 sur Switch_1 au VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Switch_1 
[Switch_1] vlan batch 100 200 
[Switch_1] interface gigabitethernet 0/0/1 
[Switch_1-GigabitEthernet0/0/1] port link-type access 
[Switch_1-GigabitEthernet0/0/1] port default vlan 100 
[Switch_1-GigabitEthernet0/0/1] quit 


# Ajoutez GE0/0/1 sur Switch_2 au VLAN 100. 

<HUAWEI> system-view 
[HUAWEI] sysname Switch_2 
[Switch_2] vlan batch 100 200 
[Switch_2] interface gigabitethernet 0/0/1 
[Switch_2-GigabitEthernet0/0/1] port link-type access 
[Switch_2-GigabitEthernet0/0/1] port default vlan 100 
[Switch_2-GigabitEthernet0/0/1] quit 


Étape 2 Ajoutez GE0/0/2 au VLAN 100.

# Ajoutez GE0/0/2 sur Switch_1 au VLAN 100.

[Switch_1] interface gigabitethernet 0/0/2 
[Switch_1-GigabitEthernet0/0/2] port link-type trunk  
[Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 
[Switch_1-GigabitEthernet0/0/2] quit 


# Ajoutez GE0/0/2 sur Switch_2 au VLAN 100.

[Switch_2] interface gigabitethernet 0/0/2 
[Switch_2-GigabitEthernet0/0/2] port link-type trunk  
[Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 
[Switch_2-GigabitEthernet0/0/2] quit 


171855ymwsttmtnl9ttnl0.jpg?ww.jpg

Les interfaces Heartbeat ne peuvent pas appartenir au même VLAN que la passerelle pour empêcher une boucle de trafic au sein du groupe VRRP. Par exemple, GE0/0/2 dans cet exemple ne peut pas être ajouté à VLAN 200.


Étape 3 Configurez GE0/0/4 et GE0/0/5.

# Désactivez STP, RSTP, VBST ou MSTP sur GE0/0/4 et GE0/0/5 sur Switch_1.

[Switch_1] interface gigabitethernet 0/0/4 
[Switch_1-GigabitEthernet0/0/4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_1-GigabitEthernet0/0/4] quit 
[Switch_1] interface gigabitethernet 0/0/5 
[Switch_1-GigabitEthernet0/0/5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_1-GigabitEthernet0/0/5] quit


# Ajoutez GE0/0/4 et GE0/0/5 sur Switch_1 aux VLAN 100 et VLAN 200 respectivement en mode d’accès.

[Switch_1] interface gigabitethernet 0/0/4 
[Switch_1-GigabitEthernet0/0/4] port link-type access 
[Switch_1-GigabitEthernet0/0/4] port default vlan 100 
[Switch_1-GigabitEthernet0/0/4] quit 
[Switch_1] interface gigabitethernet 0/0/5 
[Switch_1-GigabitEthernet0/0/5] port link-type access 
[Switch_1-GigabitEthernet0/0/5] port default vlan 200 
[Switch_1-GigabitEthernet0/0/5] quit


# Désactive STP, RSTP, VBST ou MSTP sur GE0/0/4 et GE0/0/5 sur Switch_2.

[Switch_2] interface gigabitethernet 0/0/4 
[Switch_2-GigabitEthernet0/0/4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_2-GigabitEthernet0/0/4] quit 
[Switch_2] interface gigabitethernet 0/0/5 
[Switch_2-GigabitEthernet0/0/5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_2-GigabitEthernet0/0/5] quit


# Ajoutez GE0/0/4 et GE0/0/5 sur le Switch_2 au VLAN 100 et au VLAN 200 respectivement en mode d’accès.

[Switch_2] interface gigabitethernet 0/0/4 
[Switch_2-GigabitEthernet0/0/4] port link-type access 
[Switch_2-GigabitEthernet0/0/4] port default vlan 100 
[Switch_2-GigabitEthernet0/0/4] quit 
[Switch_2] interface gigabitethernet 0/0/5 
[Switch_2-GigabitEthernet0/0/5] port link-type access 
[Switch_2-GigabitEthernet0/0/5] port default vlan 200 
[Switch_2-GigabitEthernet0/0/5] quit


Étape 4 Configurez une adresse IP pour la passerelle du cluster NLB.

# Créez le groupe 1 du VRRP sur Switch_1 et définissez la priorité VRRP sur 120.

[Switch_1] interface vlanif 200 
[Switch_1-Vlanif200] ip address 10.128.246.10 24 
[Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Create VRRP group 1 
[Switch_1-Vlanif200] vrrp vrid 1 priority 120   //Set the VRRP priority to 120 
[Switch_1-Vlanif200] quit


# Créez le groupe VRRP 1 sur Switch_2 et utilisez la priorité VRRP par défaut 100.

[Switch_2] interface vlanif 200 
[Switch_2-Vlanif200] ip address 10.128.246.11 24 
[Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Create VRRP group 1 
[Switch_2-Vlanif200] quit

172906bmzp9m69slulllf2.jpg?ww.jpg

  • Configurez l'adresse IP virtuelle VRRP 10.128.246.250 pour VLANIF 200 qui fonctionne comme passerelle du cluster NLB.

  • Pour réduire la charge de travail du réseau, il est conseillé de séparer la passerelle du cluster NLB des autres passerelles. Dans cette mise en réseau, le trafic d'un commutateur vers le cluster NLB passe par la liaison Heartbeat vers le commutateur homologue, puis par la ligne à boucle automatique du commutateur homologue. Dans ce cas, si d'autres serveurs utilisent la même passerelle que les serveurs NLB, les autres serveurs recevront le trafic destiné au cluster NLB, ce qui entraînera une augmentation de la charge de travail du réseau. Par exemple, les paquets destinés au cluster NLB de Switch_1 transmettent le lien de pulsation à Switch_2. Sur Switch_2, les paquets sont envoyés de GE0/0/4 à 0/0/5. Si VLANIF 200 sur Switch_2 est également la passerelle de serveurs non-NLB, les paquets sont envoyés à des serveurs non-NLB via GE0/0/5.

Étape 5 Configurez les entrées ARP statiques.

# Sur Switch_1, configurez une entrée ARP statique. Dans l'entrée ARP, l'adresse IP est 10.128.246.252, l'adresse MAC est 03bf-0a80-f6fc, l'interface sortante est GE0 / 0/5 où se trouve le réseau local virtuel 200.

[Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5


# Sur Switch_2, configurez une entrée ARP statique. Dans l'entrée ARP, l'adresse IP est 10.128.246.252, l'adresse MAC est 03bf-0a80-f6fc, l'interface sortante est GE0 / 0/5 où se trouve le réseau local virtuel 200.

[Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5


Étape 6 Connecter GE0 / 0/4 et GE0 / 0/5.

Après les configurations précédentes, connectez les liens physiques sur Switch_1 et Switch_2 respectivement.

Étape 7 Vérifiez la configuration.

Vérifiez que Server_1 et Server_2 peuvent recevoir des paquets destinés au cluster NLB.

----Fin 


Fichiers de configuration


  Ficher de configuration Switch_1


sysname Switch_1 

vlan batch 100 200 
#                                                                                
interface Vlanif200 
 ip address 10.128.246.10 255.255.255.0  
 vrrp vrid 1 virtual-ip 10.128.246.250 
 vrrp vrid 1 priority 120 
#                                                                                
interface GigabitEthernet0/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                  
#  
interface GigabitEthernet0/0/2                                                  
 port link-type trunk                                                            
 port trunk allow-pass vlan 100                                                  
#                                                                                
interface GigabitEthernet0/0/4                                                 
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5                                                 
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5 
#   
return 

l   Fichier de configuration Switch_2


sysname Switch_2 

vlan batch 100 200 
#                                                                                
interface Vlanif200 
 ip address 10.128.246.11 255.255.255.0  
 vrrp vrid 1 virtual-ip 10.128.246.250 
#                                                                                
interface GigabitEthernet0/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                 
#  
interface GigabitEthernet0/0/2                                                  
 port link-type trunk                                                            
 port trunk allow-pass vlan 100                                                  
#                                                                                
interface GigabitEthernet0/0/4                                                 
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5                                                 
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5 
#   
return 


  • x
  • Standard:

Commentaire

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.
Connectez-vous pour participer à la communication et au partage

Connectez-vous pour participer à la communication et au partage

S'identifier