Exemple de configuration de l'attribut de communauté BGP

32 0 0 0

Les configurations de Switch et Switch sont similaires à la configuration de SwitchA et ne sont pas mentionnées ici.Les configurations de Switch et Switch sont similaires à la configuration de SwitchA et ne sont pas mentionnées ici.


les connexions sont établies entre Switch et Switch, et entre Switch et Switch. AS 20 ne doit pas annoncer les itinéraires annoncés par AS 10 à AS 30.

163752cqr7rf3312u3103q.png
Procédure
Configurez les VLAN auxquels appartiennent les interfaces.

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/0
[SwitchA-GigabitEthernet1/0/0] port link-type trunk
[SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/0] quit
[SwitchA] interface gigabitethernet 2/0/0
[SwitchA-GigabitEthernet2/0/0] port link-type trunk
[SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet2/0/0] quit 

Les configurations de SwitchB et SwitchC sont similaires à la configuration de SwitchA et ne sont pas mentionnées ici.

Attribuez une adresse IP à chaque interface VLANIF.

[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ip address 10.1.1.1 24
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 20
[SwitchA-Vlanif20] ip address 192.168.2.1 24
[SwitchA-Vlanif20] quit

Les configurations de SwitchB et SwitchC sont similaires à la configuration de SwitchA et ne sont pas mentionnées ici.

Configurez BGP.
# Configurez SwitchA

[SwitchA] bgp 10
[SwitchA-bgp] router-id 172.16.1.1
[SwitchA-bgp] peer 192.168.2.2 as-number 20
[SwitchA-bgp] ipv4-family unicast
[SwitchA-bgp-af-ipv4] network 10.1.1.0 255.255.255.0
[SwitchA-bgp-af-ipv4] quit
[SwitchA-bgp] quit

# Configurez SwitchB.

[SwitchB] bgp 20
[SwitchB-bgp] router-id 172.16.2.2
[SwitchB-bgp] peer 192.168.2.1 as-number 10
[SwitchB-bgp] peer 192.168.3.2 as-number 30
[SwitchB-bgp] quit

# Configurez SwitchC.

[SwitchC] bgp 30
[SwitchC-bgp] router-id 172.16.3.3 
[SwitchC-bgp] peer 192.168.3.1 as-number 20
[SwitchC-bgp] quit

# Vérifiez la table de routage de SwitchB

[SwitchB] display bgp routing-table 10.1.1.0

BGP local router ID : 172.16.2.2
 Local AS number : 20
 Paths:   1 available, 1 best, 1 select
 BGP routing table entry information of 10.1.1.0/24:
 From: 192.168.2.1 (172.16.1.1)
 Route Duration: 00h00m15s
 Direct Out-interface: Vlanif20
 Original nexthop: 192.168.2.1
 Qos information : 0x0
 AS-path 10, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255
 Advertised to such 2 peers:
    192.168.2.1
    192.168.3.2

Vous pouvez voir que Switch annonce les itinéraires reçus pour le basculer dans AS 30.
# Vérifiez la table de routage de SwitchC.

[SwitchC] display bgp routing-table

 BGP Local router ID is 172.16.3.3
 Status codes: * - valid, > - best, d - damped,
               h - history,  i - internal, s - suppressed, S - Stale
               Origin : i - IGP, e - EGP, ? - incomplete
 Total Number of Routes: 1
      Network            NextHop        MED        LocPrf    PrefVal Path/Ogn

 *>   10.11.1.0/24        192.168.3.1                           0      20 10i

Vous pouvez constater que SwitchC a appris un itinéraire vers la destination 10.1.1.0/24 à partir de SwitchB.

Configurez les attributs de la communauté BGP.

# Configurez la politique de routage sur SwitchA pour permettre à SwitchB de ne pas publier les itinéraires annoncés par SwitchA vers un autre AS.

[SwitchA] route-policy comm_policy permit node 10
[SwitchA-route-policy] apply community no-export
[SwitchA-route-policy] quit# Apply routing policies.

[SwitchA] bgp 10
[SwitchA-bgp] ipv4-family unicast
[SwitchA-bgp-af-ipv4] peer 192.168.2.2 route-policy comm_policy export
[SwitchA-bgp-af-ipv4] peer 192.168.2.2 advertise-community # Vérifiez la table de routage de SwitchB.

[SwitchB] display bgp routing-table 10.1.1.0

BGP local router ID : 172.16.2.2
 Local AS number : 20
 Paths:   1 available, 1 best, 1 select
 BGP routing table entry information of 10.1.1.0/24:
 From: 192.168.2.1 (172.16.1.1)
 Route Duration: 00h00m33s
 Direct Out-interface: Vlanif20
 Original nexthop: 192.168.2.1
 Qos information : 0x0
 Community:no-export
 AS-path 10, origin igp, MED 0, pref-val 0, valid, external, best, select, activ
e, pre 255


Vous n'êtes pas encore annoncé à un homologue. Vous pouvez afficher l'attribut de communauté configuré dans la table de routage BGP de SwitchB. À l'heure actuelle, il n'y a pas de route vers la destination 10.1.1.0/24 dans la table de routage BGP de SwitchC.

Fichiers de configuration
Fichier de configuration de SwitchA

#
sysname SwitchA
#
vlan batch 10 20
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif20
 ip address 192.168.2.1 255.255.255.0
#
interface GigabitEthernet1/0/0
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet2/0/0
 port link-type trunk
 port trunk allow-pass vlan 20
#
bgp 10
 router-id 172.16.1.1
 peer 192.168.2.2 as-number 20
 #
 ipv4-family unicast
  undo synchronization
  network 10.1.1.0 255.255.255.0
  peer 192.168.2.2 enable
  peer 192.168.2.2 route-policy comm_policy export
  peer 192.168.2.2 advertise-community
#
route-policy comm_policy permit node 10
 apply community no-export
#
returnConfiguration file of SwitchB

#
sysname SwitchB
#
vlan batch 20 30
#
interface Vlanif20
 ip address 192.168.2.2 255.255.255.0
#
interface Vlanif30
 ip address 192.168.3.1 255.255.255.0
#
interface GigabitEthernet2/0/0
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet3/0/0
 port link-type trunk
 port trunk allow-pass vlan 30
#
bgp 20
 router-id 172.16.2.2
 peer 192.168.2.1 as-number 10
 peer 192.168.3.2 as-number 30
 #
 ipv4-family unicast
  undo synchronization
  peer 192.168.2.1 enable
  peer 192.168.3.2 enable
#
returnConfiguration file of SwitchC

#
sysname SwitchC
#
vlan 30
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
#
interface GigabitEthernet3/0/0
 port link-type trunk
 port trunk allow-pass vlan 30
#
bgp 30
 router-id 172.16.3.3
 peer 192.168.3.1 as-number 20
 #
 ipv4-family unicast
  undo synchronization
  peer 192.168.3.1 enable
#
return


  • x
  • Standard:

Commentaire

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.
Connectez-vous pour participer à la communication et au partage

Connectez-vous pour participer à la communication et au partage

S'identifier