j'ai compris

Configuration IPSec sur GRE Routeur HUawei AR1220E et routeur Cisco

publié il y a  2020-3-26 14:07:17 24 0 0 0

J'ai testé cette configuration en Live Environment entre Huawei et Cisco:


Configuration du routeur Huawei #


interface GigabitEthernet0/0/8

 description WAN_1

 ip address 172.16.12.2 255.255.255.252


interface GigabitEthernet0/0/9

 description P2P-FW

 ip address 172.19.10.1 255.255.255.252

!

interface Tunnel0/0/0

 description Tunnel-Wan1

 ip address 192.168.3.2 255.255.255.252

 tunnel-protocol gre

 source GigabitEthernet0/0/8

 destination 172.16.12.1

 ipsec profile profile1

!

ospf 1 router-id 192.168.3.2

 import-route static

 area 0.0.0.0

  network 172.19.10.0 0.0.0.3

  network 192.168.3.0 0.0.0.3



La phase 1

========


ike proposal 5

 encryption-algorithm 3des

 dh group2

 authentication-algorithm md5

 authentication-method pre-share



ike peer spub

 pre-shared-key simple xyz@123

 ike-proposal 5

 remote-address 172.16.12.1



Phase 2

========

ipsec proposal tran1

 esp authentication-algorithm md5

 esp encryption-algorithm 3des


ipsec profile profile1

 ike-peer spub

 proposal tran1


==========================


Configuration de Cisco #


crypto isakmp policy 5

 encr 3des

 hash md5

 authentication pre-share

 group 2

crypto isakmp key xyz@123 address 172.16.12.2

!

!

crypto ipsec transform-set xxx@123 esp-3des esp-md5-hmac

 mode tunnel

!

crypto ipsec profile xyz@123

 set transform-set xxx@123

!

!

interface Loopback10

 ip address 172.21.100.1 255.255.255.0

!

interface Tunnel0

 description ##Tunnel-1 ###

 ip address 192.168.3.1 255.255.255.252

 tunnel source GigabitEthernet0/0/0

 tunnel destination 172.18.12.2

 tunnel protection ipsec profile xyz@123

!

interface GigabitEthernet0/0/0

 description WAN_1

 ip address 172.16.12.1 255.255.255.252

 negotiation auto

!

router ospf 1

 router-id 192.168.3.1

 network 172.21.100.0 0.0.0.255 area 0

 network 192.168.3.0 0.0.0.3 area 0

!



Prendre plaisir! @ _ @


  • x
  • Standard:

Commentaire

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

My Followers

Connectez-vous pour participer à la communication et au partage

S'identifier

Communauté de Support de Huawei Entreprise
Communauté de Support de Huawei Entreprise