[Uso compartido de información privilegiada] Solución de problemas de red definitiva: duplicación remota de puertos.

91 0 0 0

 Hola, chicos,

 

 A veces, los problemas de red requieren métodos especiales de solución de problemas. Los comandos de visualización, la depuración, las estadísticas de tráfico pueden no ser suficientes para cerrar el problema, por lo que una captura con paquetes de protocolo que pasan por un puerto o que coinciden con un flujo de tráfico específico puede resultar muy útil. Pero, ¿qué haría si la interfaz / flujo de destino está lejos de su red y no hay manera de viajar lo suficientemente rápido a ese punto de presencia y conectar su estación de monitoreo directamente al dispositivo? La duplicación de puertos remota hará el truco.

 

 

 

 Para empezar, ¿qué es la duplicación de paquetes?

 

 

 Es una característica que le ayuda a capturar paquetes que pasan a través de una interfaz en línea.

 

 ¿Como funciona?


 Copia los paquetes que pasan por una interfaz y los envía a otra.

 

 ¿Por qué necesitamos esto?

 - - para fines de solución de problemas.

 - - para dispositivos de red que requieren monitoreo de tráfico.

 - - Con fines educativos.

 

 En la duplicación de puertos remotos, la interfaz que recopila y envía los paquetes al host no está conectada localmente al dispositivo de duplicación. El dispositivo de monitoreo y el puerto de observación están conectados a través de una red de Capa 2.

 

 ¿Cómo funciona en este caso? ¿Has oído hablar de RSPAN?

 

 Puerto conmutado remoto  (RSPAN): el dispositivo encapsula los paquetes que pasan a través de puertos duplicados en paquetes VLAN, y el puerto de observación difunde los paquetes VLAN en la VLAN RSPAN para reenviar paquetes al dispositivo de monitoreo. Es obligatorio implementar RSPAN VLAN desde el dispositivo de puerto duplicado hasta la observación del dispositivo de puerto a través de su red de capa 2.

 

 

 ¿Cómo hacerlo en la red de Huawei?


 Consideremos un escenario simple, con algunos switches Huawei de las series 27 y 57 y 77. Topología:

093906qa183zao89uj5b8q.png

 

 La interfaz eth2 / 0/1 del S7700 está configurada con un rol de puerto duplicado para el tráfico entrante y saliente.

#

interface Ethernet2/0/1

port link-type access

port default vlan 58

port-mirroring to observe-port 3 inbound

port-mirroring to observe-port 3 outbound

#

 En la vista de sistema es necesario configurar el puerto de observación y RSPAN vlan. El Switch S7700 encapsula paquetes duplicados en paquetes VLAN, y luego, el puerto de observación transmite paquetes VLAN a la VLAN RSPAN y los reenvía al dispositivo de monitoreo.

#

observe-port 3 interface Ethernet2/0/4 vlan 999

#

 

 Es obligatorio implementar RSPAN vlan sobre la red de capa 2, desde el dispositivo espejo hasta el dispositivo de observación, por lo que debo agregarlo a los troncales.

 

#

interface Ethernet2/0/4

port hybrid tagged vlan 999

#

 

 El S5700 es un intermediario y debe retransmitir vlan 999 hasta el S2700.

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 999

ntdp enable

ndp enable

#

interface GigabitEthernet0/0/3

port link-type trunk

port trunk allow-pass vlan 999

ntdp enable

ndp enable

#

 

 En el S2700, el gi0/0/2 recolectará paquetes copiados de RSPAN vlan. La interfaz gi0/0/3 se conecta al host de monitoreo. Se configura para desmarcar los paquetes recibidos en RSPAN vlan.

 

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 999

ntdp enable

ndp enable

interface GigabitEthernet0/0/3

port link-type trunk

port trunk pvid vlan 999

port trunk allow-pass vlan 127 333

#

 

 En el puerto espejo he generado un tráfico uniforme que consta de 6 paquetes salientes y 16 paquetes entrantes.

 

<S7700>display interface Ethernet2/0/1

----------------------------------------------------------------------------------------------

Last 10 seconds input rate 194832 bits/sec, 16 packets/sec

Last 10 seconds output rate 75568 bits/sec, 6 packets/sec

----------------------------------------------------------------------------------------------

 

 Con la configuración actual, puedo ver los paquetes duplicados que salen de la interfaz S7700 y que llegan al S5700 entrante.

 

< S7700>display interface Ethernet2/0/4

-----------------------------------------------------------------------------------------

Last 10 seconds input rate 176 bits/sec, 0 packets/sec

Last 10 seconds output rate 261600 bits/sec, 22 packets/sec

-----------------------------------------------------------------------------------------

 

[S5700]display interface GigabitEthernet 0/0/2

--------------------------------------------------------------------------------------------------

Last 10 seconds input rate 261600 bits/sec, 22 packets/sec

Last 10 seconds output rate 0 bits/sec, 0 packets/sec

--------------------------------------------------------------------------------------------------

 

 Pero no puedo ver ningún paquete que salga de la interfaz de observación. ¿Cuál podría ser la razón?

[S5700]display interface GigabitEthernet 0/0/3

----------------------------------------------------------------------------------------

Last 10 seconds input rate 0 bits/sec, 0 packets/sec

Last 10 seconds output rate 0 bits/sec, 0 packets/sec

-----------------------------------------------------------------------

 

 Está claro que los frames llegan al switch. El siguiente paso es verificar y hacer coincidir el valor de la dirección MAC de destino con una entrada en la tabla de direcciones MAC del switch.

 

  Revisemos la tabla de direcciones de mac para vlan 999 para ver cómo se ve:

<S5700>display mac-address dynamic vlan 999

-------------------------------------------------------------------------------

MAC Address    VLAN/VSI                          Learned-From        Type     

-------------------------------------------------------------------------------

aaaa-bb1e-5a54 999/-                               GE0/0/2             dynamic  

aaaa-bb11-cccc  999/-                               GE0/0/2             dynamic  

aaaa-bb22 5a54 999/-                               GE0/0/2             dynamic  

 

 

 No hay ninguna entrada aprendida de gigabitethernet0 / 0/3. Esto significa que el tráfico se devolverá a GigabitEthernet0/ 0/2, y debido a que la MAC de destino es en realidad la MAC de origen el frame será descartado.

 

 Debido a la función de aprendizaje, las direcciones mac están poblando la tabla. Registra la dirección MAC de origen y la interfaz de entrada de la trama de Ethernet en una entrada de dirección MAC. Cuando el conmutador recibe otras tramas Ethernet destinadas a esta dirección MAC, el S5700 envía las tramas a través de la interfaz de salida correspondiente de acuerdo con la entrada de la dirección MAC.

 

 Al realizar la duplicación bidireccional, los paquetes entrantes se copiarán y entregarán a través del puerto observado. Esos paquetes llegarán al switch intermedio, pero aquí el switch eliminará las tramas Ethernet que llegan a través de la interfaz que ha aprendido la dirección mac de destino de estas tramas. Por lo general, cambian las tramas de difusión que no coinciden con ninguna entrada en la tabla mac, pero como ese destino se ve como origen, los paquetes se eliminarán en gi0 /0/3.

 

 La solución aquí es deshabilitar el aprendizaje de dirección-mac en RSPAN vlan. Por lo tanto, no se creará una entrada de dirección-mac en la tabla de dirección-mac para que todo el tráfico inunde el RSPAN vlan.

 

S5700]vlan 999

[S5700-vlan999]mac-address learning disable 

[S5700]undo mac-address dynamic vlan 999  \\ mac-adress need to be aged out instantly

 

 

 Usando esta secuencia de comandos, la tabla de direcciones mac estará vacía y la capa 2 de envío hará un emisión de todas las tramas en RSPAN vlan 999.


 De esta manera los paquetes serán enviados a través de Gi0 / 0/3

[S5700]display interface GigabitEthernet 0/0/3
-----------------------------------------------------------------------------------------
Last 10 seconds input rate 0 bits/sec, 0 packets/sec
Last 10 seconds output rate 287216 bits/sec, 24 packets/sec

----------------------------------------------------------------------------------------

 

 Conclusión:

 

 Para la duplicación remota es necesario deshabilitar el aprendizaje de la dirección de mac en RSPAN VLAN en dispositivos intermediarios, de lo contrario los paquetes serán devueltos por los switches intermedios y finalmente se eliminarán.

 

 Espero disfruten leyendo este caso. :)

 

 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba