[Todo sobre Switches] Ejemplo de configuración MSTP.

167 0 0 0



1          Informacion General

El protocolo Multiple Spanning Tree Protocol (MSTP) definido en el IEEE 802 es la conbinacion del protocolo Spanning Tree (STP) y de las Virtual Local Area Network (VLAN). En pocas palabras, STP o RSTP se implementa en función de los puertos, mientras que el MSTP se basa en instancias. MSTP hereda la transición rápida de RSTP y resuelve el problema de RSTP en el que todas las VLAN comparten un STP.

2                    Implementación.

2.1 Región e instancia.

Comparado con STP/RSTP, MSTP usa instancias y regiones.

 

Una instancia Multiple Spanning Tree (MSTI) es una colección de varias VLAN. Las múltiples VLAN donde se transmite el mismo servicio se pueden asignar a un MSTI. La topología de cada MSTI se calcula de forma independiente. El tráfico se puede equilibrar en la carga a través de la asignación entre VLAN y MSTI. De forma predeterminada, todas las VLAN se asignan a MSTI 0.

 

Una región consiste en el nombre de la región, el nivel de revisión y la asignación entre VLAN y MSTI. Todos los conmutadores en una región deben tener la misma configuración de región MST. Es decir, los conmutadores que tienen el mismo nombre de región, nivel de revisión y asignación entre VLAN y MSTI pertenecen a la misma región. De forma predeterminada, el nombre de la región es la dirección MAC del puente de un conmutador, el nivel de revisión es 0 y todas las VLAN se asignan a MSTI 0.

 

MSTP define los Spanning Trees:

1. EL Common Internal Spanning Tree (CIST) está compuesto por Common Spanning Tree (CST) y el árbol de expansión interno (IST).

2. El CST conecta todas las regiones MST en una red switching.

3. El IST se encuentra en una región MST.

4. Se forma un solo Spanning Tree (SST) cuando un dispositivo de switching que ejecuta STP o RSTP pertenece a un solo Spanning Tree o una región MST tiene solo un dispositivo de switching.

 

2.2 Root regional y CIST Root.


122030wb2487impb5v6izt.png


Puerto maestro: entre todos los puertos de borde en una región MST, el puerto maestro tiene el menor costo para la raíz CIST. El puerto maestro se encuentra en la ruta más corta que conecta las regiones MST con la raíz CIST. El puerto maestro es el puerto raíz en un CIST.

 

Puerto de borde regional: un puerto de borde regional está ubicado en el borde de una región MST y se conecta a otra región MST. Múltiples puertos de borde regionales pueden existir en una región MST.

 

2.1 Calculo de topología en MSTP.

 

Cálculo CIST

 

Los siguientes vectores participan en el cálculo CIST para recortar una red de anillo en una red de árbol:

{ root ID, costo de ruta en un external root, root ID de región, costo de ruta en un internal root, ID de dispositivo de switching designado, ID de puerto designado, ID de puerto de recepción}

 

Procedimiento de cálculo CIST:

1. Los dispositivos en una red envían y reciben BPDUs. Después de comparar las BPDU de configuración, el dispositivo con la prioridad más alta en toda la red se selecciona como la raíz CIST.

2. MSTP calcula un IST para cada región MST.

3. MSTP considera cada región MST como un único conmutador y calcula un CST para interconectar las regiones MST.

El CST y los IST constituyen un CIST para toda la red.

Cálculo MSTI

 

Los siguientes vectores participan en el cálculo de MSTI para recortar una red de anillo en una red de árbol:

{ root ID regional, costo de la ruta de internal root, ID de dispositivo de switching designado, ID de puerto designado, ID de puerto de recepción}

 

En una región MST, MSTP calcula un MSTI para cada VLAN basándose en la asignación entre VLAN y MSTI. Cada MSTI se calcula de forma independiente. El proceso de cálculo es similar al proceso de STP / RSTP para calcular un árbol de expansión.

 

3        Notas de configuración.

Las VLAN vinculadas a MSTI deben haberse creado y los puertos se han agregado a las VLAN. El comando display stp brief solo muestra información sobre todos los puertos habilitados para STP que estén arriba.

Después de configurar los parámetros de una región MST, debe ejecutar el comando active region-configuration para activar la configuración de la región MST.

El nombre de región predeterminado es la dirección MAC de un dispositivo. La dirección MAC de cada dispositivo es diferente, por lo que debe especificar manualmente una región para mantener la coherencia de la información de la región en los conmutadores.

En los switches fijos, los puertos envían BPDU de STP a la CPU después de que el comando bpdu enable esté configurado globalmente o en puertos. Sin esta configuración, los puertos no pueden enviar BPDU a la CPU después de recibir las BPDU. STP entonces no puede converger.

Para los switches S2700 en V100R005 y versiones anteriores, verifique si el comando bpdu enable se ha configurado globalmente. Para otros switches fijos en V100R005 y versiones anteriores, verifique si el comando bpdu enable se ha configurado en los puertos físicos y en el Eth-Trunk.

Para los switches fijos en V100R006 y versiones posteriores, el comando bpdu enable se configura globalmente o en puertos de forma predeterminada en los modelos correspondientes.

Después de habilitar STP en un Eth-Trunk, cambie el costo del Eth-Trunk a un valor más pequeño que el costo de los puertos físicos para que el Eth-Trunk no se negocie como el puerto de respaldo. El costo del Eth-Trunk es el costo de un puerto miembro dividido por el número de puertos miembros. Por lo tanto, el costo de Eth-Trunk cambia después de que cambie el estado de los puertos miembros. Un menor costo indica una mejor calidad de enlace.


4
                   Configuration Examples Ejemplos de configuracion.

4.1        Requerimientos de red


122039fcbg9sd8uuu8x5mj.png


Como se muestra en la figura, SwitchA, SwitchB, SwitchC y SwitchD constituyen una red en anillo para respaldar los enlaces y equilibrar la carga del tráfico de dos departamentos. Se requiere MSTP para bloquear un puerto y podar la red en una red de árbol sin bucles.

El tráfico en el departamento 1 y el departamento 2 debe estar equilibrado en la carga.

SwitchA y SwitchB funcionan como el puente raíz y el puente raíz secundario de los dos departamentos.

En SwitchC y SwitchD, los puertos GE0 / 0/3 conectados a los usuarios no pueden participar en el cálculo de STP.

4.2     Configuración Roadmap.

 

La configuración roadmap es la siguiente:

1. Cree VLAN y agregue puertos a las VLAN.

2. Configure los switches para que funcionen en modo MSTP.

3. Configure la región denominada RG1 y especifique la asignación entre VLAN y MSTI.

4. Configure SwitchA y SwitchB como el puente raíz y el puente raíz secundario de los dos departamentos.

5. Configure los switches para utilizar el costo de la ruta por defecto. Los switches Huawei utilizan el estándar IEEE 802.1T para calcular los costos de ruta de forma predeterminada. De forma predeterminada, el costo de un puerto GE es 20000, y el costo de un puerto Ethernet es 200000. En eNSP, el costo de la ruta STP predeterminada es 1.

6. Deshabilite STP en los puertos GE0 / 0/3 en SwitchC y SwitchD.

7. Habilite STP en SwitchA, SwitchB, SwitchC y SwitchD.

 

4.3         Procedure

Step 1: Create VLANs and add ports to VLANs.

 

<HUAWEI> system-view

[HUAWEI] sysname   SwitchA

[SwitchA] vlan   batch 2 to 4094

[SwitchA] interface   gigabitethernet0/0/1

[SwitchA-GigabitEthernet0/0/1] port   link-type trunk

[SwitchA-GigabitEthernet0/0/1] port   trunk allow-pass vlan 2 to 4094

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface   gigabitethernet0/0/2

[SwitchA-GigabitEthernet0/0/2] port   link-type trunk

[SwitchA-GigabitEthernet0/0/2] port   trunk allow-pass vlan 2 to 4094

[SwitchA-GigabitEthernet0/0/2] quit

 

<HUAWEI> system-view

[HUAWEI] sysname   SwitchB

[SwitchB] vlan   batch 2 to 4094

[SwitchB] interface   gigabitethernet0/0/1

[SwitchB-GigabitEthernet0/0/1] port   link-type trunk

[SwitchB-GigabitEthernet0/0/1] port   trunk allow-pass vlan 2 to 4094

[SwitchB-GigabitEthernet0/0/1]   quit

[SwitchB] interface   gigabitethernet0/0/2

[SwitchB-GigabitEthernet0/0/2] port   link-type trunk

[SwitchB-GigabitEthernet0/0/2] port   trunk allow-pass vlan 2 to 4094

[SwitchB-GigabitEthernet0/0/2] quit

 

<HUAWEI> system-view

[HUAWEI] sysname   SwitchC

[SwitchC] vlan   batch 2 to 4094

[SwitchC] interface   gigabitethernet0/0/1

[SwitchC-GigabitEthernet0/0/1] port   link-type trunk

[SwitchC-GigabitEthernet0/0/1] port   trunk allow-pass vlan 2 to 4094

[SwitchC-GigabitEthernet0/0/1] quit

[SwitchC] interface   gigabitethernet0/0/2

[SwitchC-GigabitEthernet0/0/2] port   link-type trunk

[SwitchC-GigabitEthernet0/0/2] port   trunk allow-pass vlan 2 to 4094

[SwitchC-GigabitEthernet0/0/2] quit

 

<HUAWEI> system-view

[HUAWEI] sysname   SwitchD

[SwitchD] vlan   batch 2 to 4094

[SwitchD] interface   gigabitethernet0/0/1

[SwitchD-GigabitEthernet0/0/1] port   link-type trunk

[SwitchD-GigabitEthernet0/0/1] port   trunk allow-pass vlan 2 to 4094

[SwitchD-GigabitEthernet0/0/1] quit

[SwitchD] interface   gigabitethernet0/0/2

[SwitchD-GigabitEthernet0/0/2] port   link-type trunk

[SwitchD-GigabitEthernet0/0/2] port   trunk allow-pass vlan 2 to 4094

[SwitchD-GigabitEthernet0/0/2] quit

Step 2: Configure switches to work in MSTP mode.

En los switches Huawei, MSTP está habilitado por default, siendo así se puede omitir este paso.

 

 [SwitchA] stp mode mstp

 

 [SwitchB] stp mode mstp

 

 [SwitchC] stp mode mstp

 

 [SwitchD] stp mode mstp

Step 3: Configure the region named RG1 and specify the mapping between VLANs and MSTIs.

La configuración de región en los cuatro dispositivos debe ser coherente para que se pueda eliminar el bucle.

 

[SwitchA] stp   region-configuration

[SwitchA-mst-region] region-name   RG1   //Configure the region name RG1.

[SwitchA-mst-region] instance   1 vlan 1 to 200  //By default, all VLANs are mapped to MSTI 0. Here, VLANs 1 to   200 are mapped to MSTI 1, and VLANs 201 to 4094 are mapped to MSTI 0.

[SwitchA-mst-region] active   region-configuration  //Activate the region configuration.

[SwitchA-mst-region] quit  

 

[SwitchB] stp   region-configuration

[SwitchB-mst-region] region-name   RG1

[SwitchB-mst-region] instance   1 vlan 1 to 200

[SwitchB-mst-region] active   region-configuration

[SwitchB-mst-region] quit 

 

[SwitchC] stp   region-configuration

[SwitchC-mst-region] region-name   RG1

[SwitchC-mst-region] instance   1 vlan 1 to 200

[SwitchC-mst-region] active   region-configuration

[SwitchC-mst-region] quit 

 

[SwitchD] stp   region-configuration

[SwitchD-mst-region] region-name   RG1

[SwitchD-mst-region] instance   1 vlan 1 to 200

[SwitchD-mst-region] active   region-configuration

[SwitchD-mst-region] quit 

 

Step 4: Configure the root bridge and secondary root bridge.

 

Configure SwitchA como el puente raíz y SwitchB como el puente raíz secundario en MSTI 0, y configure SwitchA como el puente raíz secundario y SwitchBcomo el puente raíz en MSTI 1.

 

[SwitchA] stp   instance 0 root primary   //You can also use the stp priority 0 command to set   the STP priority to 0. Running the stp priority 0 command is   equivalent to running the stp root primary command.

[SwitchA] stp   instance 1 root secondary  //You can also use the stp priority 4096 command to   set the STP priority to 4096. The stp priority 4096 command   is equivalent to the stp root secondary command.

 

[SwitchB] stp   instance 0 root secondary

[SwitchB] stp   instance 1 root primary

Step 5: Disable STP on GE0/0/3 interfaces of SwitchC and SwitchD.

[SwitchC] interface   gigabitethernet0/0/3

[SwitchC-GigabitEthernet0/0/3] stp   disable

[SwitchC-GigabitEthernet0/0/3] quit

 

[SwitchD] interface   gigabitethernet0/0/3

[SwitchD-GigabitEthernet0/0/3] stp   disable

[SwitchD-GigabitEthernet0/0/3] quit

Step 6: Enable STP globally.

En los switches Huawei serie X7 STP esta habilitado por default, en este caso puede omitir este paso.

 

[SwitchA] stp enable

 

[SwitchB] stp enable

 

[SwitchC] stp enable

 

[SwitchD] stp enable

Step 7: Verify the configuration.

Revise el resumen de la información sobre MSTP. Usted podrá ver los roles de los puertos y su estado.


122109g3u57n2955u7o70h.png


4.4        Archivos de configuración.

Archivo de configuración SwitchA

#

sysname SwitchA

#

vlan batch 2 to 4094

#

stp instance 0 root   primary

stp instance 1 root   secondary

stp enable

#

stp   region-configuration

 region-name RG1

 instance 1 vlan   1 to 200

 active   region-configuration

#

interface   GigabitEthernet0/0/1

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface   GigabitEthernet0/0/2

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

return

Archivo de configuración SwitchB

#

sysname SwitchB

#

vlan batch 2 to 4094

#

stp instance 0 root   secondary

stp instance 1 root   primary

stp enable

stp   region-configuration

 region-name RG1

 instance 1 vlan   1 to 200

 active   region-configuration

#

interface   GigabitEthernet0/0/1

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface   GigabitEthernet0/0/2

port link-type trunk

 port trunk allow-pass   vlan 2 to 4094

return 

Archivo de configuración SwitchC

#

sysname SwitchC 

vlan batch 2 to 4094

#

stp enable

#

stp   region-configuration

 region-name RG1

 instance 1 vlan   1 to 200

 active   region-configuration

interface   GigabitEthernet0/0/1

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface   GigabitEthernet0/0/2

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface   GigabitEthernet0/0/3

 stp disable

return 

Archivo de configuración SwitchD

#

sysname SwitchD

#

vlan batch 2 to 4094

#

stp mode stp

interface   GigabitEthernet0/0/1

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface   GigabitEthernet0/0/2

port link-type trunk

 port trunk   allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/3

 stp disable

return

 

 

 

 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba