[Todo acerca de switches] 27 Tecnoligía QinQ

78 0 0 0

La mayoría de la gente tiene gran interés en QinQ, pero enfrentan dificulades durante el uso de QinQ.

Acontinuacion describiré cómo usar QinQ.

060545hqwaqqhcoq89cw2q.png?VRRP.pngPrimero, presentaré QinQ.

QinQ se despliega a menudo en la capa de agregación. Los paquetes Qinq llevan etiquetas de VLAN dobles y contienen etiquetas VLAN de cuatro bytes adicionales en comparación con los paquetes de capa 2 comunes. La tecnología Qinq puede identificar con flexibilidad los servicios.

060554vibgiuzexjighrjg.png?VRRP.png¿Cuál es el fondo de QinQ?

En una red de capa 2, un switch agrega una etiqueta VLAN a los paquetes para aislar dominios de difusión; sin embargo, el IEEE 802.1Q sólo finaliza 4096 ID de VLAN. Las ID de VLAN de 4096 son insuficientes. Para resolver este problema, se utiliza la tecnología Qinq. La tecnología Qinq, definida por IEEE 802.1ad encapsula las etiquetas de doble VLAN a los paquetes, expandiendo el espacio de VLAN a 4096x4096.

                061306gfilhif65i4h5f6o.png?VRRP.png

060603gkd13djnrwzwj9r3.png?VRRP.png¿Los switches de la serie S soportan QinQ? ¿Cómo se implementa QinQ?

Los switches de baja gama Except de S2300EI&SI y S2700EI&SI, los switches de la serie S de other de todas las versiones soportan QinQ.

QinQ cae en QinQ básico y QinQ selectivo.

QinQ básico

QinQ básico, también llamado QinQ común, se implementa en base a interfaces. Es decir, se agrega una etiqueta VLAN a todos los paquetes que pasan por una interfaz.

Los paquetes de VLAN 10, VLAN 20 y VLAN 30 llegan a la salida del dispositivo de agregación y se etiquetan con 100 de VLAN. Los paquetes que se transmiten en la red pública llevan etiquetas de VLAN dobles. Los paquetes se transmiten en la VLAN especificada por la etiqueta externa, y la etiqueta VLAN interna se transmite como datos en paquetes. (¿El switch aprende la dirección MAC de los paquetes QinQ basados en la etiqueta VLAN externa o interna? La pregunta será respondida más tarde.)

               061219men32kzne5jaoa3w.png?VRRP.png

 QinQ selectivo, también llamado VLAN stacking

El Selective QinQ se implementa en base a ID de VLAN e interfaces. Es decir, el switch sólo agrega una etiqueta VLAN al paquete que pasa a través de una interfaz y coincide con la ID de VLAN especificada.

Los paquetes de VLAN 10, VLAN 20 y VLAN 30 llegan a la salida del dispositivo de agregación y se etiquetan con VLAN 100, VLAN 200 y VLAN 300 respectivamente. Cuando los paquetes de usuario se transmiten en la red pública, los paquetes transportan etiquetas VLAN dobles y se reenvían en las VLAN especificadas por otras etiquetas.

(Respuesta: El switch aprende la dirección MAC de los paquetes QinQ basados en la etiqueta VLAN externa. Esto se debe a que la etiqueta VLAN interna se transmite como los datos en paquetes.)

              062242l1cenpgpvtcegjeq.png?VRRP.png

060613qczem1okjwo2k1ik.png?VRRP.png¿Cómo se configuran QinQ básico y QinQ selectivo?


Tipo

Configuración

Descripción

QinQ básico

port link-type dot1q-tunnel

port default vlan 100

Las   configuraciones en switches fijos y modulares son las mismas.Sólo necesita configurar dos comandos.

"Selective QinQ"

port link-type   hybrid

QinQ vlan-translation enable

port hybrid untagged vlan 100 200   300

port vlan-stacking vlan 10 stack-vlan   100

port vlan-stacking vlan 20 stack-vlan   200

port vlan-stacking vlan 30 to 39   stack-vlan 300

QinQ   vlan-translation enable

El comando   anterior debe configurarse en el switch fijo, pero no en el switch modular.

La configuración   selectiva de QinQ es flexible y el QinQ selectivo se utiliza ampliamente.

       

Pasemos a los escenarios de aplicación de QinQ básico y QinQ selectivo.


QinQ básico

La empresa S quiere conectarse a la red ISP, el carrier asigna VLAN 1000 a la empresa S, y los departamentos de la empresa S pertenecen a diferentes VLAN.

           062337o7g9re7kiazd78o6.png?1.png

"Configuration Roadmap"

Sólo necesita configurar QinQ básico en las interfaces PE conectadas a la CE de la empresa S. El PE etiqueta todos los paquetes de la empresa S con VLAN 1000 sin necesidad de modificar la configuración de la CE.

Dispositivo

Configuración   de GE1/0 / 1

Configuración   de GE1/0 / 2

PE

port link-type   dot1q-tunnel

port default vlan 1000

port link-type   trunk

port trunk allow-pass vlan 1000? 

            Una vez realizada la configuración, los departamentos de la empresa S pueden acceder a la red ISP.

QinQ selectivo

Las empresas A y B se encuentran en diferentes regiones. Los servicios de datos y voz de la empresa A se transmiten en VLAN 10 y VLAN 30 respectivamente. Los servicios de datos y voz de la empresa B también se transmiten en VLAN 10 y VLAN 30 respectivamente. El PE de la red ISP se requiere para transmitir servicios de datos en VLAN 100 y servicios de voz en VLAN 30 Los servicios de datos y voz de las empresas A y B deben ser reenviados correctamente sin cambiar el networking.

            062416miimphlmofich5io.png?2.png

Configuración.

1. Para los servicios de datos en diferentes VLAN, sólo es necesario configurar QinQ selectivo en el PE para que las empresas A y B puedan comunicarse.

2. Para los servicios de voz en la misma VLAN, se debe configurar la transmisión transparente en el PE.

          

Dispositivo

Configuración   de GE1/0 / 1

Configuración   de GE1/0 / 2

PE1.

port link-type hybrid

port hybrid tagged vlan   30

port hybrid untagged vlan   100

 port vlan-stacking vlan 10 stack-vlan 100

port link-type trunk

port trunk allow-pass vlan 30 100  

PE2.

port link-type hybrid

port hybrid tagged vlan   30

port hybrid untagged vlan   100

port vlan-stacking vlan 10 stack-vlan 100

port link-type   trunk

port trunk allow-pass vlan 30 100 30 100

Sugerencia 1: Ejecute el comando port vlan-stacking para configurar QinQ selectivo en GE1/0 / 1 conectado a la CE para que la misma ID de PE-VLAN se agregue a packets desde diferentes VLAN CE. Configure GE1/0 / 2 conectado a la red pública para transmitir paquetes de forma transparente desde la PE-VLAN. No olvide esta configuración.

Sugerencia 2: El GE1/0 / 1 conectado a la CE debe agregarse a la PE-VLAN en modo sin etiquetar. Cuando GE1/0 / 1 envía paquetes etiquetados con 100 VLAN externa, elimina la etiqueta VLAN externa para que la CE pueda procesar correctamente los paquetes.

060655n8z1s07zzxhzs1dd.png?VRRP.pngUna vez finalizada la configuración, las empresas A y B no pueden comunicarse. ¿Por qué?

La causa común es que la VLAN externa no se crea en el PE. Ejecute el comando de resumen display vlan para verificar si existe la VLAN externa 100 y la VLAN 30.

          062431z2kk7jj2j7ypjs6q.png?3.png

060647jbl4lnngjtik6e6b.png?VRRP.pngDespués de que las VLANs se crean globalmente, los servicios de datos pueden ser transmitidos correctamente, pero los servicios de voz no pueden. Es decir, los paquetes de doble etiquetado se pueden transmitir, mientras que los paquetes de una sola etiqueta no pueden.

El problema anterior ocurre a menudo en las tarjetas de la serie SA y los switches fijos de S5300EI/S5700EI y S3300EI&SI/S3700EI y SI. En las tarjetas de la serie SA y los switches fijos de S5300EI/S5700EI y S3300EI&SI/S3700EI&SI se debe configurar el mapeo de VLAN para mapear la VLAN a sí misma desde la cual los paquetes de una sola etiqueta deben ser transmitidos de forma transparente.

En GE1/0 / 1 de PE1 y PE, el comando port vlan-mapping vlan 30 map-vlan 30.

062442gd267vd2l2ved26g.png?4.png

060632fu5lel9uelulltql.png?VRRP.pngLa presentación ha terminado.


Para obtener más detalles sobre otras funciones QinQ tales como QinQ selectivo basado en flujo, visite:

http://support.huawei.com/enterprise/docinforeader.action?contentId=DOC1000049819&idPath=7919710|9856733|7923144|7070015



This post was last edited by Gabo at 2019-01-22 16:30.
  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba