Ejemplo para conectar una stack a un clúster NLB (mediante loopback enlace fisico)

Pubilicado 2019-1-27 16:03:48 64 0 0 0

Visión general

NLB está desarrollado por Microsoft para un clúster configurado por varios servidores de Windows. Cuando un switch está conectado a un clúster NLB, el conmutador debe enviar paquetes destinados a la dirección IP del clúster a cada servidor NLB en el clúster. Un servidor NLB puede funcionar en modo de unicast, multicast, o IGMP multicast.

 

Actualmente, se puede conectar un switch al servidor NLB que funciona solo en modo de unicast o multicast. Si el conmutador admite ARP de interfaz múltiple, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el conmutador o la versión no son compatibles con ARP de interfaz múltiple y no hay suficientes recursos en el dispositivo, puede usar el enlace de enlace físico para conectar el switch al clúster NLB.

 

Notas de configuración

 

·         Cuando el clúster NLB funciona en modo de unicast, las entradas ARP estáticas no necesitan configurarse en el conmutador; cuando el clúster funciona en modo de multicast, las entradas ARP estáticas deben configurarse en el switch.

 

·         Una gateway virtual VRRP no se puede configurar en un switch en stack para clientes.

 

·         La Tabla 1 enumera los productos y versiones aplicables.

 

Tabla 1 Modelos de producto aplicables y versiones.

Product

Product Model

Software Version

S2700

S2710SI

V100R006C05

S2700EI

V100R006C05

S2720EI

V200R006C10, V200R009C00, V200R010C00, V200R011C10

S2750EI

V200R003C00, V200R005C00SPC300,   V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00,   V200R011C10

S3700

S3700SI

V100R006C05

S3700EI

V100R006C05

S5700

S5700LI

V200R001C00, V200R002C00, V200R003(C00&C02&C10),   V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00,   V200R010C00, V200R011C00, V200R011C10

S5700S-LI

V200R008C00, V200R009C00, V200R010C00,   V200R011C00, V200R011C10

S5700SI

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5700EI

V200R001(C00&C01), V200R002C00,   V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00,   V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-C-LI

V200R001C00

S5710-X-LI

V200R008C00, V200R009C00, V200R010C00,   V200R011C00, V200R011C10

S5710EI

V200R001C00, V200R002C00, V200R003C00,   V200R005(C00&C02)

S5710HI

V200R005C03

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00,   V200R011C00, V200R011C10

S5720EI

V200R007C00, V200R008C00, V200R009C00,   V200R010C00, V200R011C00, V200R011C10

S5720HI

V200R009C00, V200R010C00, V200R011C00, V200R011C10

S6700

S6700EI

V200R001(C00&C01), V200R002C00,   V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10

S6720SI and S6720S-SI

V200R011C00, V200R011C10

S6720EI

V200R008C00, V200R009C00, V200R010C00,   V200R011C00, V200R011C10

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10

 

 

060238sclvrolnmnnqnnuo.png?image.png

Para obtener más información sobre las asignaciones de software, consulte Búsqueda de asignación de versión para los switches de campus de Huawei.

 

Requisitos de red

 

Como se muestra en la Figura 1, Switch_1 y Switch_2 forman un stack y están conectados directamente a dos servidores NLB, respectivamente, a través de GE0 / 0/1 y GE1 / 0/1. El clúster NLB funciona en modo de multicast, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 03bf-0a80-f6fc. Hay rutas accesibles entre el Switch y el Cliente.

 

El cliente requiere que el stack pueda enviar los paquetes del Cliente destinados a la dirección IP del clúster NLB a todos los servidores NLB.

 

Figura 1 Conexión de un stack a un clúster NLB en modo de multicast.

060246trqfh86r49ole9ei.png?image.png

 

 

 

 

 

 

Plan de datos

 

Antes de la configuración, necesita los siguientes datos.

 

 

Item

Datos

Descripcion

Direccion IP

VLANIF200: 10.128.246.250/24

-

 

 

Mapa de configuración

 

La ruta de configuración es la siguiente:

 

1. Agregue GE0 / 0/1 y GE1 / 0/1 que están directamente conectados a los servidores NLB a la VLAN 100.

 

2. Agregue GE0 / 0/4 y GE1 / 0/4 a Eth-Trunk 4, y GE0 / 0/5 y GE1 / 0/5 a Eth-Trunk 5.

 

3. Desactive STP, RSTP, VBST o MSTP en Eth-Trunk 4 y Eth-Trunk 5, y agregue Eth-Trunk 4 y Eth-Trunk 5 a VLAN 100 y VLAN 200 respectivamente en el modo de acceso.

 

4. Configure una dirección IP para VLANIF 200 que funcione como gateway del clúster NLB.

 

5. Configure una entrada ARP estática. En la entrada ARP estática, la dirección IP es la dirección IP del clúster, la dirección MAC es la dirección MAC multicast del clúster y la interfaz de salida es la interfaz donde está configurada la VLAN a la que pertenece el gateway del clúster NLB.

 

6. Conecte GE0 / 0/4 y GE0 / 0/5, así como GE1 / 0/4 y GE1 / 0/5.

 

Procedimiento

 

Paso 1 Agregue las interfaces directamente conectadas a los servidores NLB a la VLAN 100.

 

# Agregue GE0 / 0/1 a la VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Stack 
[Stack] vlan batch 100 200 
[Stack] interface gigabitethernet 0/0/1 
[Stack-GigabitEthernet0/0/1] port link-type access  
[Stack-GigabitEthernet0/0/1] port default vlan 100 
[Stack-GigabitEthernet0/0/1] quit 

 

# Agregue GE1 / 0/1 a la VLAN 100.

[Stack] interface gigabitethernet 1/0/1 
[Stack-GigabitEthernet1/0/1] port link-type access  
[Stack-GigabitEthernet1/0/1] port default vlan 100 
[Stack-GigabitEthernet1/0/1] quit 

Paso 2 Añadir interfaces a Eth-Trunks

# Agregue GE0 / 0/4 y GE1 / 0/4 a Eth-Trunk 4.

[Stack] interface eth-trunk 4 
[Stack-Eth-Trunk4] quit 
[Stack] interface gigabitethernet 0/0/4 
[Stack-GigabitEthernet0/0/4] eth-trunk 4 
[Stack-GigabitEthernet0/0/4] quit 
[Stack] interface gigabitethernet 1/0/4 
[Stack-GigabitEthernet1/0/4] eth-trunk 4 
[Stack-GigabitEthernet1/0/4] quit

# Agregue GE0 / 0/5 y GE1 / 0/5 a Eth-Trunk 5.

[Stack] interface eth-trunk 5 
[Stack-Eth-Trunk5] quit 
[Stack] interface gigabitethernet 0/0/5 
[Stack-GigabitEthernet0/0/5] eth-trunk 5 
[Stack-GigabitEthernet0/0/5] quit 
[Stack] interface gigabitethernet 1/0/5 
[Stack-GigabitEthernet1/0/5] eth-trunk 5 
[Stack-GigabitEthernet1/0/5] quit

Paso 3 Configure Eth-Trunk 4 y Eth-Trunk 5.

 

# Deshabilite STP, RSTP, VBST o MSTP en Eth-Trunk 4 y Eth-Trunk 5.

[Stack] interface eth-trunk 4 
[Stack-Eth-Trunk4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Stack-Eth-Trunk4] quit 
[Stack] interface eth-trunk 5 
[Stack-Eth-Trunk5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Stack-Eth-Trunk5] quit 

# Agregue Eth-Trunk 4 y Eth-Trunk 5 a VLAN 100 y VLAN 200 respectivamente en el modo de acceso.

[Stack] interface eth-trunk 4 
[Stack-Eth-Trunk4] port link-type access 
[Stack-Eth-Trunk4] port default vlan 100 
[Stack-Eth-Trunk4] quit 
[Stack] interface eth-trunk 5 
[Stack-Eth-Trunk5] port link-type access 
[Stack-Eth-Trunk5] port default vlan 200 
[Stack-Eth-Trunk5] quit

 

Paso 4 Configure una dirección IP para el gateway del clúster NLB.

[Stack] interface vlanif 200 
[Stack-Vlanif200] ip address 10.128.246.250 24 
[Stack-Vlanif200] quit 

Paso 5 Configure una entrada ARP estática. En la entrada de ARP estática, la dirección IP es la dirección IP del clúster 10.128.246.252, la dirección MAC es la dirección MAC multicast del clúster 03bf-0a80-f6fc, y la interfaz de salida es Eth-Trunk 5 en la VLAN 200.

[Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5   //Configure a static ARP entry

Paso 6 Conecte GE0 / 0/4 y GE0 / 0/5 en Switch_1, y GE1 / 0/4 y GE1 / 0/5 en Switch_2.

 

Después de las configuraciones anteriores, conecte enlaces físicos.

 

Paso 7 Verificar la configuración.

Verifique que Server_1 y Server_2 puedan recibir paquetes destinados a la dirección IP del clúster NLB.

 

Archivos de configuración

Archivo de configuración del stack


sysname Stack 

vlan batch 100 200 
#                                                                                
interface Vlanif200                                                              
 ip address 10.128.246.250 255.255.255.0                                         

interface Eth-Trunk4                                                             
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#                                                                                 
interface Eth-Trunk5                                                             
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#                                                                                 
interface GigabitEthernet0/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                
#  
interface GigabitEthernet0/0/4 
 eth-trunk 4 
#  
interface GigabitEthernet0/0/5 
 eth-trunk 5 
#  
interface GigabitEthernet1/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                 
#                                                                                
interface GigabitEthernet1/0/4                                                  
 eth-trunk 4                                                                     
#                                                                                
interface GigabitEthernet1/0/5                                                  
 eth-trunk 5                                                                     

arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5  

return 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba