Interfuncionamiento y Guía de Reemplazo DTP.

Publicado 2019-1-27 16:00:58 82 0 0 0

1.1 Resumen del protocolo

 

Huawei LNP

 

El Protocolo de negociación de tipo de enlace (LNP) negocia dinámicamente si una interfaz Ethernet es la interfaz de acceso o troncal. Los switches de la serie Huawei S admiten LNP a partir de V200R005.

 

Tabla 1-1 Negociación de LNP.

Tipo de enlace local

Tipo de enlace remoto o estado    de negociación

Tipo de enlace negociado    localmente

Estado final de la interfaz    remota

Negociación-deseable   / Negociación-auto

Acceso (negociación   LNP habilitada)

Access

Access

Híbrido (negociación   LNP habilitada)

Trunk

Hybrid

Dot1q-tunnel (negociación LNP habilitada)

Access

Dot1q-tunnel

Tronco (negociación   LNP habilitada)

Trunk

Trunk

Negociación LNP no soportada o deshabilitada

Access

Uncertain

Negociación-deseable

Negociación-deseable

Trunk

Trunk

Negociación-deseable

Negociación-auto

Trunk

Trunk

Negociación-auto

Negociación-auto

Access

Access

 

NOTA:

• El nombre de dominio VCMP afecta a la negociación LNP. Una interfaz troncal se negocia solo cuando los nombres de dominio en ambos extremos de un enlace son consistentes o el nombre de dominio de al menos un extremo está vacío; De lo contrario, se negocia una interfaz de acceso.

 

• La interfaz Ethernet que se negocia como una interfaz de acceso se une a la VLAN 1 de manera predeterminada. La interfaz Ethernet que se negocia como una interfaz troncal permite a todas las VLAN de forma predeterminada.

Cisco DTP

 

El Protocolo de enlace dinámico (DTP) negocia dinámicamente si una interfaz Ethernet es el acceso o la interfaz troncal.

 

Table 1-2 DTP negotiation

Tipo de    enlace configurado de una interfaz

Tipo de    enlace negociado de una interfaz

Acceso al modo switchport

La   interfaz está configurada para trabajar en modo de acceso por la fuerza.

Switchport modo dinámico automático

Si la   interfaz remota funciona en modo troncal o deseable, la interfaz local   funciona en modo troncal mediante negociación.

Puerto modo dinámico deseable

Si la   interfaz remota funciona en modo troncal, deseable o automático, la interfaz   local funciona en modo troncal mediante negociación.

Modo puerto troncal

La   interfaz está configurada para trabajar en modo troncal por la fuerza.

Switchport no negociado

Este   comando se usa para permitir que la interfaz no envíe paquetes DTP, y se   puede usar solo en la interfaz en modo troncal o de acceso.

 

·         Los dispositivos en ambos extremos deben tener el mismo nombre de dominio VTP para garantizar una negociación DTP exitosa.

·         DTP es compatible con el Inter-Switch Link (ISL) y el IEEE 802.1Q. ISL es un protocolo de encapsulación propietario de Cisco e IEEE 802.1Q es un protocolo estándar.

 

1.2 Comparación de implementación

 

Tabla 1-3 Soporte de funciones.

Función

Huawei S Series Switches

Cisco Switches

Habilitar o   deshabilitar la negociación automática global del tipo de enlace de una   interfaz

Soportado

No soportado

Habilitar o   deshabilitar la negociación automática del tipo de enlace de una interfaz

La   autonegociación global del tipo de enlace de una interfaz está habilitada de   forma predeterminada.

Soportado

Negociando   dinámicamente el tipo de enlace.

Para   dispositivos como los dispositivos de acceso que no requieren negociación   dinámica, LNP puede deshabilitarse globalmente. Una vez que se deshabilita   LNP, el dispositivo deja de enviar paquetes LNP. Por lo tanto, la carga de   red se reduce.

Consulte la   documentación de Cisco.

Entrega de   información de VLAN sobre una interfaz basada en el resultado de la   negociación después de que el tipo de enlace se negocia dinámicamente

Soportado

Soportado

Mostrar   información de negociación sobre el tipo de enlace de una interfaz

La   negociación automática del tipo de enlace de una interfaz está habilitada de   forma predeterminada.

Soportado

Recuperación   automática del estado del enlace negociado dinámicamente después de la   conmutación activa / en espera

Soportado

Soportado

 

Tabla 1-4 Diferencias en  comandos.

Función

Comandos en Huawei S Series Switches

Comandos en  Cisco    Switches

Configure el   modo de negociación dinámica del enlace como automático.

port link-type   negotiation-auto

switchport mode   dynamic auto

Configure el   modo de negociación dinámica del enlace como deseable.

port link-type   negotiation-desirable

switchport mode   dynamic desirable

Eliminar una   interfaz de una VLAN en modo de negociación. Por ejemplo, eliminar una   interfaz de VLAN 10.

No se utiliza ningún comando para eliminar una interfaz de la VLAN 10.   Puede especificar las VLAN a las que se pueden agregar las interfaces.

port trunk allow-pass only-vlan 1 to 9 11 to 4094

switchport trunk   allowed vlan remove 10

Desactivar   la autonegociación de una interfaz.

port negotiation   disable

switchport   nonegotiate

Deshabilitar LNP global.

lnp disable

Not supported

Modificar el   modo de encapsulación de paquetes.

Huawei solo admite encapsulación basada en el protocolo estándar, sin   ninguna configuración.

switchport trunk   encapsulation dot1q

 

1.3 Análisis de soluciones de inter funcionamiento y reemplazo.

 

DTP y LNP son protocolos propietarios, por lo que no pueden inter funcionar. Los dos protocolos pueden reemplazarse entre sí. Hay dos soluciones disponibles:

 

·         Reemplazo en toda la red: todos los switches DTP de Cisco son reemplazados por los switches de la serie S de Huawei que admiten LNP.

 

·         Reemplazo único: un switch Cisco se reemplaza por un switch de la serie S de Huawei. El interruptor remoto sigue siendo un interruptor de Cisco. En esta situación, debe configurar la interfaz del switch Cisco remoto para que funcione en modo de no negociación.

 

1.3.1 Solución de reemplazo en toda la red

Visión general

 

El reemplazo en toda la red indica que todos los switches DTP de Cisco se reemplazan por los switches de la serie S de Huawei que admiten LNP. A continuación se describe la configuración de Huawei LNP.

 

Notas de configuración

 

·         Este ejemplo se aplica a los switches de la serie S de Huawei de V200R005 y versiones posteriores.

 

·         En los switches de la serie S de Huawei, LNP se usa globalmente y en las interfaces de forma predeterminada. La interfaz que se negocia como una interfaz de acceso se une a la VLAN 1 de forma predeterminada, y la interfaz que se negocia como una interfaz troncal se une a todas las VLAN de forma predeterminada. En general, solo necesita cambiar la configuración de VLAN en una interfaz basada en la red.

 

Requisitos de red

 

En la Figura 1-1, los usuarios del terminal están conectados a la red a través de swithces. Para implementar la conectividad de Capa 2, configure el tipo de enlace en cada interfaz y agregue interfaces a las VLAN. Si la escala de la red es grande, la configuración es muy compleja. Para simplificar las configuraciones, los switches se conectan a través del enlace troncal, y los switches y terminales de usuario se conectan a través de enlaces de acceso y se agregan a las VLAN.

 

Figura 1-1 Conexión en red para configurar LNP para implementar la negociación automática del tipo de enlace de una interfaz Ethernet.

 

055607mw4r420jj8r0nj8o.png?image.png

 

Mapa de configuración

 

1. Habilite LNP en la vista del sistema y la vista de la interfaz para implementar la negociación automática del tipo de enlace de una interfaz. Debido a que las PC no son compatibles con LNP, las interfaces de switch conectadas a los terminales se utilizan como interfaces de acceso y las interfaces entre switch se utilizan como interfaces troncales a través de la negociación.

 

2. Agregue interfaces a las VLAN para implementar la conectividad de Capa 2.

 

Procedimiento

 

Paso 1 Habilitar LNP global.

 

Por defecto, el LNP global está habilitado. Si LNP está deshabilitado, ejecute el comando undo lnp disable en la vista del sistema para habilitarlo.

 

 Paso 2 Crear VLANs.

 

Los switches de la serie S de Huawei admiten dos modos de creación de VLAN:

 

·         Crear manualmente las VLAN en los switches.

 

·         Cree VLAN solo en Switch3 y configure VCMP para sincronizar VLAN en Switch3 con otros switches. Si se usa VCMP para crear VLAN, configure Switch3 como el servidor VCMP y Switch1 y Switch2 como clientes VCMP. Para más detalles, consulte "Configuración de VCMP".

A continuación se describe cómo crear VLAN manualmente.

# Cree VLAN 10 y VLAN 20 en Switch1, Switch2 y Switch3.

<HUAWEI> system-view 
[HUAWEI] sysname Switch1 
[Switch1] vlan batch 10 20

<HUAWEI> system-view 
[HUAWEI] sysname Switch2 
[Switch2] vlan batch 10 20

<HUAWEI> system-view 
[HUAWEI] sysname Switch3 
[Switch3] vlan batch 10 20

Paso 3 Habilite LNP en las interfaces, y agregue las interfaces de switch conectadas a las PC a las VLAN como interfaces de acceso e interfaces entre los switches a las VLAN como interfaces troncales.

 

De forma predeterminada, LNP en una interfaz está habilitado. Si LNP está deshabilitado, ejecute el comando para deshacer la negociación del puerto en la vista de la interfaz para habilitarlo.

 

# Configurar Switch1.

[Switch1] interface GigabitEthernet 1/0/1 
[Switch1-GigabitEthernet1/0/1] port default vlan 10   
[Switch1-GigabitEthernet1/0/1] quit 
[Switch1] interface GigabitEthernet 1/0/2 
[Switch1-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20   
[Switch1-GigabitEthernet1/0/2] quit 
[Switch1] interface GigabitEthernet 1/0/3 
[Switch1-GigabitEthernet1/0/3] port default vlan 20 
[Switch1-GigabitEthernet1/0/3] quit

# Configurar Switch2.

[Switch2] interface GigabitEthernet 1/0/1 
[Switch2-GigabitEthernet1/0/1] port default vlan 10 
[Switch2-GigabitEthernet1/0/1] quit 
[Switch2] interface GigabitEthernet 1/0/2 
[Switch2-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20 
[Switch2-GigabitEthernet1/0/2] quit 
[Switch2] interface GigabitEthernet 1/0/3 
[Switch2-GigabitEthernet1/0/3] port default vlan 20 
[Switch2-GigabitEthernet1/0/3] quit

# Configurar Switch3.

[Switch3] interface GigabitEthernet 1/0/1 
[Switch3-GigabitEthernet1/0/1] port trunk allow-pass only-vlan 10 20 
[Switch3-GigabitEthernet1/0/1] quit 
[Switch3] interface GigabitEthernet 1/0/2 
[Switch3-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20 
[Switch3-GigabitEthernet1/0/2] quit

Paso 4 Verificar la configuración.

 

Una vez completada la configuración anterior, ejecute el comando display lnp interface interface-type interface-number para verificar la negociación automática en la interfaz de Capa 2 especificada.

[Switch1] display lnp interface gigabitethernet1/0/2 
LNP information for GigabitEthernet1/0/2: 
  Port link type: trunk 
  Negotiation mode: desirable 
  Hello timer expiration(s): 7 
  Negotiation timer expiration(s): 0 
  Trunk timer expiration(s): 278 
  FSM state: trunk 
 
  Packets statistics 
  56 packets received 
    0 packets dropped 
      bad version: 0, bad TLV(s): 0, bad port link type: 0, 
      bad negotiation state: 0, other: 0 
  58 packets output 
    0 packets dropped 
      other: 0

Ejecute el comando display lnp summary para verificar la información de negociación automática en todas las interfaces del dispositivo de Capa 2.

[Switch1] display lnp summary 
Global LNP : Negotiation enable 
------------------------------------------------------------------------------- 
C: Configured; N: Negotiated; *: Negotiation disable; 
Port         link-type(C)   link-type(N)   InDropped   OutDropped  FSM          
------------------------------------------------------------------------------- 
GE1/0/1      desirable      access         0           0           access 
GE1/0/2      desirable      trunk          0           0           trunk 
GE1/0/3      desirable      access         0           0           access

Archivos de configuracion.

Switch1:

 


sysname Switch1 

vlan batch 10 20 

interface GigabitEthernet1/0/1 
 port default vlan 10 

interface GigabitEthernet1/0/2 
 port trunk allow-pass only-vlan 10 20 

interface GigabitEthernet1/0/3 
 port default vlan 20 

return

Switch2:

 


sysname Switch2 

vlan batch 10 20 

interface GigabitEthernet1/0/1 
 port default vlan 10 

interface GigabitEthernet1/0/2 
 port trunk allow-pass only-vlan 10 20 

interface GigabitEthernet1/0/3 
 port default vlan 20 

return

l   Switch3:

 


sysname Switch3 

vlan batch 10 20 

interface GigabitEthernet1/0/1 
 port trunk allow-pass only-vlan 10 20 

interface GigabitEthernet1/0/2 
 port trunk allow-pass only-vlan 10 20 

return

1.3.2 Solución de reemplazo de un solo dispositivo

 

Al reemplazar un solo dispositivo, debe configurar la interfaz conectada del dispositivo Cisco como no negociación.

 

Notas de configuración

 

·         Este ejemplo se aplica a todas las versiones de los switches de la serie S.

 

·         Durante el interfuncionamiento y la sustitución de los switches Cisco y los switches de la serie S de Huawei, el modo de encapsulación debe ser IEEE 802.1Q.

 

Requisitos de red

 

En la Figura 1-2, tres dispositivos Cisco utilizan DTP para negociar dinámicamente tipos de enlace de interfaces. Un dispositivo es reemplazado por un switch de la serie S de Huawei, y los tres switches necesitan implementar la conectividad de Capa 2.

 

Figura 1-2 Interfuncionamiento de switches de la serie S de Huawei y switches de Cisco.

055630kalattal8qq8laju.png?image.png

 

Mapa de configuración

 

1. Configure manualmente los tipos de enlace de las interfaces. El DTP en los switches Cisco y el LNP en los switches de la serie Huawei S son protocolos propietarios y no pueden interfuncionar. Cuando los switches de la serie S de Huawei están conectados a los switches Cisco, el tipo de enlace de una interfaz no se puede negociar de forma dinámica.

 

2. Configure manualmente los tipos de enlace de las interfaces en dos switches como troncal y especifique el modo de encapsulación de paquetes en los switches Cisco como IEEE 802.1Q.

 

Procedimiento

 

 Paso 1 Cambie manualmente el tipo de enlace de Fa0/2 en el switch Cisco al troncal. La configuración de dos switches Cisco es la misma.

CiscoA# configure terminal 
CiscoA(config)# interface fastEthernet 0/2 
CiscoA(config-if)# switchport trunk encapsulation dot1q 
CiscoA(config-if)# switchport mode trunk 

Paso 2 Configure el tipo de enlace de la interfaz en el switch de la serie Huawei S como troncal.

<Huawei> system-view 
[Huawei] interface GigabitEthernet1/0/2 
[Huawei-GigabitEthernet1/0/2] port link-type trunk 
[Huawei-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 4094   

Paso 3 Verificar la configuración.

·         Ejecute el comando show interfaces fastEthernet 0/2 para verificar si el campo de tipo de enlace en el switch de Cisco es modo: troncal.

 

·         Ejecute el comando display interface gigabitethernet 1/0/2  de la interfaz para verificar si el tipo de enlace en el switch de Cisco es tipo troncal (configurado).

 

 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba