Ejemplo para conectar el AR al Firewall a través de VRRP

Pubilicado 2019-1-24 15:52:30 51 0 0 0

Topología de laboratorio



155047o66tpcbnlclmqt64.png?image.png

Mapa de configuración

 

1.       Configure el VRRP en los AR y configure la dirección IP virtual de 10.1.1.254/24.

2.       Agregue la interfaz Layer 2 del firewall a la misma VLAN y configure la dirección IP de 10.1.1.3/24 para la interfaz VLANIF.

3.       Agregue las interfaces físicas del firewall y la interfaz VLANIF a una zona y configure una política interzonal.

4.       Configure una ruta estática en la que la dirección del siguiente salto sea la dirección IP virtual del VRRP. Cuando se termina el enlace de AR1 o AR2 al firewall, los servicios se pueden cambiar al otro enlace.

 

Archivos de configuración

 

Archivo de configuración AR1

interface GigabitEthernet0/0/0

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 ip address 10.1.1.1 255.255.255.0

 vrrp vrid 1 virtual-ip 10.1.1.254   

vrrp vrid 1 priority 120   

 

Archivo de configuración AR2

interface GigabitEthernet0/0/0

 ip address 192.168.1.2 255.255.255.0

#

interface GigabitEthernet0/0/2

 ip address 10.1.1.2 255.255.255.0

 vrrp vrid 1 virtual-ip 10.1.1.254 

 vrrp vrid 1 preempt-mode timer delay 20 

 

Archivo de configuración de Firewall

 

interface Vlanif2

ip address 10.1.1.3 255.255.255.0

#

interface GigabitEthernet0/0/1

 portswitch      //Switch Layer 3 interfaces of the firewall to Layer 2 interfaces.

 port link-type access

 port access vlan 2

#

interface GigabitEthernet0/0/2

 portswitch

 port link-type access

 port access vlan 2

#

interface GigabitEthernet0/0/3

 ip address 2.2.2.1 255.255.255.0

#

firewall zone trust

 set priority 85

 add interface GigabitEthernet0/0/1

 add interface GigabitEthernet0/0/2

 add interface Vlanif2

#

firewall zone untrust

 set priority 5

 add interface GigabitEthernet0/0/3

# ip route-static 192.168.1.0 255.255.255.0 10.1.1.254

ip route-static 0.0.0.0 0.0.0.0 2.2.2.2

 

Verificación de resultados

 

[AR1]display vrrp

  GigabitEthernet0/0/1 | Virtual Router 1

    State : Master

    Virtual IP : 10.1.1.254

    Master IP : 10.1.1.1

    PriorityRun : 120

    PriorityConfig : 120

    MasterPriority : 120

    Preempt : YES   Delay Time : 0 s

    TimerRun : 1 s

    TimerConfig : 1 s

    Auth type : NONE

    Virtual MAC : 0000-5e00-0101

    Check TTL : YES

    Config type : normal-vrrp

    Backup-forward : disabled

    Create time : 2015-03-23 19:15 UTC-08:00

    Last change time : 2015-03-23 19:15 UTC-08:00


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba