Ejemplo para conectar un grupo VRRP a un clúster NLB (utilizando Physical Link Loopback)

Pubilicado 2019-1-21 20:45:09 33 0 0 0

Visión general

NLB es desarrollado por Microsoft para un cluster configurado por múltiples servidores Windows. Cuando un switch está conectado a un clúster NLB, el switch necesita enviar paquetes destinados a la dirección IP del clúster a cada servidor NLB del clúster. Un servidor NLB puede trabajar en modo unicast, multicast o IGMP multicast.

En la actualidad, se puede conectar un switch al servidor NLB que trabaja solo en modo unicast o multicast. Si el switch soporta ARP multiinterfaz, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el switch o la versión no admite ARP multiinterfaz y no hay suficientes recursos de dispositivo, puede utilizar el bucle de enlace físico para conectar el conmutador al clúster NLB.

Notas de configuración

l   Cuando el cluster NLB funciona en modo unicast, las entradas ARP estáticas no necesitan ser configuradas en el switch; cuando el cluster funciona en modo multicast, las entradas ARP estáticas deben ser configuradas en el switch.

l   La Tabla 1 enumera los productos y versiones aplicables.

Tabla 1Modelos y versiones de producto aplicables

Producto

Product Model.

Versión de software

S1700.

S1720GW y S1720GWR

"V200R010C00",   "V200R011C00", "V200R011C10"

S1720GW-E   y S1720GWR-E

"V200R010C00",   "V200R011C00", "V200R011C10"

S1720X y S1720X-E

V200R011C00 y   V200R011C10

S2700.

S2720EI.

V200R011C10.

S3700.

S3700EI.

V100R006C05.

S3700HI.

V200R001C00.

S5700.

S5700EI.

"V200R001   (C00&C01"), V200r002c00, V200r003c00, "V200R005"   ("C00&C01&C02&C03")

S5700HI.

V200R001   (C00&C01, V200r002c00, V200r003c00, V200R005 (C00SPC500&C01 y C02

S5710EI.

"V200R001C00",   "V200R002C00", "V200R003C00", "V200R005"   ("C00&C02)")

S5710HI.

V200R003C00 y V200R005   ("C00&C02&C03")

S5720LI y S5720S-LI

"V200R010C00",   "V200R011C00", "V200R011C10"

S5720SI y S5720S-SI

"V200R008C00",   "V200R009C00", "V200R010C00", "V200R011C00",   "V200R011C10"

S5720EI.

"V200R007C00",   "V200R008C00", "V200R009C00", "V200R010C00",   "V200R011C00", "V200R011C10"

S5720HI.

"V200R006C00",   V200r007 ("C00&C10"), "V200R008C00",   "V200R009C00", "V200R010C00", "V200R011C00",   "V200R011C10"

S6700.

S6700EI.

V200R001   (C00&C01, V200r002c00, V200r003c00, V200R005 (C00&C01 y C02)

S6720LI y S6720S-LI

V200R011C00 y   V200R011C10

S6720SI y S6720S-SI

V200R011C00 y   V200R011C10

S6720EI.

"V200R008C00",   "V200R009C00", "V200R010C00", "V200R011C00",   "V200R011C10"

S6720S-EI.

"V200R009C00",   "V200R010C00", "V200R011C00", "V200R011C10"

S7700.

S7703 y S7706 y S7712

"V200R001   (C00&C01"), V200r002c00, V200r003c00, "V200R005C00",   "V200R006C00", "V200R007C00", "V200R008C00", "V200R009C00",   "V200R010C00", "V200R011C10"

S9700.

S9703 y S9706 y S9712

V200R001   (C00&C01, V200r002c00, V200r003c00, "V200R005C00",   "V200R006C00", "V200R007" (C00 y C10) ","   V200r008c00, V200r009c00, "V200R010C00", "V200R011C10"

 

NOTA:


Para obtener más detalles sobre las asignaciones de software, consulte Búsqueda de mapeo de versiones para Campus Switches de Huawei.

Requerimientos de networking

Como se muestra en la Figura 1, el Switch _ 1 y el Switch _ 2 conectan to entre sí utilizando GE0/0 / 2 y forman un grupo VRRP a través del enlace heartbeat. Switch _ 1 es el maestro y Switch _ 2 es copia de seguridad de the. Las interfaces GE0/0 / 1 en Switch _ 1 y Switch _ 2 están conectadas a dos servidores NLB respectivamente. El clúster NLB funciona en modo multicast, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 03bf-0a80-f6fc. Hay rutas accesibles entre el Switch y el Client

El cliente requiere que el grupo VRRP pueda enviar los paquetes de Client destinados a la dirección IP del clúster NLB a todos los servidores NLB.

 

Figura 1Conexión de un grupo VRRP a un clúster NLB en modo multicast


104240jjcwq5zhjpq6xhm5.png?image.png


Plan de datos

Antes de la configuración, necesita los siguientes datos.

Item

Datos

Descripción

Dirección IP

l  VLANIF de Switch _ 1 200   10.128.246.10/24

l  VLANIF de Switch _ 2   200: 10.128.246.11/24

l  Dirección   IP virtual: 10.128.246.250

-

Configuration Roadmap.

El roadmap de configuración es el siguiente:

1.Añadir GE0/0 / 1 a VLAN 100

2.Agregar GE0/0 / 2 a 100 VLAN.

3.Disable STP, RSTP, VBST o MSTP en GE0/0 / 4 y GE0/0 / 5, y agregar interfaces the a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

4.Configure una dirección IP virtual VRRP para VLANIF 200 que funcione como gateway del cluster NLB.

5.Configure una entrada ARP estática. En la entrada ARP estática, la dirección IP es la dirección IP del clúster, la dirección MAC es la dirección MAC multicast del clúster y la interfaz saliente es la interfaz donde se configura la VLAN a la que pertenece el gateway del cluster NLB.

6.Conectar GE0/0 / 4 y GE0/0 / 5.

Procedimiento

"Step 1 # Configure GE0/0 / 1".

# add GE0/0 / 1 on switch _ 1 to VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Switch_1 
[Switch_1] vlan batch 100 200 
[Switch_1] interface gigabitethernet 0/0/1 
[Switch_1-GigabitEthernet0/0/1] port link-type access 
[Switch_1-GigabitEthernet0/0/1] port default vlan 100 
[Switch_1-GigabitEthernet0/0/1] quit 


# add GE0/0 / 1 on switch _ 2 to VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Switch_2 
[Switch_2] vlan batch 100 200 
[Switch_2] interface gigabitethernet 0/0/1 
[Switch_2-GigabitEthernet0/0/1] port link-type access 
[Switch_2-GigabitEthernet0/0/1] port default vlan 100 
[Switch_2-GigabitEthernet0/0/1] quit 


Step 2Add GE0/0 / 2 a VLAN 100

# add GE0/0 / 2 on switch _ 1 to VLAN 100.

[Switch_1] interface gigabitethernet 0/0/2 
[Switch_1-GigabitEthernet0/0/2] port link-type trunk  
[Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 
[Switch_1-GigabitEthernet0/0/2] quit 


# add GE0/0 / 2 on switch _ 2 to VLAN 100.

[Switch_2] interface gigabitethernet 0/0/2 
[Switch_2-GigabitEthernet0/0/2] port link-type trunk  
[Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 
[Switch_2-GigabitEthernet0/0/2] quit 


 

NOTA:


Las interfaces Heartbeat no pueden pertenecer a la misma VLAN que el gateway para evitar un bucle de tráfico dentro del grupo VRRP. Por ejemplo, el GE0/0 / 2 de este ejemplo no se puede agregar a 200 de VLAN.

Step 3Configure GE0/0 / 4 y GE0/0 / 5.

# deshabilitar STP, RSTP, VBST o MSTP en GE0/0 / 4 y GE0/0 / 5 en switch _ 1.

[Switch_1] interface gigabitethernet 0/0/4 
[Switch_1-GigabitEthernet0/0/4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_1-GigabitEthernet0/0/4] quit 
[Switch_1] interface gigabitethernet 0/0/5 
[Switch_1-GigabitEthernet0/0/5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_1-GigabitEthernet0/0/5] quit

# Añadir GE0/0 / 4 y GE0/0 / 5 en Switch _ 1 a VLAN 100 y VLAN 200, respectivamente, modo de acceso in.

[Switch_1] interface gigabitethernet 0/0/4 
[Switch_1-GigabitEthernet0/0/4] port link-type access 
[Switch_1-GigabitEthernet0/0/4] port default vlan 100 
[Switch_1-GigabitEthernet0/0/4] quit 
[Switch_1] interface gigabitethernet 0/0/5 
[Switch_1-GigabitEthernet0/0/5] port link-type access 
[Switch_1-GigabitEthernet0/0/5] port default vlan 200 
[Switch_1-GigabitEthernet0/0/5] quit

# deshabilitar STP, RSTP y VBST, o MSTP en GE0/0 / 4 y GE0/0 / 5 en switch _ 2.

[Switch_2] interface gigabitethernet 0/0/4 
[Switch_2-GigabitEthernet0/0/4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_2-GigabitEthernet0/0/4] quit 
[Switch_2] interface gigabitethernet 0/0/5 
[Switch_2-GigabitEthernet0/0/5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP 
[Switch_2-GigabitEthernet0/0/5] quit

# Añadir GE0/0 / 4 y GE0/0 / 5 en Switch _ 2 a VLAN 100 y VLAN 200 respectivamente modo de acceso in.

[Switch_2] interface gigabitethernet 0/0/4 
[Switch_2-GigabitEthernet0/0/4] port link-type access 
[Switch_2-GigabitEthernet0/0/4] port default vlan 100 
[Switch_2-GigabitEthernet0/0/4] quit 
[Switch_2] interface gigabitethernet 0/0/5 
[Switch_2-GigabitEthernet0/0/5] port link-type access 
[Switch_2-GigabitEthernet0/0/5] port default vlan 200 
[Switch_2-GigabitEthernet0/0/5] quit

Step 4 Configure una dirección IP para el gateway del cluster NLB.

# Crear el grupo VRRP 1 en Switch _ 1 y configurar la prioridad VRRP en 120.

[Switch_1] interface vlanif 200 
[Switch_1-Vlanif200] ip address 10.128.246.10 24 
[Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Create VRRP group 1 
[Switch_1-Vlanif200] vrrp vrid 1 priority 120   //Set the VRRP priority to 120 
[Switch_1-Vlanif200] quit

# Crear el grupo VRRP 1 en group y utilizar la prioridad por defecto VRRP 100.

[Switch_2] interface vlanif 200 
[Switch_2-Vlanif200] ip address 10.128.246.11 24 
[Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Create VRRP group 1 
[Switch_2-Vlanif200] quit

l  Configure la dirección IP virtual VRRP 10.128.246.250 para VLANIF 200 que funciona como gateway del cluster NLB.

l  Para reducir la carga de trabajo de la red, se recomienda separar el gateway del cluster NLB de otras gateways.

En este networking, el tráfico desde un switch al clúster NLB pasa a lo largo del enlace heartbeat al conmutador de pares y luego pasa a lo largo de la línea de bucle automático en el conmutador de pares. En este caso, si otros servidores utilizan el mismo gateway que los servidores NLB, otros servidores recibirán tráfico destinado al clúster NLB, causando un aumento de la carga de trabajo de la red. Por ejemplo, los paquetes destinados al clúster NLB de Switch _ 1 pasan a lo largo del enlace heartbeat a Switch _ 2. En Switch _ 2 los paquetes se envían de GE0/0 / 4 a 0/0 / 5 Si VLANIF 200 en Switch _ 2 is también es la puerta de enlace de servidores no NLB, los paquetes se envían a servidores no NLB a través de GE0/0 / 5.

Step 5 Configure entradas ARP estáticas.

# En Switch _ 1 configure una entrada ARP estática. En la entrada ARP, la dirección IP es 10.128.246.252 y la dirección MAC es 03bf-0a80-f6fc, la interfaz saliente es GE0/0 / 5 donde se encuentra la VLAN 200.

[Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

# En Switch _ 2 configure una entrada de ARP estática. En la entrada ARP, la dirección IP es 10.128.246.252 y la dirección MAC es 03bf-0a80-f6fc, la interfaz saliente es GE0/0 / 5 donde se encuentra la VLAN 200.

[Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

Step 6Connect GE0/0 / 4 y GE0/0 / 5.

Después de las configuraciones anteriores, conecte los enlaces físicos en Switch _ 1 y Switch _ 2 respectivamente.

Step 7 Verificar la configuración.

Verificar que Server _ 1 y Server _ 2 puedan recibir paquetes destinados al clúster NLB.

----End

Archivos de configuración

l   Archivo de configuración receive


sysname Switch_1 

vlan batch 100 200 
#                                                                                
interface Vlanif200 
 ip address 10.128.246.10 255.255.255.0  
 vrrp vrid 1 virtual-ip 10.128.246.250 
 vrrp vrid 1 priority 120 
#                                                                                
interface GigabitEthernet0/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                  
#  
interface GigabitEthernet0/0/2                                                  
 port link-type trunk                                                            
 port trunk allow-pass vlan 100                                                  
#                                                                                
interface GigabitEthernet0/0/4                                                 
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5                                                 
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5 
#   
return 


l   Archivo de configuración Switch _ 2


sysname Switch_2 

vlan batch 100 200 
#                                                                                
interface Vlanif200 
 ip address 10.128.246.11 255.255.255.0  
 vrrp vrid 1 virtual-ip 10.128.246.250 
#                                                                                
interface GigabitEthernet0/0/1                                                  
 port link-type access                                                           
 port default vlan 100                                                 
#  
interface GigabitEthernet0/0/2                                                  
 port link-type trunk                                                            
 port trunk allow-pass vlan 100                                                  
#                                                                                
interface GigabitEthernet0/0/4                                                 
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5                                                 
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5 
#   
return 

 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba