Ejemplo de configuración de BGP

Pubilicado 2019-1-17 13:23:05 59 0 0 0

Las conexiones se establecen entre Switch A y Switch B, y entre Switch  B y Switch C. Se requiere que AS 20 no anuncie las rutas anunciadas por AS 10 a AS 30..


024212efpfraavzljwa2w0.png


Procedimiento
Configurar VLANs correspondientes


<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/0
[SwitchA-GigabitEthernet1/0/0] port link-type trunk
[SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/0] quit
[SwitchA] interface gigabitethernet 2/0/0
[SwitchA-GigabitEthernet2/0/0] port link-type trunk
[SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet2/0/0] quit

 

La configuración del Switch B y del Switch C son similares.  


Assign an IP address to each VLANIF interface.

[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ip address 10.1.1.1 24
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 20
[SwitchA-Vlanif20] ip address 192.168.2.1 24
[SwitchA-Vlanif20] quit

 

La configuración del Switch B y Switch C, son similares a la del Switch A.


Configurar EBGP


# Switch A

[SwitchA] bgp 10
[SwitchA-bgp] router-id 172.16.1.1
[SwitchA-bgp] peer 192.168.2.2 as-number 20
[SwitchA-bgp] ipv4-family unicast
[SwitchA-bgp-af-ipv4] network 10.1.1.0 255.255.255.0
[SwitchA-bgp-af-ipv4] quit
[SwitchA-bgp] quit# Configure SwitchB.

[SwitchB] bgp 20
[SwitchB-bgp] router-id 172.16.2.2
[SwitchB-bgp] peer 192.168.2.1 as-number 10
[SwitchB-bgp] peer 192.168.3.2 as-number 30
[SwitchB-bgp] quit# Configure SwitchC.

[SwitchC] bgp 30
[SwitchC-bgp] router-id 172.16.3.3 
[SwitchC-bgp] peer 192.168.3.1 as-number 20
[SwitchC-bgp] quit# Check the routing table of SwitchB.

[SwitchB] display bgp routing-table 10.1.1.0

BGP local router ID : 172.16.2.2
 Local AS number : 20
 Paths:   1 available, 1 best, 1 select
 BGP routing table entry information of 10.1.1.0/24:
 From: 192.168.2.1 (172.16.1.1)
 Route Duration: 00h00m15s
 Direct Out-interface: Vlanif2
Original nexthop: 192.168.2.1

 Qos information : 0x0
 AS-path 10, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255
 Advertised to such 2 peers:
    192.168.2.1
    192.168.3.2

 

# Revisar tabla de enrutamiento del Switch C

[SwitchC] display bgp routing-table

 BGP Local router ID is 172.16.3.3
 Status codes: * - valid, > - best, d - damped,
               h - history,  i - internal, s - suppressed, S - Stale
               Origin : i - IGP, e - EGP, ? - incomplete
 Total Number of Routes: 1
      Network            NextHop        MED        LocPrf    PrefVal Path/Ogn

 *>   10.11.1.0/24        192.168.3.1                           0      20 10i

 

El switch C ha aprendido la ruta de destino del Switch B


# Configurar routing policy en SwitchA para habilitar SwitchB

[SwitchA] route-policy comm_policy permit node 10
[SwitchA-route-policy] apply community no-export
[SwitchA-route-policy] quit# Apply routing policies.

[SwitchA] bgp 10
[SwitchA-bgp] ipv4-family unicast
[SwitchA-bgp-af-ipv4] peer 192.168.2.2 route-policy comm_policy export
[SwitchA-bgp-af-ipv4] peer 192.168.2.2 advertise-community# Check the routing table of SwitchB.

[SwitchB] display bgp routing-table 10.1.1.0

BGP local router ID : 172.16.2.2
 Local AS number : 20
 Paths:   1 available, 1 best, 1 select
 BGP routing table entry information of 10.1.1.0/24:
 From: 192.168.2.1 (172.16.1.1)
 Route Duration: 00h00m33s
 Direct Out-interface: Vlanif20
 Original nexthop: 192.168.2.1
 Qos information : 0x0
 Community:no-export
 AS-path 10, origin igp, MED 0, pref-val 0, valid, external, best, select, activ
e, pre 255
 


Archivos de configuración
Archivo de configuración de Switch A

#
sysname SwitchA
#
vlan batch 10 20
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif20
 ip address 192.168.2.1 255.255.255.0
#
interface GigabitEthernet1/0/0
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet2/0/0
 port link-type trunk
 port trunk allow-pass vlan 20
#
bgp 10
 router-id 172.16.1.1
 peer 192.168.2.2 as-number 20
 #
 ipv4-family unicast
  undo synchronization
  network 10.1.1.0 255.255.255.0
  peer 192.168.2.2 enable
  peer 192.168.2.2 route-policy comm_policy export
  peer 192.168.2.2 advertise-community
#
route-policy comm_policy permit node 10
 apply community no-export
#
returnConfiguration file of SwitchB

#
sysname SwitchB
#
vlan batch 20 30
#
interface Vlanif20
 ip address 192.168.2.2 255.255.255.0
#
interface Vlanif30
 ip address 192.168.3.1 255.255.255.0
#
interface GigabitEthernet2/0/0
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet3/0/0
 port link-type trunk

 port trunk allow-pass vlan 30
#
bgp 20
 router-id 172.16.2.2
 peer 192.168.2.1 as-number 10
 peer 192.168.3.2 as-number 30
 #
 ipv4-family unicast
  undo synchronization
  peer 192.168.2.1 enable
  peer 192.168.3.2 enable
#
returnConfiguration file of SwitchC

#
sysname SwitchC
#
vlan 30
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
#
interface GigabitEthernet3/0/0
 port link-type trunk
 port trunk allow-pass vlan 30
#
bgp 30
 router-id 172.16.3.3
 peer 192.168.3.1 as-number 20
 #
 ipv4-family unicast
  undo synchronization
  peer 192.168.3.1 enable
#
return


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba