Operaciones Comunes de QinQ: Configurando QinQ Selectivo

Publicado 2019-1-11 17:00:58 43 0 0 0

QinQ selectivo, también conocido como VLAN stacking o QinQ stacking, es implementado con base en interfaces y VLANs.

Configure el dispositivo para etiquetar la VLAN 2 en la etiqueta exterior de los paquetes con etiqueta interior de VLANs 100 a 200, etiquetar VLAN 3 como etiqueta exterior en paquetes de VLANs 300 a 400, y transparentemente transmitir paquetes de la VLAN 1000.

 

·        Configure QinQ selectivo en un switch fijo.

# Cree VLAN 2, VLAN 3, y VLAN 1000.

<HUAWEI> system-view

[HUAWEI] vlan batch 2 3 1000

# Configure la interfaz de downlink GE0/0/1.

[HUAWEI] interface gigabitethernet0/0/1

[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid  

[HUAWEI-GigabitEthernet0/0/1] qinq vlan-translation enable   //La traduccion de VLAN debe estar habilitada en el dispositivo fijo.

[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3   //La interfaz une VLAN 2 y VLAN 3 en modo sin etiqueta.

[HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 1000   //La interfaz transmite paquetes etiquetados con la VLAN 1000 de manera transparente.

[HUAWEI-GigabitEthernet0/0/1] port vlan-stacking vlan 100 to 200 stack-vlan 2   //La interfaz agrega VLAN 2 en la etiqueta exterior de los paquetes con etiqueta interior de VLANs 100 a 200.

[HUAWEI-GigabitEthernet0/0/1] port vlan-stacking vlan 300 to 400 stack-vlan 3   //La interfaz agrega VLAN 3 en la etiqueta exterior de los paquetes con etiqueta interior de VLANs 300 a 400.

[HUAWEI-GigabitEthernet0/0/1] port vlan-mapping vlan 1000 map-vlan 1000   //El S5700EI, S3700EI, y S3700SI deben estar configurado para mapear la VLAN a si misma desde donde los paquetes con una sola etiqueta deben ser transmitidos en modo transparente.

[HUAWEI-GigabitEthernet0/0/1] quit

# Configure la interfaz de uplink GE0/0/5 para que transmita paquetes de las VLANs 2,3 y 1000 transparentemente.

[HUAWEI] interface gigabitethernet0/0/5

[HUAWEI-GigabitEthernet0/0/5] port link-type trunk

[HUAWEI-GigabitEthernet0/0/5] port trunk allow-pass vlan 2 3 1000

·        Configure QinQ selectivo en un switch modular.

# Cree VLAN 2, VLAN 3, y VLAN 1000.

<HUAWEI> system-view

[HUAWEI] vlan batch 2 3 1000

# Configure la interfaz de downlink GE1/0/1.

[HUAWEI] interface gigabitethernet1/0/1

[HUAWEI-GigabitEthernet1/0/1] port link-type hybrid

[HUAWEI-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3   //La interfaz une VLAN 2 y VLAN 3 en modo sin etiquetar.

[HUAWEI-GigabitEthernet1/0/1] port hybrid tagged vlan 1000   //La interfaz transmite paquetes etiquetados con la VLAN 1000 de manera transparente.

[HUAWEI-GigabitEthernet1/0/1] port vlan-stacking vlan 100 to 200 stack-vlan 2   //La interfaz agrega VLAN 2 en la etiqueta exterior de los paquetes de con etiqueta interior de VLANs 100 a 200.

[HUAWEI-GigabitEthernet1/0/1] port vlan-stacking vlan 300 to 400 stack-vlan 3   //La interfaz agrega VLAN 3 a la etiqueta exterior de los paquetes con etiqueta interior de VLANs 300 a 400.

[HUAWEI-GigabitEthernet1/0/1] port vlan-mapping vlan 1000 map-vlan 1000   //Las tarjetas ES0D0G24SA00 y ES0D0G24CA00 del S7700, y las tarjetas EH1D2S24CSA0 y EH1D2G24SSA0 del S9700 deben ser configuradas para mapear la VLAN a si misma desde la cual los paquetes de una sola etiqueta deben ser transmitidos de modo transparente.

[HUAWEI-GigabitEthernet1/0/1] quit

# Configure la interfaz de uplink GE2/0/1 para que transmita paquetes de las VLANs 2,3 y 1000 transparentemente.

[HUAWEI] interface gigabitethernet2/0/1

[HUAWEI-GigabitEthernet2/0/1] port link-type trunk

[HUAWEI-GigabitEthernet2/0/1] port trunk allow-pass vlan 2 3 1000

 

 

Para más información: S Series Switches Common Operation Guide


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba