Transmisión transparente de protocolo de Capa 2 basado en QinQ.

Pubilicado 2019-1-10 09:01:57 48 0 0 0

Hola,

Intercambiar el núcleo de Cisco con el equipo de Huawei no es una tarea fácil. Por lo general, un intercambio comienza con el núcleo y luego vas a la rama. Aún debe garantizar la comunicación para protocolos privados o instancias privadas de STP mientras ingresa con nuevos elementos de red en la red troncal. Será un desafío mantener a los dominios STP de LAN conectados y pasar los paquetes PVST + privados por la nueva red troncal.


Me gustaría compartir una manera fácil de pasar paquetes privados a través de una red troncal de múltiples proveedores: Transmisión transparente de protocolo de Capa 2 basada en QinQ.


Transmisión transparente de protocolo de capa 2 puede transmitir de manera transparente paquetes de protocolo de capa 2 desde la red del usuario para la red del ISP. Esto aborda el problema de identidad de red. El procedimiento es el siguiente:


- Después de recibir los paquetes de protocolo de Capa 2 enviados desde CE1, PE1 reemplaza la dirección MAC de destino con una dirección MAC de multidifusión específica. Luego PE1 reenvía los paquetes en la red ISP.

- Los paquetes de protocolo de Capa 2 se reenvían a PE2. PE2 restaura la dirección MAC de destino original de los paquetes y envía los paquetes a CE2.


Para hacer que la comunicación LAN sea privada usaremos la tecnología 802.1Q-in-802.1Q (QinQ). En este caso, los marcos de las etiquetas VLAN privadas se pueden transmitir de forma transparente en la red pública. Una trama transmitida en la red troncal tiene etiquetas dobles 802.1Q (una para la red pública y otra para la red privada), es decir, 802.1Q-in-802.1Q (QinQ).

Topología:


085928vn74u5l5rjdtgzeu.png

Configuración:

PE1(S7706)

 

#                                                                              

vlan batch 10 100                                                           

#                                                                              

stp disable                                                                     

#                                                                              

l2protocol-tunnel pvst+ group-mac 0100-0ccd-cdd0                               

#                                                                                                                          

interface GigabitEthernet2/0/0                                                 

 port link-type dot1q-tunnel                                                   

 port default vlan 100                                                                                                                            

 l2protocol-tunnel pvst+ vlan 100                                              

 l2protocol-tunnel stp vlan 100                                                

#                                                                              

interface GigabitEthernet2/0/1                                                 

 port hybrid tagged vlan 100                                                   

#

 

 

PE2(ME3400)

 

!                                                                              

vlan 10 100     

!                                                                                                                            

interface FastEthernet0/15                                                     

 port-type nni                                                                  

 switchport trunk allowed vlan 100                                             

 switchport mode trunk                                                         

 duplex full                                                                   

!                                                                               

interface FastEthernet0/16                                                     

 port-type nni                                                                 

 switchport access vlan 100                                                    

 switchport mode dot1q-tunnel                                                  

 duplex full                                                                   

 l2protocol-tunnel stp                                                          

!

 

 

P(S7706)

 

#                                                                              

vlan batch 100                                              

#                                                                             

stp disable                                                                    

#                                                                             

interface GigabitEthernet1/0/2                                                  

 port hybrid tagged vlan 100                                                   

#                                                                                                                                                

interface GigabitEthernet1/0/4                                                 

 port hybrid tagged vlan 100                                                   

#

 

CE1(ME3600X)

 

!                                                                              

spanning-tree mode pvst                                                        

spanning-tree loopguard default                                                

spanning-tree extend system-id                                                                                                                                                                     

!                                                                              

vlan 10                                                                                     

!                                                                                                                                                                                                           

interface GigabitEthernet0/21                                                   

 port-type nni                                                                 

 switchport trunk allowed vlan 10                                              

 switchport mode trunk                                                          

 duplex full                                                                   

!

 

CE2   SWITCH(C2960G)

 

!                                                                              

spanning-tree mode pvst                                                         

spanning-tree extend system-id                                                                                              

!                                                                                                              

vlan 10                                                              

!                                                                                                                                                                                                                                                                       

interface GigabitEthernet0/6                                                   

 switchport trunk allowed vlan 10                                               

 switchport mode trunk                                                         

!

 

Resultados:

1.       CE2 es el puente raíz cuando CE1 y CE2 están configurados con la misma prioridad;


085951yk6ijj6i06h6363o.png


2.       El puerto designado de CE2 envía el paquete BPDU y el puerto raíz de CE1 recibió los paquetes BPDU de manera normal;



090020ftopcjwpcpkoszc9.png

090024i04q0q0h0uzz91r9.png


3.       Cambiemos la prioridad de CE1 a 0 y veamos si se convertirá en el puente raíz, lo que demuestra que las BPDU pasan de manera transparente a través de la red


090041j2z2tfb3dnadtzlx.png


4.       El puerto designado de CE1 envía paquetes BPDU y el puerto raíz de CE2 recibe paquetes BPDU de manera normal;


090055f1891kh0eovo9xt9.png

090100p85jor5fysrkf8ky.png

  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba