Problema entre dos enlaces troncales S5700 & AR201.

Pubilicado 2019-1-8 07:22:31 35 0 0 0

No estoy seguro de si se trata de un error en eNSP o no, pero la creación de dos enlaces troncales entre S5700 y AR201 hace que los router-id en OSPF se dupliquen. Apagar un enlace troncal y dejar intacto el otro enlace troncal soluciona el problema. Aquí está mi explicación: cuando el router o el switch intentan enviar un paquete de protocolo OSPF, este lo recupera debido al loop causado por dos troncales al mismo dispositivo. Esto hace que el router o el switch piensen que su propio paquete es enviado por otro dispositivo con router-id de OSPF duplicado.

He creado dos enlaces troncales para redundancia. Ahora estoy pensando en crear en su lugar un canal Ethernet.

Aquí están las configuraciones para su entendimiento:

072043njb2qng0gbketke0.png

Errores:

 

Aug 22 2013 18:47:03-08:00 CE1 %%01OSPF/4/CONFLICT_ROUTERID_INTF(l)[1]:OSPF Route

r id conflict is detected on interface. (ProcessId=200, RouterId=2.1.1.1, AreaId=

0.0.0.0, InterfaceName=Vlanif60, IpAddr=60.60.60.5, PacketSrcIp=60.60.60.5)

 

Aug 22 2013 18:47:09-08:00 CE1 %%01OSPF/4/CONFLICT_ROUTERID_INTF(l)[2]:OSPF Route

r id conflict is detected on interface. (ProcessId=100, RouterId=1.1.1.1, AreaId=

0.0.0.0, InterfaceName=Vlanif50, IpAddr=50.50.50.5, PacketSrcIp=50.50.50.5)

CE1 Configurations:

 

interface Vlanif50

description CE-PE1-Service_1

ip binding vpn-instance SERVICE_1

ip address 50.50.50.5 255.255.255.252

#

interface Vlanif60

description CE-PE1-Service_2

ip binding vpn-instance SERVICE_2

ip address 60.60.60.5 255.255.255.252

#

interface LoopBack0

ip binding vpn-instance SERVICE_1

ip address 1.1.1.1 255.255.255.255

#

interface LoopBack1

ip binding vpn-instance SERVICE_2

ip address 2.1.1.1 255.255.255.255

#

ospf 100 router-id 1.1.1.1 vpn-instance SERVICE_1

area 0.0.0.0

network 1.1.1.1 0.0.0.0 network 50.50.50.4 0.0.0.3

#

ospf 200 router-id 2.1.1.1 vpn-instance SERVICE_2

area 0.0.0.0

network 2.1.1.1 0.0.0.0

network 60.60.60.4 0.0.0.3

#

interface GigabitEthernet0/0/7

description S=CE1#D=PE1

eth-trunk 2

#

interface GigabitEthernet0/0/8

description S=CE1#D=PE1

eth-trunk 2

PE1 Configurations:

ip vpn-instance SERVICE_1

 description SERVICE_1

 ipv4-family

  route-distinguisher 100:1#

ip vpn-instance SERVICE_2

 description SERVICE_2

 ipv4-family

  route-distinguisher 100:2

#

interface Vlanif50

 description PE1-CE1-Service_1

 ip binding vpn-instance SERVICE_1

 ip address 50.50.50.6 255.255.255.252

#

interface Vlanif60

 description PE1-CE1-Service_2

 ip binding vpn-instance SERVICE_2

 ip address 60.60.60.6 255.255.255.252

#

interface Ethernet0/0/0

 description S=PE1#D=CE1

 port link-type trunk

 port trunk allow-pass vlan 50 60

#

interface Ethernet0/0/1

 description S=PE1#D=CE1

 port link-type trunk

 port trunk allow-pass vlan 50 60

#

interface LoopBack0

 ip binding vpn-instance SERVICE_1

 ip address 1.1.1.3 255.255.255.255

#

interface LoopBack1

 ip binding vpn-instance SERVICE_2

 ip address 2.1.1.3 255.255.255.255

#

ospf 100 router-id 1.1.1.3 vpn-instance SERVICE_1

 area 0.0.0.0

  network 1.1.1.3 0.0.0.0

  network 50.50.50.4 0.0.0.3 #

ospf 200 router-id 2.1.1.3 vpn-instance SERVICE_2

 area 0.0.0.0

  network 2.1.1.3 0.0.0.0

  network 60.60.60.4 0.0.0.3

 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
Respuesta rápida Desplácese hasta arriba