De acuerdo

Selección de ruta BGP

14 0 0 0

Hola a todos,


En esta publicación, mostraré cómo seleccionar rutas cuando las longitudes de atributo AS_Path de dos rutas BGP son iguales pero los números de AS son diferentes.


Primero, saquemos una conclusión. Después de configurar el equilibrio de carga BGP en un enrutador Huawei, si el enrutador recibe dos rutas con la misma longitud AS_Path pero diferentes números AS, el equilibrio de carga no se puede implementar entre las dos rutas porque los atributos AS_Path de las dos rutas son diferentes, los enrutadores Huawei no seleccionan la ruta óptima en función del número AS en el atributo AS_Path. En cambio, los enrutadores de Huawei seleccionan la ruta con la ID de enrutador más pequeña según la ID de enrutador del vecino. En V800R009, se agrega el comando load-balancing as-path-relax. Después de ejecutar este comando, las dos rutas con la misma longitud AS_Path pero diferentes números AS se utilizan para el equilibrio de carga.


Topología del experimento


203100rmndr1mcnn9akddk.png


Configuraciones claves



RT01

interface Ethernet1/0/0

undo shutdown

ip address 10.1.2.1 255.255.255.252

interface Ethernet1/0/1

undo shutdown

ip address 10.1.3.1 255.255.255.252

bgp 100

router-id 1.1.1.1

peer 10.1.2.2 as-number 200

peer 10.1.3.2 as-number 300

ipv4-family unicast

undo synchronization

maximum load-balancing 8

peer 10.1.2.2 enable

peer 10.1.3.2 enable

RT02

interface Ethernet1/0/0

undo shutdown

ip address 10.1.2.2 255.255.255.252

bgp 200

router-id 2.2.2.2

peer 10.1.2.1 as-number 100

ipv4-family unicast

undo synchronization

network 192.168.1.0 255.255.255.0

peer 10.1.2.1 enable

ip route-static 192.168.1.0 255.255.255.0 NULL0

RT03

interface Ethernet1/0/1

undo shutdown

ip address 10.1.3.2 255.255.255.252

bgp 300

router-id 3.3.3.3

peer 10.1.3.1 as-number 100

ipv4-family unicast

undo synchronization

network 192.168.1.0 255.255.255.0

peer 10.1.3.1 enable

ip route-static 192.168.1.0 255.255.255.0 NULL0



Observaciones y verificación.


Verifique la tabla de enrutamiento en RT01. Puede encontrar que la ruta 192.168.1.0/24 tiene solo un salto siguiente y no implementa el equilibrio de carga, como se muestra en la siguiente figura.

203101cqw3k88usqqkj8qu.png


En RT01, verifique información detallada sobre la ruta BGP hacia 192.168.1.0/24. La salida del comando muestra que el id de enrutador prefiere la ruta enviada por RT02, como se muestra en la siguiente figura.


203101k9uu91c2l6gk4rhg.png


Para verificar que los dispositivos Huawei solo comparen la ID del enrutador, pero no el número AS. Después de que la ID del router RT02 se cambia a 4.4.4.4, RT01 prefiere la ruta enviada por RT03, como se muestra en la siguiente figura.

203101e64xaw5cc6hcfc5q.png


Después de ejecutar el comando load-balancing as-path-relax en RT01, se utiliza la ruta hacia 192.168.1.0/24 para el equilibrio de carga, como se muestra en la siguiente figura.


203102hr44649pa60b3llz.png


Resumen


Las rutas BGP con el mismo atributo AS_Path se pueden usar para equilibrar la carga. Tenga en cuenta que los atributos AS_Path de las rutas BGP con la misma longitud y el número AS deben ser los mismos. Cuando las longitudes de los atributos AS_Path de dos rutas BGP son iguales pero los números AS en los atributos AS_Path son diferentes, el dispositivo Huawei no selecciona rutas en función del número AS. Es decir, el dispositivo Huawei no discrimina rutas con un número AS mayor. Después de todo, en el mundo BGP, los números AS son iguales independientemente de sus tamaños.


Saludos.

  • x
  • convención:

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Comunidad Huawei Enterprise
Comunidad Huawei Enterprise