De acuerdo

Protección de redes metro ethernet empleando troncales de radio Destacado

Última respuesta febr. 22, 2021 14:16:49 648 9 6 0 0


Hola amigos y miembro de forum, quiero esta vez compartir con ustedes como hacer cierres de anillo en redes metro-ethernet empleando troncales de radio, la serie Optix RTN 900 por citar un tipo ofrece la posibilidad de trabajar en un escenario hybrido (SDH(Gerarquía Digital Sincrónica)+Ethernet). Si hacemos uso de los recursos ethernet podemos incorporalo a las redes metro-ethernet como un enlace de protección.


El objetivo de esta publicación es ofrecerle el modo de implementarlo, para ello vamos a partir de una red metro-ethernet con dispositivos del tipo S9306E así como S5320HI, el tipo de radio empleado como habiamos citado antes son la familia Optix RTN900. En la red metro ethernet el protocolo de la capa de control es el protocolo de enrrutamiento dinámico OSPF (Open Shortest Path First) mientras que en el plano de forwarding tenemos a MPLS (Conmutación Multiprotocolo Mediante Etiquetas), los principales servicios de este plano son VPLS (virtual private LAN service) y VLL (Virtual Leased Line).


Para explicar la solución partimos de  una topología de red tipo anillo, este se implementa sobre una misma fibra, esto lo hace vulnerable, ya que el cierre de anillo es sobre un mismo cable, por otro lado, si empleamos troncales de radio como via redundante posibilita la creación de anillo físico garantizando la supervivencia de  los servicios a tiempo completo.


En la figura siguiente se muestra a la derecha la topología física de la red, un corte entre el SITE A y SITE B interrumpe todos los servicios tanto para el SITE B como para el SITE C. En la parte izquierda está representado la topología de anillo lógico implementado sobre un mismo cable.

1

Para la solución es necesaria la creación de una VLAN en los nodos frontera de la topología(S9306E SITE A y S5320 SITE B), la vlan seleccionada tiene que permitirce en el enlace por radio, el servicio emplementado en los radio enlaces  es del tipo E-LAN Service permitiendo la VLAN(Virtual Local Area Network) tanto en las interfaz directamente conectada a los elementos de la red metro como en la parte inalámbrica. Los atributos de las interfaces en el radio se configuraran del tipo Tag-Aware teniendo en cuenta que las tramas que se procesaran por el radio enlace van hacer etiqueteadas con VLAN 1111.

En la siguiente figura se ilustra la topología final del servicio.

2

En la siguiente figura se ilustra el proceso de configuración de la E-LAN Service.

Con el terminal U2000 se conecta a cada nodo de manera independiente->Click Derecho->NE Explorer->Configuration->Ethernet Service Management->E-LAN Service.

Una vez llegado a E-LAN Service creamos el servicio.


3

Service ID->Identificado con un número esta vez 1.

Service Name->Nombre del Servicio, puede ser el nombre que viene en la imagen Protección.

TagType->Se le aplicó la configuración C-Aware

Luego nos dirigimos a la pestaña de Configuration y permitimos la VLAN por las interfaces apropiadas (Conexión directa a la red metro así como en la parte inalámbrica).

S9306E SITE A así como S5320SITE B

Crear la vlan 1111 y permitirla por las interfaces gigabit ethernet 2/1/0 y 0/0/1 respectivamente, luego crear la interface vlanif 1111 en los nodos S9306E SITE A y S5320 SITE B.

S9306E SITE A

Interface GigabitEthernet2/1/0         

Description Conexión física hacia Optix RTN  SITE E (GE 8/EGS6/1)

port link-type trunk

undo port trunk allow-pass vlan 1

port trunk allow-pass vlan 1111

#

Interface vlanif1111

Description Enlace via radio Protección Red Metro Ethernet.

ip address 172.31.2.13  255.255.255.252

____________________________________

S5320 SITE B

Interface GigabitEthernet0/0/1       

Description Conexión física hacia Optix RTN  SITE D (GE 8/EGS6/1)

port link-type trunk

undo port trunk allow-pass vlan 1

port trunk allow-pass vlan 1111

#

Inteface vlanif1111

Description Enlace via radio Protección Red Metro Ethernet.

ip address 172.31.2.14  255.255.255.252

 

Teniendo en cuenta que previamente se configuró la VLAN 1111 en el radio enlace asi como en los elementos de la red metro (S9306E SITE A y S5320 SITE B) el siguiente paso es probar conectividad desde la consola de comando desde cualquier nodo, si el ping es exitoso el trazado de la vlan está correcto tanto en los elemenos fronteras de la red como en el optix RTN910B, por lo tanto, procedemos a configurar la capa de control (OSPF) en los elementos fronteras de la red (S9306E SITE A y S5320 SITE B) para disponer de una enlace adicional, esta vez via radio.

 

 

Etapa final, Incorporar otra dirección OSPF via radio e incorporarlo a los elementos de la red  metro-ethetrnet (S9306E SITE A y S5320 SITE B).

Configurar el plano de control en el S9306E SITE A y S5320 SITE B para que sea alcanzable por via radio.

S9306E SITE A

Interface Loopback0

ip address 172.30.0.1 255.255.255.255

ospf enable 1 area 0.0.0.0 

#

ospf 1  

area 0.0.0.0 

network 172.30.0.1  0.0.0.0        

network 172.31.2.0  0.0.0.3

network 172.31.2.4  0.0.0.3

network 172.31.2.12  0.0.0.3 // Segmento de red alcanzable  via radio.

#

Interface XGigabitEthernet1/1/1                                                   

undo portswitch                                                                                

description To_SITEC (XGE 1/1/2)                                                   

ip address 172.31.2.1  255.255.255.252                                         

ospf ldp-sync                                                                                       

ospf enable 1 area 0.0.0.0                                                                

mpls                                                                                                    

mpls ldp                                                                                               

#

Interface XgigabitEthernet1/1/2                                                        

undo portswitch

description To_SITEB (XGE 0/0/2)   

ip address 172.31.2.5  255.255.255.252 

ospf ldp-sync

mpls

mpls ldp 

#

                                                       

interface Vlanif1111

description Hacia Optix RTN910 SITE E (GE 8/EGS6/1)

ip address 172.31.2.13  255.255.255.252                                        

ospf ldp-sync

ospf cost 120      // Segmento de red alcanzable  via radio//mayor costo menor prioridad//

mpls                                                                

mpls ldp

S5320 SITE B

Interface Loopback0

Ip address 172.30.0.3 255.255.255.255

ospf enable 1 area 0.0.0.0 

#

interface Vlanif1111

 description Hacia Optix RTN910 SITE D (GE 8/EGS6/1)

 ip address 172.31.2.14 255.255.255.252                                        

ospf ldp-sync

ospf cost 120      // Segmento de red alcanzable  via radio//mayor costo menor prioridad//

 mpls                                                                 

 mpls ldp

#

ospf 1  

area 0.0.0.0 

network 172.30.0.2  0.0.0.0        

network 172.31.2.0  0.0.0.3

network 172.31.2.4  0.0.0.3

network 172.31.2.12  0.0.0.3 // Segmento de red alcanzable  via radio.

 

S92306E SITE C

 Interface Loopback0

Ip address 172.30.0.3 255.255.255.255

ospf enable 1 area 0.0.0.0

#

Interface XGigabitEthernet1/1/1       

undo portswitch  

Description To_SITEB (XGE 0/0/1)     

ip address 172.31.2.9  255.255.255.252    

ospf ldp-sync

mpls

mpls ldp

#

Interface XGigabitEthernet1/1/2   

undo portswitch  

Description To_SITEA (XGE 1/1/1)     

ip address 172.31.2.2 255.255.255.252    

ospf ldp-sync

mpls

mpls ldp

#

ospf 1  

area 0.0.0.0 

network 172.30.0.3  0.0.0.0        

network 172.31.2.0  0.0.0.3

network 172.31.2.8  0.0.0.3

 

Resumen.

El resultado final es que la capa de control de la red mediante el protocolo de enrrutamiento OSPF tenga una via más por radio, por otro lado es necesario modificar los costos a las interfaces definidas para acceder por el enlace de radio, de esta manera la red lo interprete como un enlace de protección y no como un enlace activo (Mayor costo menos prioridad).

 

Bueno hasta aquí mi publicación, espero que hayan entendido lo antes expuesto, cualquier cuestión del tema pueden contactarme y debatimos cualquier duda al respecto. Por su atención gracias y hasta un nuevo post.



Te puede interesar:

Varias placas OSN 9800 UXCS están defectuosas debido a la alta temperatura

Introducción al cifrado de servicios L1 

Fiber Doctor (FD) y Optical Doctor (OD) 

OLP o DCP: una forma muy rentable de mejorar el mecanismo de protección de red 

¿Cómo comprobamos el rendimiento del canal E1? 

  • x
  • convención:

dilber
Publicado 2020-12-9 16:42:48
Muy útil su publicación. La explicación es correcta e instructiva. Gracias por compartir su experiencia técnica
Ver más
  • x
  • convención:

alexander
alexander Publicado 2021-2-23 15:02 (0) (0)
 
lucian2003
VIP Author Publicado 2020-12-10 07:20:24
Interesante. Gracias
Ver más
  • x
  • convención:

Aurea
Publicado 2020-12-15 16:48:53
Excelente publicación, gracias por compartir Protección de redes metro ethernet empleando troncales de radio-3629447-1
Ver más
  • x
  • convención:

dayana
dayana Publicado 2021-1-8 20:29 (0) (0)
Bien, excelente publicacion  
dayana
Publicado 2021-1-8 20:28:41
Excelente post
Ver más
  • x
  • convención:

Lianet
Publicado 2021-1-12 19:16:37
Muy bien explicado Alex y muy buena solución para contar con un enlace redundante en la red Metro.
Ver más
  • x
  • convención:

Ballester
Publicado 2021-1-29 22:41:29
Muy bueno el post
Ver más
  • x
  • convención:

Claire
Publicado 2021-2-22 14:16:49

Interesante publicación. Gracias por compartirla. Protección de redes metro ethernet empleando troncales de radio-3805341-1

Ver más
  • x
  • convención:

Comentar

Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse
Responder

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Contrato de usuario.”

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.
Recordatorio
Agrega tu número de teléfono para obtener un bono de invitación.