Operaciones ARP comunes configuración de entradas ARP estáticas

83 0 0 0

Las entradas ARP estáticas no envejecerán y no podrán ser anuladas por entradas ARP dinámicas. Puede configurar manualmente una entrada ARP estática, o usar el escaneo automático y ARP fijo para configurar por lotes las entradas ARP estáticas.

Configuración manual de una entrada ARP estática

  NOTA:

Si la interfaz de salida es una interfaz Ethernet en el modo Capa 2, se recomienda configurar una entrada ARP estática larga. Especifique la VLAN y la interfaz de salida al configurar la entrada.

# Configure una entrada de ARP estática con la dirección IP 172.16.10.2, la dirección MAC 0023-0045-0067 y la interfaz de salida GE1 / 0/1 en el modo Capa 2. Esta entrada ARP estática pertenece a la VLAN 100.

<HUAWEI> system-view

[HUAWEI] vlan batch 100

[HUAWEI] interface vlanif 100

[HUAWEI-Vlanif100] ip address 172.16.10.1 24// La dirección IP de la interfaz VLANIF debe estar en el mismo segmento de red con la dirección IP (172.16.10.2) en la entrada ARP estática.

[HUAWEI-Vlanif100] quit
[HUAWEI] interface gigabitethernet 1/0/1
[HUAWEI-GigabitEthernet1/0/1] port link-type trunk
[HUAWEI-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 // La interfaz GigabitEthernet1/0/1 está en modo Capa 2 y debe agregarse a VLAN 100.
[HUAWEI-GigabitEthernet1/0/1] quit
[HUAWEI] arp static 172.16.10.2 0023-0045-0067 vid 100 interface gigabitethernet 1/0/1
 
# Configure una entrada de ARP estática con la dirección IP 172.16.20.2, la dirección MAC 0023-0045-0068 y la interfaz de salida GE1/0/2 en el modo de Capa 3.
<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 1/0/2
[HUAWEI-GigabitEthernet1/0/2] undo portswitch
[HUAWEI-GigabitEthernet1/0/2] ip address 172.16.20.1 24 // La dirección IP de GigabitEthernet1 / 0/2 debe estar en el mismo segmento de red con la dirección IP (172.16.20.2) en la entrada ARP estática.
[HUAWEI-GigabitEthernet1/0/2] quit
[HUAWEI] arp static 172.16.20.2 0023-0045-0068 interface gigabitethernet 1/0/2
      
# Configure una entrada de ARP estática con la dirección IP 172.16.30.2 y la dirección MAC 0023-0045-0069. Esta entrada ARP estática pertenece a la instancia VPN vpn1.
<HUAWEI> system-view
[HUAWEI] ip vpn-instance vpn1
[HUAWEI-vpn-instance-vpn1] ipv4-family
[HUAWEI-vpn-instance-vpn1-af-ipv4] quit
[HUAWEI-vpn-instance-vpn1] quit
[HUAWEI] arp static 172.16.30.2 0023-0045-0069 vpn-instance vpn1
 
# Configure una entrada de ARP estática con la dirección IP 172.16.40.2 y la dirección MAC 02bf-0045-0070. (Por ejemplo, puede configurar una entrada de ARP estática corta cuando el dispositivo está conectado al clúster de servidores NLB en modo ARP multipuerto).
 
<HUAWEI> system-view
[HUAWEI] arp static 172.16.40.2 02bf-0045-0070
 
Usando el escaneo automático y ARP fijo para configurar por lotes las entradas ARP estáticas
# La dirección IP de VLANIF 103 es 172.16.50.1/24. Realice la exploración automática de las entradas de ARP con las direcciones IP 172.16.50.2 a 172.16.50.4, y convierta las entradas de ARP aprendidas en entradas de ARP estáticas.

 

<HUAWEI> system-view
[HUAWEI] vlan batch 103
[HUAWEI] interface vlanif 103
[HUAWEI-Vlanif103] ip address 172.16.50.1 24
[HUAWEI-Vlanif103] quit
[HUAWEI] interface gigabitethernet 1/0/3
[HUAWEI-GigabitEthernet1/0/3] port link-type trunk
[HUAWEI-GigabitEthernet1/0/3] port trunk allow-pass vlan 103
[HUAWEI-GigabitEthernet1/0/3] quit
[HUAWEI] display arp network 172.16.50.0 24
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                          VLAN/CEVLAN                                                                               
------------------------------------------------------------------------------                                                      
172.16.50.1     00e0-0987-7895            I -         Vlanif103                                                                     
------------------------------------------------------------------------------                                                      
Total:1         Dynamic:0       Static:0     Interface:1   
[HUAWEI] interface vlanif 103
[HUAWEI-Vlanif103] arp scan 172.16.50.2 to 172.16.50.4 // El escaneo automático se realiza en la VLANIF 103. Las direcciones IP 172.16.50.2 a 172.16.50.4 están en el mismo segmento de red con la dirección IP 172.16.50.1 de VLANIF 103. Es decir, las direcciones IP de inicio y fin en el ARP automáticamente El área escaneada debe estar en el mismo segmento de red con la dirección IP (primaria o secundaria) de la interfaz VLANIF.
Warning: This operation may take a long time, press CTRL+C to break. Continue?[Y/N]:y                                               
Processing...                                                                                                                       
Info: ARP scanning is completed.   
[HUAWEI-Vlanif103] display arp network 172.16.50.0 24 / / Después del escaneo automático, verifique las entradas ARP. El dispositivo recién aprende tres entradas dinámicas de ARP.
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                          VLAN/CEVLAN                                                                               
------------------------------------------------------------------------------                                                      
172.16.50.1     00e0-0987-7895            I -         Vlanif103                                                                     
172.16.50.2     0200-0000-0212  20        D-0         GE1/0/3                                                                      
                                           103/-                                                                                    
172.16.50.3     0200-0000-0212  20        D-0         GE1/0/3                                                                      
                                           103/-                                                                                    
172.16.50.4     0200-0000-0212  20        D-0         GE1/0/3                                                                      
                                           103/-                                                                                    
------------------------------------------------------------------------------                                                      
Total:4         Dynamic:3       Static:0     Interface:1      
[HUAWEI-Vlanif103] arp fixup // Configure las entradas de ARP fijas en VLANIF 103 convirtiendo las entradas de ARP dinámicas aprendidas en entradas de ARP estáticas.
Warning: This operation may generate configuration of static ARP, and take a long time, press CTRL+C to break. Continue?[Y/N]:y     
Processing...                                                                                                                       
Info: ARP fixup is completed.    
[HUAWEI-Vlanif103] display arp network 172.16.50.0 24 // Verificar entradas ARP fijas. Las tres entradas dinámicas de ARP que el dispositivo ha aprendido recientemente se han convertido en entradas de ARP estáticas.
 
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                          VLAN/CEVLAN                                                                               
------------------------------------------------------------------------------                                                      
172.16.50.2     0200-0000-0212            S--         GE1/0/3          
                                           103/-                                                                                    
172.16.50.3     0200-0000-0212            S--         GE1/0/3             
                                           103/-                                                                                    
172.16.50.4     0200-0000-0212            S--         GE1/0/3       
                                           103/-                                                                                    
172.16.50.1     00e0-0987-7895            I -         Vlanif103                                                                     
------------------------------------------------------------------------------                                                      
Total:4         Dynamic:0       Static:3     Interface:1  
 

  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba