Interoperación de Switch Huawei 5700 con Switch Cisco 3700 Destacado

Última respuesta febr. 21, 2020 11:32:43 71 4 2 1

Hola a todos, en este post quiero dar a conocer un proyecto en el que me encuentro trabajando y que me siento muy bien al poder estar al frente de este trabajo.


Como pueden notar en el titulo se trata de la interoperación de un switch 5700 Huawei con un switch 3700 de cisco y cuando hablamos de este tipo de integraciones siempre mencionamos la incompatibilidad de protocolos que existe entre estas dos tecnologías, y principalmente lo hacemos porque existen protocolos propietarios que posee cada uno, por ejemplo tenemos los protocolos de enrutamiento que por un lado cisco utiliza EIGRP y Huawei  OSPF con esto no estoy queriendo decir que solo con estos protocolos funcionen cada uno de ellos ya que también está el protocolo BGP, Rip entre otros.


No hablare de los protocolos de enrutamiento por ahora ya que en este post me dedicare a la puesta en marcha de una integración Huawei - Cisco a nivel de comunicación de capa 2, el problema en este punto radica en la incompatibilidad en función al VTP (Protocolo Troncal virtual) y el DTP (Protocolo Troncal Dinámico) ambos propiedad de Cisco, estos dos protocolo podemos reemplazarlo por el LNP (Protocolo de Negociación de Tipo de Enlace) y VCMP para lograr la interoperabilidad esperada, esto se los hago saber para que puedan deducir hacia dónde vamos en esta serie de post que iniciare en este día así como he iniciado con la serie de OSPF Que es Y Como Funciona OSPF parte 1 Que es Y Como Funciona OSPF parte 2


Vamos a iniciar de lo más sencillo al más avanzado y muchas veces he pensado en correr antes de gatear pero en esta oportunidad no será así ya que en este post empezaremos por lo básico, y es que como método factible que podríamos ante todo proponer a nuestra empresa es sustituir la Infraestructura Cisco existente por la de Huawei pero sé que su jefe le dirá No Hay Presupuesto, pero si nos encontramos con que nuestra propuesta de sustitución fue aceptada lo único que debemos hacer es lo siguiente.


Tomando como ejemplo la siguiente topología.


imag1


Creamos VLANS


<HUAWEI> system-view

[HUAWEI] sysname Switch1

[Switch1] vlan batch 10 20

<HUAWEI> system-view

[HUAWEI] sysname Switch2

[Switch2] vlan batch 10 20

<HUAWEI> system-view

[HUAWEI] sysname Switch3

[Switch3] vlan batch 10 20


Configuramos el Switch 1 


[Switch1] interface GigabitEthernet 1/0/1

[Switch1-GigabitEthernet1/0/1] port default vlan 10 

[Switch1-GigabitEthernet1/0/1] quit

[Switch1] interface GigabitEthernet 1/0/2

[Switch1-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20 

[Switch1-GigabitEthernet1/0/2] quit

[Switch1] interface GigabitEthernet 1/0/3

[Switch1-GigabitEthernet1/0/3] port default vlan 20

[Switch1-GigabitEthernet1/0/3] quit


De esta misma manera configuramos en Switch 2 y 3 tomando en cuenta las vlans que se permitirán por el enlace troncal.


Con esto ya podríamos tener comunicación troncal en la Red.


El caso más real es que deba realizar una integración para mantener la operatividad en la red utilizando Switch Huawei Conectados a Switch Cisco por defecto el protocolo LNP de huawei viene activo por defecto en los equipos, para deshabilitarlo aplica el comando en el modo de configuración de interfaz undo port negotiation disable.


Para verificar que la negociación esta deshabilitada aplicamos el siguiente comando:

[Switch1] display lnp interface gigabitethernet1/0/2


En el caso que tengamos la necesidad de unir estas dos tecnologías podría aplicar la siguiente topología: 


imag2

Cuando los conmutadores de Huawei están conectados a los de Cisco el tipo de enlace en la interfaz no se puede negociar dinámicamente es por esta razón que hemos aplicado en la interfaz trocal el comando undo port negotiation disable este comando para los conmutadores Huawei en el caso de Cisco aplicamos en la interfaz troncal el comando switchport nonegotiate.


Configuramos de manera manual los enlaces troncales tomando en cuenta que el conmutador Cisco aplicamos la encapsulación dot1q, para este ejemplo solo aplicare la configuración de la interfaz fastEthernet 0/2


CiscoA# configure terminal

CiscoA(config)# interface fastEthernet 0/2

CiscoA(config-if)# switchport trunk encapsulation dot1q

CiscoA(config-if)# switchport mode trunk 


Configuramos el enlace troncal en la interfaz gigabitEthernet 1/0/2


<Huawei> system-view

[Huawei] interface GigabitEthernet1/0/2

[Huawei-GigabitEthernet1/0/2] port link-type trunk

[Huawei-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 4094 


  • x
  • convención:

user_153387
Publicado 2020-2-15 18:33:46 Útil(0) Útil(0)
Gracias, muy bueno, siempre se aprende o refrescan los conocimientos, gracias a la comunidad.
  • x
  • convención:

Michely
Michely Publicado 2020-2-15 21:04
Gracias a usted, Saludos  
Hello%20friends%2C%20I%20am%20a%20Telecommunications%20and%20electronics%20engineer%20and%20I%20just%20graduated%20as%20a%20master%20in%20telecommunications%20systems.%20I%20work%20in%20the%20telecommunications%20company%20of%20Cuba%2C%20ETECSA.%20I%20am%2035%20years%20old%20and%20I%20attend%20the%20transport%20network%20in%20my%20province%2C%20which%20is%20mainly%20Huawei.
Gustavo.HdezF
Moderador Publicado 2020-2-21 11:32:43 Útil(0) Útil(0)
Hola @Michely Gracias por compartir este tipo de publicaciones que con seguridad los usuario del foro la encontraran muy útil. Quedamos a la espera de las próximas publicaciones. Saludos.
  • x
  • convención:

Michely
Michely Publicado 2020-2-22 20:13
Muschas gracias @Gustavo.HdezF  
Ingeniero%20en%20Comunicaciones%20y%20Electr%C3%B3nica%20con%2022%20a%C3%B1os%20de%20experiencia%20en%20el%20%C3%A1rea%20de%20las%20telecomunicaciones%20para%20voz%20y%20datos%2C%20comparto%20mi%20experiencia%20dando%20clases%20en%20la%20Universidad%20Polit%C3%A9cnica%20de%20Quer%C3%A9taro.

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión