De acuerdo

Integración de redes HUAWEI y CISCO con Redistribución OSPF EIGRP

Última respuesta Sep 08, 2020 09:24:17 742 5 1 1

Hola a todos amantes de la tecnología, hoy aprenderemos nuevas habilidades y se trata de la Redistribución de protocolo para interconectar redes con equipos de infraestructura Huawei y Cisco, muchas veces surge la pregunta.

¿Por qué Redistribuir Rutas?

La redistribución de rutas nace para la conexión entre dominios de routing, en ospf un AS (Sistema Autónomo) es un dominio de procesos y para efectuar enrutamiento entre dominios de procesos, un ASBR (Router de Borde de Sistema Autónomo) ospf debe realizar una redistribución de rutas.

Cuando hablamos de eigrp nos vemos en la misma necesidad, normalmente una red con eigrp puede estar conformada en varios sistemas autónomos, hablar de un sistema autónomo en eigrp es como hablar de un dominio de procesos en ospf, es por esta razón que para encaminar todo el tráfico de un sistema autónomo a otro debemos hacerlo con redistribución de rutas mejor conocida como redistribución de sistemas autónomos.

En este post se realizara la redistribución de protocolo en un edificio con equipos de infraestructura Huawei donde estará operando un Router AR2200 conectado a un switch 3700 dicha red huawei estará conectada a una sucursal que utiliza como medio de interconexión de red equipos de infraestructura Cisco donde estará funcionando un Switch multicapa 3720 conectado a un switch capa 2, para ubicarse bien en esta breve explicación le invita a ver la imagen de topología presentada a continuación.

Esta simulación se realiza utilizando herramientas de software como eNSP y GNS3


Topologia

195033fbrdmisyddx23rh1.png?imagen.png

Configuración de red Huawei



Configuración de la interfaz del Router Huawei que conecta el enlace hacia la red Cisco

[HUAWEI] interface GigabitEthernet 0/0/1

[HUAWEI-GigabitEthernet0/0/1] ip address 10.10.10.1 255.255.255.252

[HUAWEI-GigabitEthernet0/0/1] description Huawei cisco

[HUAWEI-GigabitEthernet0/0/1] quit



Configuración de la Interfaz de Gateway que conecta la red LAN Huawei

[HUAWEI] interface GigabitEthernet 0/0/0

[HUAWEI-GigabitEthernet0/0/0] ip address 15.15.15.1 24

[HUAWEI-GigabitEthernet0/0/0] quit



Configuración de OSPF

[HUAWEI] ospf 1 router-id 1.1.1.1

[HUAWEI-ospf-1] area 0

[HUAWEI-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.3

[HUAWEI-ospf-1-area-0.0.0.0] network 15.15.15.0 0.0.0.255

[HUAWEI-ospf-1-area-0.0.0.0] return



Configuracion de red Cisco



Configuración de la interfaz del Router Cisco que conecta el enlace hacia la red Huawei

R1(config)# interface f0/0

R1(config-if)# ip address 10.10.10.2 255.255.255.252

R1(config-if)# description cisco huawei

R1(config-if)# exit



Configuración de la Interfaz de Gateway que conecta la red LAN Cisco

R1(config)# interface f0/1

R1(config-if)# ip address 20.20.20.1 255.255.255.0

R1(config-if)# exit



Configuración de EIGRP

R1(config)# router eigrp 1


R1(config-router)# eigrp router-id 2.2.2.2


R1(config-router)# network 20.20.20.0 0.0.0.255


R1(config-router)# exit

NOTA: En esta parte debo aclarar que se configura solo la dirección de red correspondiente a la LAN de Cisco ya que el enlace que comunica Cisco con Huawei está enrutado por OSPF, entonces EIGRP se utiliza como un protocolo de enrutamiento para rutas internas de modo que, todo el tráfico generado en la red LAN Cisco sea redistribuido a OSPF en el Router Cisco



Configuración de OSPF en Cisco

R1(config)# router ospf 1


R1(config-router)# router-id 2.2.2.2


R1(config-router)# network 10.10.10.0 0.0.0.3 area 0


R1(config-router)# exit

NOTA: como se mencionó en la nota anterior la red que se configurara en este router para OSPF es la red que conecta el enlace Cisco Huawei



LLEGO la Hora de Redistribuir Rutas

Configuración para decir a OSPF que Redistribuya EIGRP

R1(config)# router ospf 1


R1(config-router)# redistribute eigrp 1 subnets


R1(config-router)# exit



Configuración para decir a EIGRP que Redistribuya OSPF

R1(config)# router eigrp 1


R1(config-router)# redistribute ospf 1 metric 1 1 1 1 1


R1(config-router)# end



Enhorabuena ya tenemos una red con infraestructura Cisco y Huawei en total operatividad.

Para una información más detallada les invito a ver el siguiente video donde se realiza la configuración presentada en este post.

https://youtu.be/2ktm7u2DbSY





  • x
  • convención:

lucian2003
VIP Publicado 2020-8-12 07:09:37 Útil(1) Útil(1)

#BuscaComunidadEnterprise


#BuscaComunidadEnterprise


Ver más
  • x
  • convención:

JTX
Publicado 2020-8-17 14:09:53 Útil(0) Útil(0)
gracias por la información y el paso de configuración de ambas tecnologías.
saludos.
Ver más
  • x
  • convención:

Michely
Michely Publicado 2020-9-7 08:08
Gracias a usted saludos  
Lucyagonzales6
Publicado 2020-8-24 13:42:21 Útil(0) Útil(0)
Que buena información, gracias
Ver más
  • x
  • convención:

caterinalo
Publicado 2020-9-8 09:24:17 Útil(1) Útil(1)
Que buena información!
Ver más
  • x
  • convención:

Comentar

Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse
Responder

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.
Recordatorio
Agrega tu número de teléfono para obtener un bono de invitación.