Huawei eNSP Configuración de protocolos HDLC y PPP con autenticación PAP y CHAP Router AR2200

Última respuesta ag. 02, 2019 05:32:02 358 8 6 1

Hola a todos amantes de la tecnología Huawei, Vamos aprender nuevas habilidades referentes a la configuración de los protocolos de encapsulación PPP y HDLC y aquellos encargados de la autenticación como el PAP y CHAP.


Los protocolos de capa 2 definen la forma en que se encapsulan los datos para la transmisión a una ubicación remota, así como los mecanismos para transferir las tramas resultantes. Se usa una variedad de tecnologías diferentes, como el protocolo punto a punto (PPP) encargado de manejar la autenticación, la compresión y la  detección de errores, de controlar la calidad de los enlaces, y de agrupar  lógicamente varias conexiones seriales para compartir la carga.


Generalmente el protocolo de capa 2 es HDLC (control de enlace de datos de alto nivel) o PPP (protocolo punto a punto) estos protocolos se encargan de la encapsulación de las tramas normalmente el HDLC es el protocolo predeterminado en las conexiones punto a punto, el HDLC utiliza la transmisión serial síncrona que proporciona una comunicación  sin errores entre dos puntos, HDLC define una estructura de trama de capa 2 que  permite el control del flujo y de errores mediante el uso de acuses de recibo,  cada trama presenta el mismo formato ya sea una trama de datos o una trama de  control.


Cuando las tramas se transmiten por enlaces síncronos o asíncronos, esos enlaces  no tienen ningún mecanismo para marcar ni el principio ni el fin de las tramas,  por este motivo HDLC utiliza un delimitador de trama o indicador para marcar  el principio y el fin de cada trama.


Equipos y Herramienta


El Router Huawei AR2200 es un router corporativo basado en la plataforma de enrutamiento versátil que abarca el área de comunicación de datos, redes inalámbricas, redes de acceso y redes core, este router incorpora funciones de enrutamiento, conmutación, 3G, voz y seguridad. Tienen una estructura de múltiples núcleos y conmutación no bloqueante.


Toda la configuración se realiza bajo el software de simulación eNSP



Topología


El la topología podemos ver 3 router AR2200 conectados entre si que conectan dos sucursales a través de enlaces punto a punto, las direcciones que utiliza cada red de enlaces está basado en el rango de red 10.0.12.0/24 y 10.0.23.0/24


190704agncqd3f9dmii7f3.png?imagen.png

Imagen 1.


Configuración


Paso 1 Preparamos el entorno


Identificamos cada equipo Router, en este ejemplo se utiliza un nombre por defecto R1, R2 ,R3 recuerde que en un Sistema de red en producción este nombre para el equipo no es el correcto, identificar lógicamente un equipo de red involucra muchos factores como por ejemplo la ubicación geográfica, numero o nombre de edificio, numero de cuarto de cableado donde se ubica, numero de stack si este lo está y modelo, todos estos parámetros se utilizan de manera abreviada.


<Huawei>system-view

[Huawei]sysname R1


<Huawei>system-view

[Huawei]sysname R2


<Huawei>system-view

[Huawei]sysname R3


 


Paso 2 Configure el direccionamiento IP de la interfaz serie para R1, R2 y R3


[R1]interface Serial 1/0/0

[R1-Serial1/0/0]ip address 10.0.12.1 24


[R2]interface Serial 1/0/0

[R2-Serial1/0/0]ip address 10.0.12.2 24

[R2-Serial1/0/0]quit

[R2]interface Serial 2/0/0

[R2-Serial2/0/0]ip address 10.0.23.2 24


[R3]interface Serial 2/0/0

[R3-Serial2/0/0]ip address 10.0.23.3 24



Paso 3 Habilite el protocolo HDLC en las interfaces seriales, recuerde colocar la letra “Y” para continuar aceptando usar la encapsulación HDLC


[R1]interface Serial 1/0/0

[R1-Serial1/0/0]link-protocol hdlc

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


[R2]interface Serial 1/0/0

[R2-Serial1/0/0]link-protocol hdlc

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y

[R2-Serial1/0/0]quit


[R2]interface Serial 2/0/0

[R2-Serial2/0/0]link-protocol hdlc

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


[R3]interface Serial 2/0/0

[R3-Serial2/0/0]link-protocol hdlc

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


Prueba conectividad haciendo una petición de eco de R2 a R1

<R2>ping 10.0.12.1



Paso 4 Configurar RIPv2.


[R1]rip

[R1-rip-1]version 2

[R1-rip-1]network 10.0.0.0


[R2]rip

[R2-rip-1]version 2

[R2-rip-1]network 10.0.0.0


[R3]rip

[R3-rip-1]version 2

[R3-rip-1]network 10.0.0.0


Podemos verificar que las rutas hayan sido aprendidas correctamente


<R1>display ip routing-table


Puede probar conectividad de R1 a R3 la petición de eco debería ser exitosa


<R1>ping 10.0.23.3



Paso 5 Configure PPP en las interfaces seriales.


Configure PPP entre R1 y R2 así como R2 y R3 Ambos extremos del enlace debe usar el mismo modo de encapsulación, recuerde colocar la letra “Y” para continuar aceptando usar la encapsulación PPP


[R1]interface Serial 1/0/0

[R1-Serial1/0/0]link-protocol ppp

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


[R2]interface Serial 1/0/0

[R2-Serial1/0/0]link-protocol ppp

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y

[R2-Serial1/0/0]quit

[R2]interface Serial 2/0/0

[R2-Serial2/0/0]link-protocol ppp

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


[R3]interface Serial 2/0/0

[R3-Serial2/0/0]link-protocol ppp

Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y


Pruebe conectividad


<R2>ping 10.0.12.1

<R2>ping 10.0.23.3


Si la operación de ping falla, verifique el estado de la interfaz y si en la capa de enlace el tipo de protocolo es correcto es decir que las interfaces estén utilizando el mismo modo de encapsulación.


<R1>display interface Serial1/0/0


Puede verificar los cambios en la tabla de Routing


[R2]display ip routing-table



Paso 6 Habilite la autenticación PAP entre R1 y R2.


El protocolo PAP no es un modo de autenticación seguro, mediante PAP las contraseñas se  envían a través del enlace en texto no cifrado, y no existe protección contra  los ataques de reproducción.


En la topología presentada al inicio puede notar que existen 2 enlaces seriales de R2 a R1 y de R2 a R3 vamos a configurar PAP en el enlace de R1 a R2


Configuramos la autenticación PAP con R1 como el autenticador PPP PAP


[R1]interface Serial 1/0/0

[R1-Serial1/0/0]ppp authentication-mode pap

[R1-Serial1/0/0]quit


[R1]aaa

[R1-aaa]local-user huawei password cipher myhuawei

info: A new user added

[R1-aaa]local-user huawei service-type ppp


Nota: el username y password es de su preferencia


Configuramos la autenticación PAP en R2 actuando como el dispositi****utenticado PAP.


[R2]interface Serial 1/0/0

[R2-Serial1/0/0]ppp pap local-user huawei password cipher myhuawei


Después de que R2 envía una solicitud de autenticación a R1, R1 envía una respuesta a R2, solicitando a R2 que use la autenticación PAP luego R2 enviará su contraseña a R1.


Pruebe la conectividad entre R1 y R2.


<R1>debugging ppp pap packet

<R1>terminal debugging

<R1>display debugging

PPP PAP packets debugging switch is on

<R1>system-view


Reiniciamos la interfaz


[R1]interface Serial 1/0/0

[R1-Serial1/0/0]shutdown

[R1-Serial1/0/0]undo shutdown


Al reiniciar la interfaz forzamos al equipo a realizar la autenticación en las interfaces, esto a través del bebugging que se realizó mostrara información de la autenticación.


Una vez vista la información del debug y comprobada la autenticación procedemos a detenerlo


<R1>undo debugging all

Info: All possible debugging has been turned off


 


Paso 7 Habilite la autenticación CHAP en el enlace serial de R2 y R3.


Configuramos R3 como el autenticador.


[R3]interface Serial 2/0/0

[R3-Serial2/0/0]ppp authentication-mode chap

[R3-Serial2/0/0]quit


[R3]aaa

[R3-aaa]local-user huawei password cipher myhuawei

info: A new user added

[R3-aaa]local-user huawei service-type ppp

[R3-aaa]quit


[R3]interface Serial 2/0/0

[R3-Serial2/0/0]shutdown

[R3-Serial2/0/0]undo shutdown


Después que R2 envía una solicitud de autenticación a R3, R3 envía un mensaje de respuesta a R2, solicitando a R2 que use la autenticación CHAP  la cual se envía un desafío a R3.


Note que después de reiniciar la interfaz el router arroja la siguiente información a través de los mensajes syslog


Dec 10 2013 15:06:00+00:00 R3 %%01PPP/4/PEERNOCHAP(l)[5]:On the interface

Serial2/0/0, authentication failed and PPP link was closed because CHAP was

disabled on the peer.

[R3-Serial2/0/0]

Dec 10 2013 15:06:00+00:00 R3 %%01PPP/4/RESULTERR(l)[6]:On the interface

Serial2/0/0, LCP negotiation failed because the result cannot be accepted.


Si ha podido detallar bien el mensaje puede notar que el router informa que no se pudo establecer la autenticación chap


¿Por qué sucede esto?


Porque debemos configurar la interfaz en R2  que mira a R3 como cliente chap


[R2]interface Serial 2/0/0

[R2-Serial2/0/0]ppp chap user huawei

[R2-Serial2/0/0]ppp chap password cipher myhuawei


Podemos probar conectividad con R3


<R2>ping 10.0.23.3



Paso 8 Depuración (debugging) PPP CHAP


Ejecute el comando de depuración para ver la negociación de la conexión PPP entre R2 y R3. La conexión PPP se establece usando CHAP.


Deshabilitamos la interfaz


[R2]interface Serial 2/0/0

[R2-Serial2/0/0]shutdown


Ejecutamos el debugging para PPP CHAP


<R2>debugging ppp chap all

<R2>terminal debugging

Info: Current terminal debugging is on.

<R2>display debugging


Forzamos la autenticación iniciando la interfaz


<R2>system-view

Enter system view, return user view with Ctrl+Z.

[R2]interface Serial 2/0/0

[R2-Serial2/0/0]undo shutdown


Mostrará una secuencia de eventos donde se establece la autenticación chap con R3


Deshabilitamos el debugging


[R2-Serial2/0/0]return

<R2>undo debugging all

Info: All possible debugging has been turned off


 


Espero que toda esta información le sea de mucha utilidad.


También puede seguirme en mi canal de YouTube https://www.youtube.com/channel/UCrOSUEdhNa0PBQI_I8GMErA

pronto iniciare un curso en español para la preparación HCIA.


Ing. Michely Lopez













  • x
  • convención:

VictorSaa
Moderador Publicado 2019-7-30 11:30:32 Útil(1) Útil(1)
En verdad, bastante buen ejemplo y bien explicado, y sobre todo bastante completo, estaría bastante bien si hubieras compartido el ejemplo de eNSP para aquellos que lo soliciten y deseen hacer pruebas en él, aunque siguiendo los pasos seguro sale.

Te felicito rotundamente por el conocimiento que tienes, sigue por este camino.

Saludos.
  • x
  • convención:

Mexicano%2C%20con%20m%C3%A1s%20de%2010%20a%C3%B1os%20de%20experiencia%20en%20el%20%C3%A1mbito%20de%20Redes%20y%20TICs%20en%20general%20y%20m%C3%A1s%20de%20dos%20dentro%20de%20Huawei%2C%20en%20donde%20cuento%20con%20doble%20certificaci%C3%B3n%20HCIP%20(Routing%20and%20Switching%20y%20WLAN)%2C%20actualmente%20encargado%20de%20ayudarlos%20con%20sus%20dudas%20y%20comentarios%20dentro%20de%20la%20comunidad.
Gustavo.HdezF
Moderador Publicado 2019-7-30 11:45:30 Útil(0) Útil(0)
Muy interesante tu publicación sobre estos temas que se enseñan en una clase de redes o cuando estudias por tu cuenta para el examen de certificación HCIA. Gracias por compartir esta información en el foro. Saludos.
  • x
  • convención:

Ingeniero%20en%20Comunicaciones%20y%20Electr%C3%B3nica%20con%2020%20a%C3%B1os%20de%20experiencia%20en%20el%20%C3%A1rea%20de%20las%20telecomunicaciones%20para%20voz%20y%20datos%2C%20comparto%20mi%20experiencia%20dando%20clases%20en%20la%20Universidad%20Polit%C3%A9cnica%20de%20Quer%C3%A9taro.
Pepe_BM
Publicado 2019-7-30 17:00:20 Útil(0) Útil(0)
Muchas gracias por el ejemplo! Haciendo uso de mis conocimientos en CISCO y junto a esta explicación he podido entender aun mas la configuración PPP, lo que me confundió un poco es el comando "quit", es un equivalente a "exit"?
  • x
  • convención:

Michely
VIP Publicado 2019-7-31 10:53:34 Útil(0) Útil(0)
Publicado por VictorSaa a las 2019-07-30 11:30 En verdad, bastante buen ejemplo y bien explicado, y sobre todo bastante completo, estaría bastante ...
muchas gracias @VictorSaa
  • x
  • convención:

Ing. Michely Lopez
Michely
VIP Publicado 2019-7-31 10:54:22 Útil(0) Útil(0)
Publicado por Gustavo.HdezF a las 2019-07-30 11:45 Muy interesante tu publicación sobre estos temas que se enseñan en una clase de redes o cuando est ...
@Gustavo.HdezF gracias a usted
  • x
  • convención:

Ing. Michely Lopez
Michely
VIP Publicado 2019-7-31 10:55:33 Útil(0) Útil(0)
Publicado por Pepe_BM a las 2019-07-30 17:00 Muchas gracias por el ejemplo! Haciendo uso de mis conocimientos en CISCO y junto a esta explicació ...
@Pepe_BM si correcto el comando quit en huawei es equivalente a exit en cisco
  • x
  • convención:

Ing. Michely Lopez
Marban
VIP Publicado 2019-8-1 17:28:45 Útil(0) Útil(0)
Gracias Por la Info, buen aporte
  • x
  • convención:

Me%20gusta%20compartir%20informaci%C3%B3n%20y%20experiencias%2C%20aprender%20nuevos%20temas%20y%20conocer%20gente%20con%20el%20mismo%20inter%C3%A9s
Michely
VIP Publicado 2019-8-2 05:32:02 Útil(0) Útil(0)
Publicado por Marban a las 2019-08-01 17:28 Gracias Por la Info, buen aporte
Muchas gracias @Marban
  • x
  • convención:

Ing. Michely Lopez

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión