Escenario homed dual CE - ¿Cuál es el mejor método de acceso VPLS?

95 0 0 0

Me gustaría comenzar una discusión sobre cómo acceder al circuito VPLS desde el lado CE.

Como pueden saber, la confiabilidad es muy importante hoy en día, sin embargo, la tecnología VPLS es bastante difícil de implementar, especialmente cuando se agregan muchos enlaces redundantes que intentan alcanzar el escenario de doble CE.

El escenario de acceso VPLS más común es el siguiente:

  •  Para CE podemos adoptar un escenario de hogar dual y lograr redundancia de PE. Además, cada circuito PE-CE consta de 2 enlaces redundantes.


233252ro64dpzgppgzp9xg.png


Para admitir el escenario de homed dual de CE, la configuración de VPLS de PE debe ajustarse en consecuencia.

  1.  Primero necesita usar el modo de señalización Kompella, Martini no es compatible.

  2. Luego, configure dos VSI con el mismo atributo en dos PE de doble origen.


Si los VSI de dos PE a los que un CE tiene doble inicio están activados, el PE con la prioridad más alta funciona como el PE maestro, mientras que el PE con la prioridad más baja funciona como el PE de respaldo.


En el lado de acceso, seguro que tendremos algunos problemas con Spanning Tree Dado que hay tantos enlaces redundantes, bloqueará algunos puertos, lo que hará que el acceso VPLS no esté disponible. 

endrá que modificar la configuración de STP. De todos modos algunos enlaces dejarán de estar disponibles. 

No podemos utilizar todo el ancho de banda disponible. El tiempo de convergencia no es lo suficientemente bueno, se basa en STP.


  • Podemos superar la limitación de STP mediante el uso de eth-trunks.


En el lado de PE agregaremos las 2 interfaces redundantes que conectan CE. En el lado CE, agregaremos todos los enlaces que vayan a CE en un eth-trunk. 

Verifique abajo:


233544q1bqtrt6hbd198o8.png


Pero aquí, si no tiene Kompella señalización implementada VPLS dual homing, tendrá un problema. 

  • Por ejemplo, CE se comunica con otra CE en la red VPLS a través de PE1. Si PE1 o el enlace Eth-Trunk entre CE1 y PE1 fallan, CE1 no puede comunicarse con CE2.

  • Podemos evitar la interrupción del servicio y configurar un E-Trunk en PE1 y PE2. Cuando falla la comunicación entre CE1 y PE1, el tráfico se conmuta a PE2 para que CE1 pueda comunicarse con CE2 a través de PE2. Cuando PE1 o el enlace Eth-Trunk entre CE1 y PE1 se recuperan, el tráfico vuelve a PE1.

  • El E-Trunk implementa la copia de seguridad de los grupos de agregación de enlaces entre PE1 y PE2 y mejora la confiabilidad de la red.

  • Además, podemos instalar BFD para rastrear el estado del grupo de agregación de enlaces y habilitar el tiempo de convergencia de milisegundos. Compruebe a continuación la topología y la configuración relacionada.


233937wx55j636nk55fzf8.png


-------------

#

 sysname CE

#

 vlan batch 10

#

interface Eth-Trunk0

 port link-type trunk

 port trunk allow-pass vlan 10

 mode lacp

#

interface GigabitEthernet0/0/1

 eth-trunk 0

#

interface GigabitEthernet0/0/2

 eth-trunk 0

#

interface GigabitEthernet0/0/3

 eth-trunk 0

#

interface GigabitEthernet0/0/4

 eth-trunk 0

#

return 

---------------

#

 sysname PE1

#

 vlan batch 100

#

 lacp e-trunk system-id 00e0-fc00-0000

 lacp e-trunk priority 1

#

e-trunk 1

 priority 10

 peer-address 2.2.2.9 source-address 1.1.1.9

 timer hello 9

 timer hold-on-failure multiplier 3

 e-trunk track bfd-session session-name hello1

#

 bfd

#

 mpls lsr-id 1.1.1.9

 mpls

#

 mpls l2vpn

#

vsi vpls_lan static

 pwsignal ldp

  vsi-id 2

  peer 3.3.3.9

#

mpls ldp

#

interface Vlanif 100

 ip address 10.1.1.1 255.255.255.0

 mpls

 mpls ldp

#

interface Eth-Trunk1

 mode lacp

 e-trunk 1

#

interface Eth-Trunk10.1

 dot1q termination vid 10

 l2 binding vsi vpls_lan

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/1

 eth-trunk 1

#

interface GigabitEthernet0/0/2

 eth-trunk 1

#

interface LoopBack1

 ip address 1.1.1.9 255.255.255.255

#

bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9

 discriminator local 1

 discriminator remote 2

 commit

#

ospf 1

 area 0.0.0.0

  network 1.1.1.9 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

return    

---------------

#

 sysname PE2

#

 vlan batch 200

#

 lacp e-trunk system-id 00e0-fc00-0000

 lacp e-trunk priority 1

#

e-trunk 1

 priority 20

 peer-address 1.1.1.9 source-address 2.2.2.9

 e-trunk track bfd-session session-name hello2

#

 bfd

#

 mpls lsr-id 2.2.2.9

 mpls

#

 mpls l2vpn

#

vsi vpls_lan static

 pwsignal ldp

  vsi-id 2

  peer 3.3.3.9

#

mpls ldp

#

interface Vlanif 200

 ip address 10.1.2.1 255.255.255.0

 mpls

 mpls ldp

#

interface Eth-Trunk 1

 mode lacp

 e-trunk 1

#

interface Eth-Trunk10.1

 dot1q termination vid 10

 l2 binding vsi vpls_lan

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 200

#

interface GigabitEthernet0/0/1

 eth-trunk 1

#

interface GigabitEthernet0/0/2

 eth-trunk 1

#

interface LoopBack1

 ip address 2.2.2.9 255.255.255.255

#

bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9

 discriminator local 2

 discriminator remote 1

 commit

#

ospf 1

 area 0.0.0.0

  network 2.2.2.9 0.0.0.0

  network 10.1.2.0 0.0.0.255

#

return

------------------







  • x
  • convención:

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje