Ejemplo para Conectar un Equipo a un Cluster NLB (Utilizando el Link Físico de Loopback)

56 0 0 0

Ejemplo para Conectar un Equipo a un Cluster NLB (Utilizando el Link Físico de Loopback)

Resúmen

NLB está desarrollado por Microsoft para un clúster configurado por varios servidores de Windows. Cuando un switch está conectado a un clúster NLB, el switch debe enviar paquetes destinados a la dirección IP del clúster a cada servidor NLB en el clúster. Un servidor NLB puede funcionar en modo unicast, multicast, o IGMP multicast.

Actualmente, se puede conectar un switch al servidor NLB que funciona solo en modo unicast o multicast. Si el switch admite ARP de interfaz múltiple, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el switch o la versión no son compatibles con ARP de interfaz múltiple y no hay suficientes recursos en el dispositivo, se puede usar el loopback de enlace físico para conectar el switch al clúster NLB.

Notas de Configuración

l   Cuando el clúster NLB funciona en modo de unicast, las entradas ARP estáticas no necesitan configurarse en el switch; cuando el clúster funciona en modo multicast, las entradas ARP estáticas deben configurarse en el switch.

l   Este ejemplo aplica para todas las versiones de todos los switches de la serie S.

Requerimientos de Red

Como se muestra en la Figura 1-1, el Switch se conecta a tres servidores NLB a través de GE0/0/1, GE0/0/2 y GE0/0/3. El clúster NLB funciona en modo unicast, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 02bf-0a80-f6fc. Hay rutas alcanzables entre el Switch y el Cliente.

El cliente requiere que el Switch pueda enviar los paquetes del Cliente destinados a la dirección IP del clúster NLB a todos los servidores NLB.

Figure 1-1 Conexión de un solo dispositi**** un clúster NLB en modo unicast

20170323143845125004.png

 

Configuración

La configuración es la siguiente:

1.         Agregue desde la GE0/0/1 a la GE0/0/3 que estén directamente conectadas a los servidores NLB a la VLAN 100.

2.         Deshabilite STP, RSTP, VBST o MSTP en GE0/0/4 y GE0/0/5, agregue las interfaces a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

3.         Configure una dirección IP para VLANIF 200 que funcione como la gateway del clúster NLB.

4.         Conecte GE0/0/4 y GE0/0/5.

Procedimiento

                               Paso 1     Agregue desde la GE0/0/1 a la GE0/0/3 que estén directamente conectadas a los servidores NLB a la VLAN 100.

<HUAWEI> system-view 
[HUAWEI] sysname Switch 
[Switch] vlan batch 100 200 
[Switch] interface gigabitethernet 0/0/1 
[Switch-GigabitEthernet0/0/1] port link-type access 
[Switch-GigabitEthernet0/0/1] quit 
[Switch] interface gigabitethernet 0/0/2 
[Switch-GigabitEthernet0/0/2] port link-type access 
[Switch-GigabitEthernet0/0/2] quit 
[Switch] interface gigabitethernet 0/0/3 
[Switch-GigabitEthernet0/0/3] port link-type access 
[Switch-GigabitEthernet0/0/3] quit 
[Switch] vlan 100 
[Switch-vlan100] port gigabitethernet 0/0/1 to 0/0/3 
[Switch-vlan100] quit 


                               Paso 2     Configure GE0/0/4 y GE0/0/5.

# Deshabilite STP, RSTP, VBST o MSTP en GE0/0/4 y GE0/0/5

[Switch] interface gigabitethernet 0/0/4 
[Switch-GigabitEthernet0/0/4] undo stp enable   
[Switch-GigabitEthernet0/0/4] quit 
[Switch] interface gigabitethernet 0/0/5 
[Switch-GigabitEthernet0/0/5] undo stp enable   
[Switch-GigabitEthernet0/0/5] quit

# Agregue las interfaces a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

[Switch] interface gigabitethernet 0/0/4 
[Switch-GigabitEthernet0/0/4] port link-type access 
[Switch-GigabitEthernet0/0/4] port default vlan 100 
[Switch-GigabitEthernet0/0/4] quit 
[Switch] interface gigabitethernet 0/0/5 
[Switch-GigabitEthernet0/0/5] port link-type access 
[Switch-GigabitEthernet0/0/5] port default vlan 200 
[Switch-GigabitEthernet0/0/5] quit

                               Paso 3     Configure una dirección IP para VLANIF 200 que funcione como la gateway del clúster NLB.

[Switch] interface vlanif 200 
[Switch-Vlanif200] ip address 10.128.246.250 24 
[Switch-Vlanif200] quit 


                               Step 4     Conecte GE0/0/4 y GE0/0/5.

Después de las configuraciones previas, conecte los enlaces físicos.

                               Step 5     Verifique la configuración.

Verifque que desde el Server_1 al Server_3 puedan recibir paquetes destinados al cluster NLB.

----Fin

Archivos de Configuración

Archivo de Configuración del Switch


sysname Switch 

vlan batch 100 200 
#                                                                                
interface Vlanif200                                                              
 ip address 10.128.246.250 255.255.255.0                                         
#                                                                                
interface GigabitEthernet0/0/1               
 port link-type access                                                           
 port default vlan 100                                                 
#  
interface GigabitEthernet0/0/2               
 port link-type access                                                           
 port default vlan 100                                                   
#                                                                                
interface GigabitEthernet0/0/3               
 port link-type access                                                           
 port default vlan 100                                                   
#                                                                                
interface GigabitEthernet0/0/4               
 port link-type access                                                           
 port default vlan 100                                                           
 stp disable                                                                     
#  
interface GigabitEthernet0/0/5               
 port link-type access                                                           
 port default vlan 200                                                           
 stp disable                                                                     
#  
return 

 

 


  • x
  • convención:

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje