Ejemplo para Conectar los teléfonos IP a los switches a través del PVID del Voice VLAN ID

64 0 0 0

Visión general

Si un dispositivo de voz envía paquetes con paquetes de etiqueta 0 o no etiquetados, el PVID de una interfaz se puede agregar a los paquetes de voz. Luego se aumenta la prioridad de los paquetes de voz en función de la ID de VLAN.

Notas de configuración

l   Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Cisco 7912 y Cisco 7940G, y Cisco 7960G phones son PDs no estándar. Si se requiere un switch para proporcionar PoE, ejecute thepoe legacy enablecommand en las interfaces del switch conectado a los teléfonos IP para permitir la detección de compatibilidad para PDs en el PSE.

l   Cisco SPA 303 y Linksys SPA 921 teléfonos do no soportan PoE, por lo que es necesario conectar Cisco SPA 303 y Linksys SPA 921 teléfonos to fuentes de alimentación externas and y luego conectarlos a los switches.

l   Para los teléfonos Mitel 5212, la opción 128, la opción 129, la opción 130 y la opción 131 deben configurarse en el pool de direcciones del servidor DHCP; de lo contrario, los teléfonos Mitel 5212 no pueden identificar la oferta DHCP packets enviada por el servidor DHCP o ir en línea. La configuración del interruptor es la siguiente:

<HUAWEI> system-view 
[HUAWEI] ip pool ip-phone 
[HUAWEI-ip-pool-ip-phone] option 128 ip-address 10.20.20.1 
[HUAWEI-ip-pool-ip-phone] option 129 ip-address 11.20.20.1 
[HUAWEI-ip-pool-ip-phone] option 130 ascii MITEL IP PHONE 
[HUAWEI-ip-pool-ip-phone] option 131 ip-address 11.20.20.1 


Teléfonos IP aplicables

Ver "1.3 modos de interconexión soportados por diferentes modelos de teléfonos IP".

 

Requerimientos de networking

Infigure 1-11:

l   Los teléfonos IP sólo pueden enviar paquetes de voz no etiquetados.

l   Es necesario aumentar la prioridad de los paquetes de voz para garantizar la calidad de la comunicación.

l   Los paquetes de voz se transmiten en 100 VLAN.

l   Las direcciones IP de los teléfonos IP y la dirección IP del servidor DHCP se encuentran en diferentes segmentos de red.

l   Los teléfonos IP deben conectarse a los switches a través de la autenticación MAC address.

Conexión de teléfonos IP a switches a través del PVID de la ID de VLAN de voz


073436fteebq0t5ldde509.png?image.png




Configuration Roadmap.

El roadmap de configuración es el siguiente:

 

1. Añadir una interfaz a a VLAN en modo untagged para que los paquetes de voz se reenvíen en la VLAN.

2. Habilitar la función VLAN de voz en una interfaz y configurar el PVID de la interfaz a la ID de VLAN de voz.

3. Configurar las funciones del servidor DHCP relay y DHCP para que las direcciones IP se asignen a los teléfonos IP.

4. Configurar la autenticación de direcciones MAC para teléfonos IP. (Este paso puede ser ignorado si no se requiere autenticación.)

Procedimiento

STEP1 Agregar una interfaz en SwitchA to a VLAN

# create VLAN 100

<HUAWEI> system-view 
[HUAWEI] sysname SwitchA 
[SwitchA] vlan batch 100  //Configure VLAN 100 in which voice traffic is transmitted. 


# Añadir una interfaz a VLAN 100 en modo sin etiquetar.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid   //In V200R005C00 and later versions, the default link type of an interface is not hybrid, and needs to be manually configured. 
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100  //Packets sent by IP phones do not carry tags, so the interface must be join VLAN 100 in untagged mode. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100 
[SwitchA-GigabitEthernet1/0/2] quit 


STEP 2 Habilitar la función VLAN de voz en una interfaz de SwitchA y configurar el PVID de la interfaz a la ID de VLAN de voz.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] voice-vlan 100 enable  //Enable the voice VLAN function on the interface. 
[SwitchA-GigabitEthernet1/0/1] voice-vlan remark-mode mac-address  //In V200R003 and later versions, the interface needs to be configured to identify voice packets based on MAC addresses. This configuration is not required in earlier versions of V200R003. 
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100  //Configure the PVID. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2  //The configuration of GE1/0/2 is similar to the configuration of GE1/0/1. 
[SwitchA-GigabitEthernet1/0/2] voice-vlan 100 enable 
[SwitchA-GigabitEthernet1/0/2] voice-vlan remark-mode mac-address 
[SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100 
[SwitchA-GigabitEthernet1/0/2] quit 
[SwitchA] voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
[SwitchA] voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000

Paso 3 Configure la función DHCP relay y el servidor DHCP.

1. Configure la función DHCP relay en SwitchA.

# Configure el relé DHCP function en una interfaz.

[SwitchA] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled. 

[SwitchA] interface Vlanif 100  //Create VLANIF 100. 

[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Assign an IP address to VLANIF 100. 

[SwitchA-Vlanif100] dhcp select relay  //Enable the DHCP relay function on VLANIF 100. 

[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure the DHCP server address on the DHCP relay agent. 

[SwitchA-Vlanif100] quit 


# Crear VLANIF 200

[SwitchA] vlan batch 200 

[SwitchA] interface Vlanif 200 

[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure an IP address for VLANIF 200 for communication with SwitchB. 

[SwitchA-Vlanif200] quit 

# Añadir la interfaz uplink a 200 de VLAN.

[SwitchA] interface gigabitethernet 1/0/3 

[SwitchA-GigabitEthernet1/0/3] port link-type hybrid 

[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200 

[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200 

[SwitchA-GigabitEthernet1/0/3] quit 


# Configure una ruta estática predeterminada.

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //The next hop address of the route corresponds to the IP address of VLANIF 200 on SwitchB. 



2. Configure SwitchB como servidor DHCP para asignar direcciones IP a teléfonos IP.

# Configure un pool de direcciones.

<HUAWEI> system-view 

[HUAWEI] sysname SwitchB 

[SwitchB] ip pool ip-phone  //Create an address pool. 

[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure the gateway address on the DHCP server. 

[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure allocatable IP addresses in the IP address pool. 

[SwitchB-ip-pool-ip-phone] quit 



# Configure la función del servidor DHCP.

[SwitchB] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled. 
[SwitchB] vlan batch 200 
[SwitchB] interface Vlanif 200  //Create VLANIF 200. 
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Assign an IP address to VLANIF 200. 
[SwitchB-Vlanif200] dhcp select global  //Configure SwitchB to allocate IP addresses from the global IP address pool to the IP phone. 
[SwitchB-Vlanif200] quit 


# Añadir la interfaz downlink a la VLAN 200

[SwitchB] interface gigabitethernet 1/0/3 
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid 
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200 
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200 
[SwitchB-GigabitEthernet1/0/3] quit

# Configure una ruta de retorno.

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

Paso 4 Configure un dominio de autenticación y autenticación de direcciones MAC para teléfonos IP.

1. Configure un dominio de autenticación.

# Crear y configurar una plantilla de servidor RADIUS.

[SwitchA] radius-server template cisco  //Create a RADIUS server template named cisco
[SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812  //Configure the IP address and port number of the RADIUS authentication server. 
[SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813  //Configure the IP address and port number of the RADIUS accounting server. 
[SwitchA-radius-cisco] quit 


# Configure un esquema de autenticación.

[SwitchA] aaa 
[SwitchA-aaa] authentication-scheme radius  //Create an authentication scheme named radius
[SwitchA-aaa-authen-radius] authentication-mode radius  //Set the authentication mode to RADIUS. 
[SwitchA-aaa-authen-radius] quit 


# Crear un dominio de autenticación y vincular la plantilla de servidor RADIUS y el esquema de autenticación al dominio de autenticación.

[SwitchA-aaa] domain default  //Configure a domain named default
[SwitchA-aaa-domain-default] authentication-scheme radius  //Bind the authentication scheme radiusto the domain. 
[SwitchA-aaa-domain-default] radius-server cisco  //Bind the RADIUS server template cisco to the domain. 
[SwitchA-aaa-domain-default] quit 
[SwitchA-aaa] quit 


2. Configure la autenticación de direcciones MAC para teléfonos IP y PC.

           V200R007C00 y versiones anteriores, y V200R008C00

# Configure el modo NAC como unificado.

[SwitchA] authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

# Habilitar autenticación de direcciones MAC en una interfaz.

[SwitchA] interface gigabitethernet 1/0/1 


[SwitchA-GigabitEthernet1/0/1] authentication mac-authen  //Enable MAC address authentication. [SwitchA-GigabitEthernet1/0/1] quit 

[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] authentication mac-authen 
[SwitchA-GigabitEthernet1/0/2] quit 


  V200R009C00 y versiones posteriores

# Configure el modo NAC como unificado.

[SwitchA] authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

# Configure un perfil de acceso MAC.

[SwitchA] mac-access-profile name cisco  //Create a MAC access profile named cisco
[SwitchA-mac-access-profile-cisco] quit

# Configure un perfil de autenticación.

[SwitchA] authentication-profile name cisco  //Configure an authentication profile. 
[SwitchA-authen-profile-cisco] mac-access-profile cisco  //Bind the MAC access profile cisco to the authentication profile. 
[SwitchA-authen-profile-cisco] quit

# Aplicar el perfil de autenticación a la interfaz.

[SwitchA] interface gigabitethernet 1/0/1 
[SwitchA-GigabitEthernet1/0/1] authentication-profile cisco  //Bind the authentication profile and enable MAC address authentication. 
[SwitchA-GigabitEthernet1/0/1] quit 
[SwitchA] interface gigabitethernet 1/0/2 
[SwitchA-GigabitEthernet1/0/2] authentication-profile cisco 
[SwitchA-GigabitEthernet1/0/2] quit 


3. Configurar el Agile Controller La visualización del Agile Controller varía dependiendo de las versiones. V100R002C10SPC401 se utiliza como ejemplo.

A. Log en el Agile Controller

Abra el Explorador de Internet, introduzca la dirección de acceso Agile Controller en la barra de direcciones y presione.

Ingrese el nombre de usuario y la contraseña del administrador. Si inicia sesión en el controlador Agile por primera vez, utilice el usuario superadministrador nameadminand password Changeme123 Cambie la contraseña inmediatamente después de iniciar sesión. De lo contrario, no se puede utilizar el Agile Controller.

Se pueden utilizar los siguientes modos de acceso del Agile Controller.

Modo de acceso

Descripción

Https://Agile   Controller-IP: 8443

Agile   Controller-IPespecifica la dirección IP del Agile Controller

Dirección   IP del Agile Controller

Si   el puerto 80 está habilitado durante la instalación, puede acceder al Agile   Controller introduciendo su dirección IP sin el número de puerto. La URL del   Agile Controller se cambiará automáticamente a https://Agile Controller-IP:   8443.

 

B.Agregar una dirección MAC.

I. Elegir Resource > User > User Management

Ii. Seleccionar All Accounts.

Iii .Click Add para crea una cuenta MAC. El valor de Mac contabiliza la dirección MAC del teléfono IP.


073732byazfrwwyf6rnwf8.png?image.png



C.Add SwitchA al Agile Controller

I. Elegir Resource > device > device management.

Ii .Click Add en añadir Device page, agregue Switch A utilizado para autenticar los teléfonos IP.



073911y8o72fwp2oxxf74x.png?image.png

D. Agregar un teléfono IP al Agile Controller

I. Elegir Resource > Terminal > Terminal List

II. Click Add para acceder a la página Agregar dispositivo.

III. En la página para agregar un dispositivo en el grupo, agregue un grupo IP phone.



073945w2fff0ij0880fcyr.png?image.png


IV. Haga clic en un grupo de dispositivos, seleccione cisco_ipphone y seleccione Device List, y de click en Add para añada un teléfono IP.



074025baerouyaumbmrw09.png?image.png




E. Agregar una regla de autenticación.

Seleccione Policy > Permission Control > Authentication & Authorization > Authentication Rule y de click en Add para crear una regla de autenticación.




074048ly0npqrilh6v2fan.png?image.png



F. Agregar un resultado de autorización.

Seleccione Policy > Permission Control > Authentication & Authorization > Authorization Rule y de click en Add para crear un resultado de autorización.




075528cr1kwaoxj12ll91z.png?image.png



Paso 5 Verifique la configuración.

l   Los teléfonos IP pueden obtener la ID de VLAN de voz y las direcciones IP.

l   La comando display access-user en el SwitchA muestra la información de conexión sobre los teléfonos IP.

 

----End

Archivos de configuración

l   Archivo de configuración SwitchA (V200R007C00 y versiones anteriores, y V200R008C00) 

 


sysname SwitchA 

voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000 

vlan batch 100 200 

dhcp enable 

radius-server template cisco 
 radius-server authentication 192.168.6.182 1812 weight 80 
 radius-server accounting 192.168.6.182 1813 weight 80 

aaa 
 authentication-scheme radius 
  authentication-mode radius 
 domain default 
  authentication-scheme radius 
  radius-server cisco 

interface Vlanif100 
 ip address 10.20.20.1 255.255.255.0 
 dhcp select relay 
 dhcp relay server-ip 10.10.20.2 

interface Vlanif200 
 ip address 10.10.20.1 255.255.255.0 

interface GigabitEthernet1/0/1        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication mac-authen 

interface GigabitEthernet1/0/2        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication mac-authen 

interface GigabitEthernet1/0/3        
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 

ip route-static 0.0.0.0 0.0.0.0 10.10.20.2 

return 


l   Archivo de configuración de SwitchA (V200R009C00 y versiones posteriores)


sysname SwitchA 

voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000 
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000 

vlan batch 100 200 

authentication-profile name cisco 
 mac-access-profile cisco 

dhcp enable 

radius-server template cisco 
 radius-server authentication 192.168.6.182 1812 weight 80 
 radius-server accounting 192.168.6.182 1813 weight 80 

aaa 
 authentication-scheme radius 
  authentication-mode radius 
 domain default 
  authentication-scheme radius 
  radius-server cisco 

interface Vlanif100 
 ip address 10.20.20.1 255.255.255.0 
 dhcp select relay 
 dhcp relay server-ip 10.10.20.2 

interface Vlanif200 
 ip address 10.10.20.1 255.255.255.0 

interface GigabitEthernet1/0/1        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication-profile cisco 

interface GigabitEthernet1/0/2        
 port link-type hybrid 
 voice-vlan 100 enable 
 voice-vlan remark-mode mac-address 
 port hybrid pvid vlan 100 
 port hybrid untagged vlan 100 
 authentication-profile cisco 

interface GigabitEthernet1/0/3        
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 

ip route-static 0.0.0.0 0.0.0.0 10.10.20.2 

mac-access-profile name cisco 

return 


l   Archivo de configuración SwitchB


sysname SwitchB 

vlan batch 200 

dhcp enable 

ip pool ip-phone 
 gateway-list 10.20.20.1  
 network 10.20.20.0 mask 255.255.255.0  

interface Vlanif200 
 ip address 10.10.20.2 255.255.255.0 
 dhcp select global 

interface GigabitEthernet1/0/3 
 port link-type hybrid 
 port hybrid pvid vlan 200 
 port hybrid untagged vlan 200 

ip route-static 10.20.20.0 255.255.255.0 10.10.20.1 

return 







  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje