Ejemplo de Establecimiento de un túnel IPSec entre un AR y un router Cisco en modo agresivo IKEv1

100 0 0 0

Especificaciones


Este ejemplo se aplica a todas las versiones y Routers.

Este ejemplo se aplica a los Routers de todas las versiones.

Requisitos de red

Como se muestra en la Figura 1-1, RouterA es la puerta de enlace del branch, y RouterB es la puerta de enlace de la sede de la empresa (Router de Cisco). La sucursal y la sede se comunican a través de la red pública.

La empresa quiere proteger los flujos de datos entre la subred de sucursal y la subred de la sede. Se puede configurar un túnel IPSec entre la puerta de enlace de la sucursal y la puerta de enlace de la sede porque se comunican a través de Internet.


Figura 1-1 Conexión en red para establecer un túnel IPSec entre el AR y el Router de Cisco en modo agresivo IKEv1  


Procedimiento

                      Paso 1    Configurar RouterA.



sysname RouterA 

ipsec authentication sha2 compatible enable 

 ike local-name huawei 
 # 
 acl number 3000  //Especificar flujo de datos 
 rule 5 permit ip source 10.1.1.0 0.0.0.255 destination 10.1.2.0 0.0.0.255 
 # 
 ipsec proposal prop1 
 esp authentication-algorithm sha2-256 
 esp encryption-algorithm aes-128 
 # 
 ike proposal 1 
 encryption-algorithm aes-cbc-128   //En la V200R008 el parametro aes-cbc-128 es cambiado a aes-128. 
dh group14 

authentication-algorithm sha2-256 

ike peer peer1 v1 
 exchange-mode aggressive  //Configurar modo agresivo 
 pre-shared-key cipher %@%@W'KwGZ8`tQ8s^C8q(qC"0(;@%@%@%#%#@W4p8i~Mm5sn;9Xc&U#(cJC;.CE|qCD#jAH&/#nR%#%#  //Configure the pre-shared key as huawei@1234. 
 ike-proposal 1 
 local-id-type name    
 remote-name RouterB  
 remote-address 60.1.2.1 

ipsec policy policy1 10 isakmp  //Configurar politica IPSec
 security acl 3000  
 ike-peer peer1 
 proposal prop1 

interface GigabitEthernet0/0/1 
 ip address 60.1.1.1 255.255.255.0 
 ipsec policy policy1    

interface GigabitEthernet0/0/2 
 ip address 10.1.1.1 255.255.255.0 

ip route-static 0.0.0.0 0.0.0.0 60.1.1.2 

return

                      Paso 2    Configurar RouterB.


hostname RouterB 

crypto isakmp policy 1 
 encryption aes 128 
 hash sha256 
 authentication pre-share 
 group 14 
crypto isakmp key huawei@1234 hostname huawei   

crypto isakmp identity hostname  

crypto ipsec transform-set p1 esp-sha256-hmac esp-aes 128 

crypto map p1 1 ipsec-isakmp 
 set peer 60.1.1.1 
 set transform-set p1 
 match address 102 


interface GigabitEthernet0/0 
 ip address 60.1.2.1 255.255.255.0 
 duplex auto 
 speed auto 
 crypto map p1    

interface GigabitEthernet0/1 
 ip address 10.1.2.1 255.255.255.0 
 duplex auto 
 speed auto 


ip route 0.0.0.0 0.0.0.0 60.1.2.2 

access-list 102 permit ip 10.1.2.0 0.0.0.255 10.1.1.0 0.0.0.255

end

                      Paso 3    Verificar la configuración



# Ping de PCA a PCB



 




  • x
  • convención:

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje