De acuerdo

Configurar L2TP para la comunicación entre dos sucursales

Última respuesta dic. 08, 2020 08:40:09 170 2 0 0 0

Como se muestra en la Imagen, los usuarios de las sucursales 1 y 2 propios de la LAN1 y 2 se conectan a LAC mediante PPPoE e inician conexiones con LAN 3.

topo

Dos dominios están configurados en LAC: aaa.com y bbb.com. Los usuarios en el dominio aaa.com se encuentran en el segmento de red 10.1.1.0/24 y los usuarios en el dominio bbb.com están ubicados en el segmento de red 10.2.1.0/24.

 

Hay una ruta accesible desde LNS hasta LAC y se establece un túnel entre LNS y LAC.

 

Después de que los usuarios de acceso sean autenticados, el LNS asigna direcciones IP y direcciones de gateway a los usuarios de acceso.

 

Paso 1 Configure el LAC.

#

sysname LAC

 

#

l2tp enable    //Habilite L2TP.

 

#

aaa

authentication-scheme lmt

domain aaa.com

authentication-scheme lmt

domain bbb.com

authentication-scheme lmt

local-user user1@aaa.com password cipher xxxxxxx

local-user user1@aaa.com service-type ppp

local-user user1@aaa.com privilege level 0

local-user user2@bbb.com password cipher xxxxxxx

local-user user2@bbb.com privilege level 0

local-user user2@bbb.com service-type ppp    //Configure nombres de usuario y contraseñas locales en el servidor de PPPoE.

 

#

interface Virtual-Template1    //Cree una interfaz virtual VT1 y establezca parámetros para el servidor de PPPoE.

 

ppp authentication-mode chap    //Establezca el modo de autenticación en CHAP.

 

#

interface GigabitEthernet1/0/0

ip address 202.1.1.2 255.255.255.0

 

#

interface GigabitEthernet2/0/0

pppoe-server bind Virtual-Template 1    //Habilite el servidor de PPPoE en la interfaz, importe los parámetros configurados en VT1, y autentique usuarios de acceso telefónico.

 

#

interface GigabitEthernet3/0/0

pppoe-server bind Virtual-Template 1

 

#

l2tp-group 1    //Cree un grupo de L2TP y configure los parámetros para la configuración de L2TP.

tunnel password cipher xxxxxx    //Habilite la autenticación de túnel y establezca la contraseña de cifrado en huawei, que es lo mismo que en el dispositivo peer.

tunnel name lac1    //Establezca el nombre del túnel en lac1, que es identificado por el LNS peer.

start l2tp ip 202.1.1.1 domain aaa.com    //Inicie la configuración del túnel de

L2TP en el dispositivo peer.

 

#

l2tp-group 2

tunnel password cipher xxxxxx

tunnel name lac2

start l2tp ip 202.1.1.1 domain bbb.com

 

 

Paso 2 Configure el LNS.

 

#

sysname LNS

 

#

l2tp enable

 

#

ip pool 1    //Cree el grupo 1 de direcciones IP desde el cual se asignan las direcciones IP para acceder a los usuarios.

gateway-list 10.1.1.1    //Configure la dirección de gateway.

network 10.1.1.0 mask 255.255.255.0    //Especifique el rango de direcciones IP.

 

#

ip pool 2

gateway-list 10.2.1.1

network 10.2.1.0 mask 255.255.255.0

 

 

#

aaa

local-user user1@aaa.com password cipher xxxxxx

local-user user1@aaa.com privilege level 0

local-user user1@aaa.com service-type ppp

local-user user2@bbb.com password cipher xxxxxx

local-user user2@bbb.com privilege level 0

local-user user2@bbb.com service-type ppp

 

#

interface Virtual-Template1

ppp authentication-mode chap

remote address pool 1   //Importe el grupo de direcciones IP. El servidor de

PPPoE luego asigna direcciones IP del grupo de direcciones IP a los usuarios autenticados.

ip address 10.1.1.1 255.255.255.0    //Configure la dirección del gateway para el pool de direcciones.

 

#

interface Virtual-Template2

ppp authentication-mode chap

remote address pool 2

ip address 10.2.1.1 255.255.255.0

 

#

interface GigabitEthernet1/0/0

ip address 202.1.1.1 255.255.255.0

 

#

interface GigabitEthernet2/0/0

ip address 10.3.1.1 255.255.255.0

 

#

l2tp-group 1

allow l2tp virtual-template 1 remote lac1    //Especifique el nombre del extremo remoto del túnel.

tunnel password cipher xxxxxxx

tunnel name lns

 

#

l2tp-group 2

allow l2tp virtual-template 2 remote lac2

tunnel password cipher xxxxxxx

tunnel name lns


  • x
  • convención:

marthasanch
Publicado 2020-12-8 08:40:09
Excelente informacion Configurar L2TP para la comunicación entre dos sucursales-3616667-1
Ver más
  • x
  • convención:

edimargo
edimargo Publicado 2020-12-13 06:51 (0) (0)
 

Comentar

Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse
Responder

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.
Recordatorio
Agrega tu número de teléfono para obtener un bono de invitación.