Configurar CSS y VS para implementación en una red de centro de datos con Switches Cloud Engine

Última respuesta Sep 02, 2019 11:48:19 61 1 2 0

Buen día Comunidad Huawei Enterprise, comparto con Ustedes el siguiente ejemplo de configuración de CSS y VS para implantación en una red de centro de datos.

 

En una red de centro de datos, como se muestra en el siguiente diagrama de red, dos CE12800 en la capa de core configuran un CSS para simplificar la estructura de la red y mejorar la confiabilidad. La tecnología VS se usa para virtualizar el CSS en dos switches independientes. Los dos switches sirven como el núcleo de la zona de oficina y la zona de producción para proporcionar un reenvío de servicios independiente y aislar los servicios y el tráfico de diferentes zonas. De esta manera, se mejora la seguridad y la confiabilidad. Los gateways de los servidores se despliegan en VS. Varios CE6800 en la capa de acceso configuran dos sistemas de iStack y se conectan a los CE12800 a través de Eth-Trunks entre switches para evitar bucles de capa 2.

Sin título

Pasos para realizar el procedimiento de configuración.

 

1.    Configurar la función CSS en los switches core CE12800-1 y CE12800-2.

a.    Conectar los cables de stack entre CE12800-1 y CE12800-2 de acuerdo al siguiente diagrama.

Sin título

b. Configurar los atributos de stack para CE12800-1 y CE12800-2. (Establezca una prioridad más alta para CE12800-1, entonces CE12800-1 se convertirá en el switch maestro.)

 

# Establecer el ID de stack de CE12800-1 en 1, la prioridad en 150, el ID de dominio en 10 y el modo de conexión en la conexión MPU.

<HUAWEI> system-view

[~HUAWEI] sysname CE12800-1

[*HUAWEI] commit

[~CE12800-1] stack

[~CE12800-1-stack] stack member 1         //Configurar el ID de miembro de stack. El valor predeterminado es 1.

[*CE12800-1-stack] stack priority 150     //Configurar la prioridad de stack. El valor predeterminado es 100.

[*CE12800-1-stack] stack domain 10        //Configurar el ID de dominio.

[*CE12800-1-stack] stack link-type mainboard-direct     //Configure el modo de conexión. El modo predeterminado es mainboard-direct.

[*CE12800-1-stack] quit

[*CE12800-1] commit

 

# Establecer el ID de stack de CE12800-2 en 2, la prioridad en 100, el ID de dominio en 10 y el modo de conexión en la conexión MPU.

<HUAWEI> system-view
[~HUAWEI] sysname CE12800-2
[*HUAWEI] commit
[~CE12800-2] stack
[~CE12800-2-stack] stack member 2
Warning: The device will use the configuration of member ID 2 after the device resets. Continue? [Y/N]: y
[*CE12800-2-stack] stack priority 100
[*CE12800-2-stack] stack domain 10
[*CE12800-2-stack] stack link-type mainboard-direct
[*CE12800-2-stack] quit
[*CE12800-2] commit


c. Configurar los puertos de stack. Los dos switches están conectados por ocho puertos ópticos 10GE en diferentes LPU.

# En CE12800-1, agregamos 10GE1/0/1-10GE1/0/4 y 10GE2/0/1-10GE2/0/4 al puerto de stack.

[~CE12800-1] port-group group1       //Creamos un grupo de puertos.
[*CE12800-1-port-group-group1] group-member 10ge 1/0/1 to 10ge 1/0/4       //Agregamos puertos a un grupo de puertos.
[*CE12800-1-port-group-group1] group-member 10ge 2/0/1 to 10ge 2/0/4
[*CE12800-1-port-group-group1] shutdown       //Apagamos el puerto.
[*CE12800-1-port-group-group1] quit
[*CE12800-1] commit
[~CE12800-1] interface stack-port 1
[*CE12800-1-Stack-Port1] port member-group interface 10ge 1/0/1 to 1/0/4       //Agregamos puertos físicos al puerto de stack.
[*CE12800-1-Stack-Port1] port member-group interface 10ge 2/0/1 to 2/0/4
[*CE12800-1-Stack-Port1] quit
[*CE12800-1] commit
[~CE12800-1] port-group group1
[~CE12800-1-port-group-group1] undo shutdown       //Habilitamos el puerto.
[*CE12800-1-port-group-group1] quit
[*CE12800-1] commit
[~CE12800-1] return


# El procedimiento de configuración en CE12800-2 es el mismo que el procedimiento de configuración en CE12800-1, por tal motivo la configuración no la mostrare aquí.

 

d. Habilitamos la función de stack.

 

# Habilitamos la función de stack en CE12800-1 y reiniciamos el switch.

<CE12800-1> save
Warning: The current configuration will be written to the device. Continue? [Y/N]: y
<CE12800-1> system-view
[~CE12800-1] stack
[~CE12800-1-stack] stack enable
Warning: Make sure that one or more dual-active detection methods are configured once the conversion is complete and the device enters the stack mode.
Current configuration will be converted to the next startup saved-configuration file of stack mode.
System will reboot. Continue? [Y/N]: y

# Habilitamos la función de stack en CE12800-2 y reiniciamos el switch. 

<CE12800-2> save
Warning: The current configuration will be written to the device. Continue? [Y/N]: y
<CE12800-2> system-view
[~CE12800-2] stack
[~CE12800-2-stack] stack enable
Warning: Make sure that one or more dual-active detection methods are configured once the conversion is complete and the device enters the stack mode.
Current configuration will be converted to the next startup saved-configuration file of stack mode.
System will reboot. Continue? [Y/N]: y

e. Renombramos el sistema de stack a CSS.

<CE12800-1> system-view
[~CE12800-1] sysname CSS
[*CE12800-1] commit

2. Configurar iStack en los switches de acceso. Lo siguiente usa CE6800-1 y CE6800-2 como ejemplo.

 

a.    Configurar los atributos de stack para CE6800-1 y CE6800-2. (Establezcer una prioridad más alta para CE6800-1, entonces CE6800-1 se convertirá en el switch maestro.)

 

# En CE6800-1, establecer ID de stack en 1, prioridad en 150 e ID de dominio en 20. (Por defecto, el ID de miembro de stack de un switch es 1. En este ejemplo, CE6800-1 conserva el ID de miembro de stack predeterminada 1 y no debe configurarse este parámetro.)

<HUAWEI> system-view
[~HUAWEI] sysname CE6800-1
[*HUAWEI] commit
[~CE6800-1] stack
[~CE6800-1-stack] stack member 1 priority 150
[*CE6800-1-stack] stack member 1 domain 20
[*CE6800-1-stack] quit
[*CE6800-1] commit

# En CE6800-2, establezca el ID de pila en 2 y el ID de dominio en 20.

<HUAWEI> system-view
[~HUAWEI] sysname CE6800-2
[*HUAWEI] commit
[~CE6800-2] stack
[~CE6800-2-stack] stack member 1 renumber 2 inherit-config
Warning: The stack configuration of member ID 1 will be inherited to member ID 2 after the device resets. Continue? [Y/N]: y
[*CE6800-2-stack] stack member 1 priority 100
[*CE6800-2-stack] stack member 1 domain 20
[*CE6800-2-stack] quit
[*CE6800-2] commit

b. Configurar los puertos de stack. Dos switches están conectados por cuatro puertos ópticos 10GE.

 

# En CE6800-1, agregamos 10GE1/0/1-10GE1/0/4 al puerto de stack 1/1.

[~CE6800-1] interface stack-port 1/1
[*CE6800-1-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/4
Warning: The interface(s) (10GE1/0/1-1/0/4) will be converted to stack mode. [Y/N]: y
[*CE6800-1-Stack-Port1/1] quit
[*CE6800-1] commit

# El procedimiento de configuración en CE6800-2 es el mismo que en CE6800-1, motivo por el cual no se mostrara la configuración aquí.

 

c. Guardamos las configuraciones de CE6800-1 y CE6800-2, apagamos los dos switches, conectamos los cables de stack y encendemos los switches.

 

d. Renombramos el sistema de stack a iStack-1. CE6800-1 funciona como el switch maestro en este ejemplo.

 

<CE6800-1> system-view
[~CE6800-1] sysname iStack-1
[*CE6800-1] commit


e. Configuramos stack que consta de CE6800-3 y CE6800-4 según las configuraciones anteriores. Renombramos el sistema de stack a iStack-2. CE6800-3 funciona como el switch maestro en este ejemplo.

 

3. Configuramos DAD en modo directo en CSS e iStacks para garantizar una alta confiabilidad. A continuación, se usa la configuración de DAD en modo directo en el CSS como ejemplo.

 

# Configuramos DAD en modo directo en las interfaces directamente conectadas entre los dos switches en el CSS.

[~CSS] interface interface 10ge 1/1/0/10
[~CSS-10GE1/1/0/10] dual-active detect mode direct          //10GE1/1/0/10 está directamente conectado a 10GE2/1/0/10.
Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
[*CSS-10GE1/1/0/10] quit
[*CSS] interface interface 10ge 2/1/0/10
[*CSS-10GE2/1/0/10] dual-active detect mode direct
Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
[*CSS-10GE2/1/0/10] quit
[*CSS] interface interface 10ge 1/2/0/10
[*CSS-10GE1/2/0/10] dual-active detect mode direct          //10GE1/2/0/10 está directamente conectado a 10GE2/2/0/10.
Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
[*CSS-10GE1/2/0/10] quit
[*CSS] interface interface 10ge 2/2/0/10
[*CSS-10GE2/2/0/10] dual-active detect mode direct
Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
[*CSS-10GE2/2/0/10] quit
[*CSS] commit

# Configuramos DAD en modo directo en iStack de acuerdo con el método anterior, por tal motivo la configuración no se muestra aquí.

 

4. Dividimos CSS en la capa de core en VS1 y VS2.

 

NOTA:

La función de VS está controlada por una licencia. Por defecto, la función de VS está desactivada en un switch nuevo. Para usar la función de VS, solicite y compre la licencia  con un partner Huawei de su localidad.

 

# Creamos VS1 y VS2 en el modo de grupo de puertos, asignamos los últimos 24 puertos 10GE en LPU en las ranuras 1/1 y 2/1 a VS1 y los últimos 24 puertos 10GE en LPU en las ranuras 1/2 y 2/2 a VS2.

[~CSS] admin
[~CSS-admin] virtual-system vs1          //Creamos VS1.
[*CSS-admin-vs:vs1] port-mode group          //Configuramos VS1 como un grupo de puertos de VS.
[*CSS-admin-vs:vs1] assign interface 10ge 1/1/0/47          //Asignamos puertos físicos a VS1.
Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
[*CSS-admin-vs:vs1] assign interface 10ge 2/1/0/47
Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
[*CSS-admin-vs:vs1] quit
[*CSS-admin] virtual-system vs2          //Creamos VS2.
[*CSS-admin-vs:vs2] port-mode group
[*CSS-admin-vs:vs2] assign interface 10ge 1/2/0/47
Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
[*CSS-admin-vs:vs2] assign interface 10ge 2/2/0/47
Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
[*CSS-admin-vs:vs2] commit
[~CSS-admin-vs:vs2] return

 NOTA:

Antes de asignar puertos físicos a un VS en modo de grupo de puertos, ejecutamos el comando display device port-map [slot slot-id] en la vista del usuario o del sistema para comprobar la asignación entre reenvío de chips y puertos y determinar cuáles puertos se asignarán al VS.

 

# Configuramos las direcciones IP de administración y las cuentas de administración para VS.

<CSS> switch virtual-system vs1          //Cambiamos de Admin-VS a VS1.
<CSS-vs1> system-view
[~CSS-vs1] interface MEth 0/0/0/0
[~CSS-vs1-MEth0/0/0/0] ip address 10.1.1.10 24          //Configuramos una dirección IP de interfaz de administración.
[*CSS-vs1-MEth0/0/0/0] quit
[*CSS-vs1] user-interface vty 0 4
[*CSS-vs1-vty0-4] authentication-mode aaa          //Configuramos el modo de autenticación de usuario.
[*CSS-vs1-vty0-4] user privilege level 3          //Configuramos el nivel de usuario.
[*CSS-vs1-vty0-4] quit
[*CSS-vs1] aaa
[*CSS-vs1-aaa] local-user vs1_user password cipher VS1_password          //Configuramos un nombre de usuario y contraseña.
[*CSS-vs1-aaa] local-user vs1_user service-type telnet
[*CSS-vs1-aaa] local-user vs1_user level 3
[*CSS-vs1-aaa] quit
[*CSS-vs1] undo telnet server disable          //Iniciamos el servicio de Telnet.
[*CSS-vs1] commit

# La configuración de VS2 es similar a la de VS1, motivo por el cual no se muestra la configuración aquí.

 

5. Configuramos los VS para conectarse a los dispositivos de flujo ascendente y descendente a través de Eth-Trunks entre switches. A continuación, se usa la configuración entre VS1 e iStack-1 como ejemplo.

 

# Creamos Eth-Trunk3 en VS1, y agregue 10GE1/1/0/47 y 10GE2/1/0/47 a Eth-Trunk3.

[~CSS-vs1] interface eth-trunk 3
[*CSS-vs1-Eth-Trunk3] description To_iStack-1
[*CSS-vs1-Eth-Trunk3] trunkport 10ge 1/1/0/47 2/1/0/47           //Agregamos puertos de miembro a Eth-Trunk3.
[*CSS-vs1-Eth-Trunk3] quit
[*CSS-vs1] commit

# Creamos Eth-Trunk3 en iStack-1, y agregue 10GE1/0/5 y 10GE2/0/5 a Eth-Trunk3.

[~iStack-1] interface eth-trunk 3
[*iStack-1-Eth-Trunk3] description To_vs1
[*iStack-1-Eth-Trunk3] trunkport 10ge 1/0/5 2/0/5
[*iStack-1-Eth-Trunk3] quit
[*iStack-1] commit

Las configuraciones de otros Eth-Trunks son similares a la configuración de Eth-Trunk3 motivo por el cual no se mencionan aquí.

 

6. Configuramos las VLAN en los VS e iStacks para la interconexión de capa 2.

 

# Configuramos la interfaz que conecta VS1 a iStack-1 para permitir que los paquetes de la VLAN 100 pasen.

[~CSS-vs1] vlan batch 100
[*CSS-vs1] interface eth-trunk 3
[*CSS-vs1-Eth-Trunk3] port link-type trunk
[*CSS-vs1-Eth-Trunk3] undo port trunk allow-pass vlan 1
[*CSS-vs1-Eth-Trunk3] port trunk allow-pass vlan 100
[*CSS-vs1-Eth-Trunk3] quit
[*CSS-vs1] commit

# Configuramos la interfaz que conecta iStack-1 a VS1 para permitir que los paquetes de la VLAN 100 pasen.

[~iStack-1] vlan batch 100
[*iStack-1] interface eth-trunk 3
[*iStack-1-Eth-Trunk3] port link-type trunk
[*iStack-1-Eth-Trunk3] undo port trunk allow-pass vlan 1
[*iStack-1-Eth-Trunk3] port trunk allow-pass vlan 100         //Configuramos Eth-Trunk3 para permitir que los paquetes de la VLAN100 pasen.
[*iStack-1-Eth-Trunk3] quit
[*iStack-1] commit

# Configuramos las interfaces que conectan VS2 e iStack-2 para permitir que los paquetes de la VLAN 100 pasen de acuerdo con las configuraciones anteriores, motivo por el cual las configuraciones no se muestran aquí.

 

7. Configuramos las direcciones IP para las interfaces.

 

# Configuramos las direcciones IP para las interfaces VLANIF que conectan VS a iStacks. A continuación, se usa la configuración de VS1 como ejemplo.

[~CSS-vs1] interface vlanif 100
[*CSS-vs1-Vlanif100] ip address 10.10.1.1 24          //Configuramos las direcciones IP para las interfaces VLANIF.
[*CSS-vs1-Vlanif100] quit
[*CSS-vs1] commit

# La configuración de VS2 es similar a la de VS1, motivo por el cual la configuración no se muestra aquí.

 

# Configuramos las direcciones IP para Eth-Trunk conectando VS al Router. A continuación, se usa la configuración de VS1 como ejemplo.

[~CSS-vs1] interface eth-trunk 1
[~CSS-vs1-Eth-Trunk1] undo portswitch          //Configuramos Eth-Trunk como una interfaz de capa 3.
[*CSS-vs1-Eth-Trunk1] ip address 10.10.10.1 24           //Configuramos una dirección IP para Eth-Trunk.
[*CSS-vs1-Eth-Trunk1] quit
[*CSS-vs1] commit

 

# Las configuraciones del router y VS2 son similares a las de VS1, motivo por el cual la configuración no se muestra aquí.

 

8. Configuramos un protocolo de enrutamiento entre los VS y los switches de enlace ascendente, y entre los VS y los switches de enlace descendente para la interconexión de capa 3.

 

# Ejecutamos OSPF entre VS y el router e importamos ls rutas directas a OSPF. A continuación, se usa la configuración de VS1 como ejemplo. La configuración de VS2 es similar a la de VS1, motivo por el cual n se mostrara la configuración aquí.

[~CSS-vs1] ospf 1           //Ejecutamos OSPF entre VS1 y el Router.
[*CSS-vs1-ospf-1] area 0
[*CSS-vs1-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
[*CSS-vs1-ospf-1-area-0.0.0.0] quit
[*CSS-vs1-ospf-1] import-route direct          //Importamos las rutas directas a OSPF.
[*CSS-vs1-ospf-1] commit
[~CSS-vs1-ospf-1] return

# Configuramos OSPF en el router. La configuración del router es similar a la de VS1, motivo por el cual no se muestra la configuración aquí.

 

Validamos de la configuración.

 

Una vez completadas las configuraciones anteriores, comprobamos si los servidores y el router pueden hacer ping entre sí (el gateway predeterminado debe estar configurado para servidores). A continuación, se usa la operación de ping de un servidor al Router como ejemplo.

 

PC> ping 10.10.10.2
 
Ping 10.10.10.2: 32 data bytes, Press Ctrl_C to break
From 10.10.10.2: bytes=32 seq=1 ttl=254 time=63 ms
From 10.10.10.2: bytes=32 seq=2 ttl=254 time=94 ms
From 10.10.10.2: bytes=32 seq=3 ttl=254 time=63 ms
From 10.10.10.2: bytes=32 seq=4 ttl=254 time=62 ms
From 10.10.10.2: bytes=32 seq=5 ttl=254 time=47 ms
 
--- 10.10.10.2 ping statistics ---
  5 packet(s) transmitted
  5 packet(s) received
  0.00% packet loss
  round-trip min/avg/max = 47/65/94 ms


Espero que con este ejemplo típico de configuración de CSS y VS para implementar en una red de centro de datos con switches Cloud Enginesea de gran utilidad.

 

Te invito a que me dejes un comentario y/o pregunta, lo antes posible estaría dando respuesta a ellas.

 

Saludos!

  • x
  • convención:

Gustavo.HdezF
Moderador Publicado 2019-9-2 11:48:19 Útil(0) Útil(0)
Gracias por compartir esta información con seguridad los usuarios del foro la encontraran útil. Saludos.
  • x
  • convención:

Ingeniero%20en%20Comunicaciones%20y%20Electr%C3%B3nica%20con%2020%20a%C3%B1os%20de%20experiencia%20en%20el%20%C3%A1rea%20de%20las%20telecomunicaciones%20para%20voz%20y%20datos%2C%20comparto%20mi%20experiencia%20dando%20clases%20en%20la%20Universidad%20Polit%C3%A9cnica%20de%20Quer%C3%A9taro.

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión