De acuerdo

Configurar BFD para BGP en Router AR

106 0 0 0 0

topo


Paso 1 Configure Router_1.

 

sysname Router_1

 

interface GigabitEthernet2/0/1

ip address 10.20.0.1 255.255.255.0

 

Habilite BGP y establezca el número de AS local en 200.

bgp 200

router-id 1.1.1.1

Configure Router_1 y Router_2 para establecer una conexión de EBGP.

peer 10.20.0.2 as-number 100

 

ipv4-family unicast

undo synchronization

network 10.20.0.0 255.255.255.0

peer 10.20.0.2 enable

 

Paso 2 Configure Router_2.

 

sysname Router_2

 

bfd

 

Creamos una lista de control de acceso

acl number 2000

rule 0 permit source 10.20.0.0 0.0.0.255

 

interface GigabitEthernet2/0/1

ip address 10.1.0.101 255.255.255.0

 

interface GigabitEthernet2/0/2

ip address 10.30.0.101 255.255.255.0

 

interface GigabitEthernet2/0/3

ip address 10.20.0.2 255.255.255.0

 

Habilite BGP y establezca el número de AS local en 100.

bgp 100

router-id 2.2.2.2

peer 10.2.0.101 as-number 100

peer 10.2.0.101 bfd enable

 

Configure Router_2 y Router_1 para establecer una conexión de EBGP.

 

peer 10.20.0.1 as-number 200

 

Configure Router_2 y Router_4 para establecer una conexión de IBGP.

peer 10.40.1.101 as-number 100

 

ipv4-family unicast

undo synchronization

preference 255 100 130

import-route ospf 1

peer 10.2.0.101 enable

peer 10.2.0.101 route-policy local-pre export

peer 10.2.0.101 next-hop-local

peer 10.20.0.1 enable

peer 10.40.1.101 enable

peer 10.40.1.101 next-hop-local

 

Configuramos OSPF en AS 100 para asegurarse de que haya rutas accesibles entre dispositivos.

ospf 1

import-route bgp

area 0.0.0.0

network 10.1.0.0 0.0.0.255

network 10.30.0.0 0.0.0.255

 

Configure una política de ruta para anunciar las rutas al peer en 10.2.0.101, y establezca la prioridad local en 200.

route-policy local-pre permit node 10

if-match ip route-source acl 2000

apply local-preference 200

 

Paso 3 Configure Router_3.

 

sysname Router_3

 

interface GigabitEthernet2/0/1

ip address 10.1.0.102 255.255.255.0

 

interface GigabitEthernet2/0/2

ip address 10.2.0.102 255.255.255.0

 

Configure OSPF en AS 100 para asegurarse de que haya rutas accesibles entre dispositivos.

ospf 1

area 0.0.0.0

network 10.1.0.0 0.0.0.255

network 10.2.0.0 0.0.0.255

 

Paso 4 Configure Router_4.

 

sysname Router_4

 

bfd

 

Cree ACL 2000 para permitir paquetes con la dirección IP de origen 10.50.0.0/24.

acl number 2000

rule 0 permit source 10.50.0.0 0.0.0.255

 

interface GigabitEthernet2/0/1

ip address 10.2.0.101 255.255.255.0

 

interface GigabitEthernet2/0/2

ip address 10.40.1.101 255.255.255.0

 

interface GigabitEthernet2/0/3

ip address 10.50.0.2 255.255.255.0

 

Habilite BGP y establezca el número de AS local en 100.

bgp 100

router-id 4.4.4.4

 

Configure Router_4 y Router_2 para establecer una conexión de IBGP.

peer 10.1.0.101 as-number 100

peer 10.1.0.101 bfd min-tx-interval 100 min-rx-interval 100

 

Configure BFD.

peer 10.1.0.101 bfd enable

peer 10.30.0.101 as-number 100

 

Configure Router_4 y Router_6 para establecer una conexión de EBGP.

peer 10.50.0.1 as-number 300

peer 10.50.0.1 ebgp-max-hop 255

 

ipv4-family unicast

undo synchronization

preference 255 100 130

peer 10.1.0.101 enable

peer 10.1.0.101 route-policy local-pre export

 

En la vista de familia de direcciones de unidifusión de BGP IPv4, configure el dispositivo para establecer su dirección IP como el siguiente salto de rutas al anunciar las rutas de BGP al peer en 10.1.0.101.

peer 10.1.0.101 next-hop-local

peer 10.30.0.101 enable

 

En la vista de familia de direcciones de unidifusión de BGP IPv4, configure el dispositivo para establecer su dirección IP como el siguiente salto de rutas al anunciar las rutas de BGP al peer en 10.30.0.101.

peer 10.30.0.101 next-hop-local

peer 10.50.0.1 enable

 

Configure OSPF en AS 100 para asegurarse de que haya rutas accesibles entre dispositivos

ospf 1

import-route direct

area 0.0.0.0

network 10.2.0.0 0.0.0.255

network 10.40.1.0 0.0.0.255

 

Configure una política de ruta para anunciar las rutas al peer en 10.1.0.101 y establezca la prioridad local en 200.

route-policy local-pre permit node 10

if-match ip route-source acl 2000

apply local-preference 200

 

Paso 5 Configure Router_5.

 

sysname Router_5

 

interface GigabitEthernet2/0/1

ip address 10.30.0.102 255.255.255.0

 

interface GigabitEthernet2/0/2

ip address 10.40.1.102 255.255.255.0

 

ospf 1

area 0.0.0.0

network 10.30.0.0 0.0.0.255

network 10.40.1.0 0.0.0.255

 

Paso 6 Configure Router_6.

 

sysname Router_6

 

interface GigabitEthernet2/0/1

ip address 10.50.0.1 255.255.255.0

 

Habilite BGP y establezca el número de AS local en 300.

bgp 300

router-id 6.6.6.6

 

Configure Router_6 y Router_4 para establecer una conexión de EBGP.

peer 10.50.0.2 as-number 100

peer 10.50.0.2 ebgp-max-hop 255

 

ipv4-family unicast

undo synchronization

network 10.50.0.0 255.255.255.0

peer 10.50.0.2 enable

 

Fin de Esta Historia…


  • x
  • convención:

Comentar

Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse
Responder

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.
Recordatorio
Agrega tu número de teléfono para obtener un bono de invitación.