Configurar Agregación de Enlaces en Modo Manual Destacado

Última respuesta Sep 02, 2019 11:26:32 39 2 2 0

La agregación de enlaces de Ethernet aumenta el ancho de banda del enlace agrupando varios enlaces físicos para formar un enlace lógico. La agregación de enlaces puede funcionar en modo manual o en modo de Protocolo de control de agregación de enlaces (LACP).

En este ejemplo se trabajará el modo manual para crear un Eth-Trunk y agregar interfaces al mismo. El modo manual aumenta el ancho de banda, mejora la confiabilidad, implementa el equilibrio de carga en los enlaces activos que reenvían datos.


Notas de Configuracion.

  • Las interfaces de un Eth-Trunk deben usar el mismo tipo y velocidad de Ethernet.
  • Ambos dispositivos del Eth-Trunk deben usar la misma cantidad de interfaces físicas, velocidad de interfaz, modo dúplex y modo de control de flujo.
  • Si se agrega una interfaz del dispositivo local a un Eth-Trunk, una interfaz del dispositivo remoto conectado directamente a la interfaz del dispositivo local también se debe agregar a un Eth-Trunk. De lo contrario, los dos extremos no pueden comunicarse.
  • Ambos dispositivos de un Eth-Trunk deben usar el mismo modo de agregación de enlaces.
  • Este ejemplo se aplica a todas las versiones y productos.
  • Este ejemplo se aplica a todas las versiones de S12700.

 

Caso Practico.

En la topologia SwitchA y SwitchB se conectan a dispositivos en VLAN 10 y VLAN 20 a través de enlaces de Ethernet, y el tráfico pesado se transmite entre SwitchA y SwitchB.


SwitchA y SwitchB pueden proporcionar mayor ancho de banda de enlace para implementar comunicación entre VLAN.  La transmisión de datos y la fiabilidad del enlace deben estar garantizadas.


1


Tareas a Realizar:

  1. Crear un Eth-Trunk y agregue interfaces de miembro al Eth-Trunk para aumentar el ancho de banda del enlace.
  2. Crear las VLAN y agregue interfaces a las VLAN.
  3. Ajuste el modo de equilibrio de carga para garantizar que el tráfico esté equilibrado de carga entre las interfaces de miembro de Eth-Trunk y mejore la confiabilidad.
  4. Validar la configuración.

Procedimiento:


Tarea 1. Crear un Eth-Trunk en SwitchA y SwitchB y agregue interfaces al Eth-Trunk.


<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] interface eth-trunk 1  
[SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3   
[SwitchA-Eth-Trunk1] quit


<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] interface eth-trunk 1   
[SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3 
[SwitchB-Eth-Trunk1] quit


Tarea 2. Crear las VLAN 10 y VLAN 20 y agregarlas a las interfaces. La configuración de SwitchB es similar a la configuración de SwitchA.


[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/4
[SwitchA-GigabitEthernet1/0/4] port link-type trunk 
[SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/4] quit
[SwitchA] interface gigabitethernet 1/0/5
[SwitchA-GigabitEthernet1/0/5] port link-type trunk   
[SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet1/0/5] quit

Configurar Eth-Trunk 1 para permitir que los paquetes de VLAN 10 y VLAN 20 pasen. La configuración de SwitchB es similar a la configuración de SwitchA.

[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] port link-type trunk   
[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SwitchA-Eth-Trunk1] quit



Tarea 3. Ajuste el modo de balanceo de carga de Eth-Trunk 1. La configuración de SwitchB es similar a la configuración de SwitchA.

 

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1]load-balance src-dst-mac //Configure el equilibrio de carga con base a las direcciones MAC de origen y destino en Eth-Trunk 1.

[SwitchA-Eth-Trunk1] quit


Tarea 4. Validar la configuración.


Ejecutar el comando display eth-trunk 1 en cualquier vista para verificar si se ha creado Eth-Trunk y si se han agregado las interfaces de miembro.

[SwitchA] display eth-trunk 1

Eth-Trunk1's state information is:

WorkingMode: NORMAL           Hash arithmetic: According to SA-XOR-DA

Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8

Operate status: up             Number Of Up Port In Trunk: 3

--------------------------------------------------------------------------------

PortName                           Status       Weight

GigabitEthernet1/0/1               Up           1

GigabitEthernet1/0/2               Up           1

GigabitEthernet1/0/3               Up           1


La información anterior muestra que Eth-Trunk 1 contiene tres interfaces: GigabitEthernet1/0/1, GigabitEthernet1/0/2, y GigabitEthernet1/0/3. El estado de las interfaces de miembro es de Up y el valor de Operate status del Eth-Trunk 1 es de up.


Saludos

  • x
  • convención:

Jorge
Moderador Publicado 2019-8-29 12:38:03
Solo el autor puede ver esta publicación
  • x
  • convención:

Senior Cybersecurity Engineer
Gustavo.HdezF
Moderador Publicado 2019-9-2 11:26:32
Solo el autor puede ver esta publicación
  • x
  • convención:

Ingeniero%20en%20Comunicaciones%20y%20Electr%C3%B3nica%20con%2020%20a%C3%B1os%20de%20experiencia%20en%20el%20%C3%A1rea%20de%20las%20telecomunicaciones%20para%20voz%20y%20datos%2C%20comparto%20mi%20experiencia%20dando%20clases%20en%20la%20Universidad%20Polit%C3%A9cnica%20de%20Quer%C3%A9taro.

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje