Configuracion de Huawei Switch Capa 2

Última respuesta ag. 27, 2019 11:42:46 52 1 1 0

Este Post está diseñado como una referencia para configurar los equipos de red, por lo que se debe estar familiarizado con los conocimientos básicos de Ethernet.


Los números de interfaz utilizados en este manual son ejemplos. En la configuración del dispositivo, use los números de interfaz existentes en los dispositivos.


En la siguiente figura se observa un escenario simulando dos segmentos de red dentro de una compañía y se requiere que los usuarios accedan a Internet a través del Switch de Capa 2 y Router el cual debe funcionar como el Gateway de los usuarios.


SW Capa 2


Tareas a realizar:


1.       Configurar la asignación de VLAN en la interfaz del Switch.

2.       Configurar el Router como el Gateway.

3.       Configure el Router como el servidor DHCP para asignar direcciones IP a los usuarios.

4.       Configure la función NAT en el Router para admitir que los usuarios tengan acceso a Internet.



Configure el switch.

# Configure las interfaces conectadas a los usuarios.

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 2 3

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port default vlan 2  

[Switch-GigabitEthernet1/0/2] quit

 

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port default vlan 3  

[Switch-GigabitEthernet1/0/3] quit

 

# Configure la interfaz conectada al router.

[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type trunk
[Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 3  
[Switch-GigabitEthernet1/0/1] quit

 

 

Configure el Router.

# Configurar las subinterfaces para la etiqueta de VLAN.

<Huawei> system-view

[Huawei] sysname Router

[Router] vlan batch 2 3

[Router] interface gigabitethernet 0/0/1.1

[Router-GigabitEthernet0/0/1.1] dot1q termination vid 2  

[Router-GigabitEthernet0/0/1.1] ip address 192.168.1.1 24

[Router-GigabitEthernet0/0/1.1] quit

 

[Router] interface gigabitethernet 0/0/1.2

[Router-GigabitEthernet0/0/1.2] dot1q termination vid 3  

[Router-GigabitEthernet0/0/1.2] ip address 192.168.2.1 24

 [Router-GigabitEthernet0/0/1.2] quit

 

 

 

 

# Configure la función DHCP para asignar direcciones IP a usuarios de la intranet y especifique la dirección del servidor DNS.

[Router] dhcp enable

[Router] interface gigabitethernet 0/0/1.1

[Router-GigabitEthernet0/0/1.1] dhcp select interface   //DHCP usa un grupo de direcciones de interfaz para asignar direcciones IP a usuarios de la intranet.

[Router-GigabitEthernet0/0/1.1] dhcp server dns-list 8.8.8.8 8.8.4.4

[Router-GigabitEthernet0/0/1.1] quit

 

[Router] interface gigabitethernet 0/0/1.2

[Router-GigabitEthernet0/0/1.2] dhcp select interface  

[Router-GigabitEthernet0/0/1.2] dhcp server dns-list 8.8.8.8 8.8.4.4

[Router-GigabitEthernet0/0/1.2] quit

 

# Configure una dirección IP de interfaz de red pública y una ruta estática.

[Router] interface gigabitethernet 0/0/2

[Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0 

[Router-GigabitEthernet0/0/2] quit

[Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1  

 

# Configure la función NAT para admitir que los usuarios de la intranet tengan acceso a Internet.

[Router] acl number 2001

[Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255   

[Router-acl-basic-2001] quit

[Router] interface gigabitethernet 0/0/2

[Router-GigabitEthernet0/0/2] nat outbound 2001

[Router-GigabitEthernet0/0/2] quit

 

# Configure las interfaces VLANIF.

<Huawei> system-view

[Huawei] sysname Router

[Router] vlan batch 2 3

[Router] interface gigabitethernet 0/0/1

[Router-GigabitEthernet0/0/1] portswitch  

[Router-GigabitEthernet0/0/1] port link-type trunk

[Router-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3

[Router-GigabitEthernet0/0/1] quit

 

[Router] interface vlanif 2

[Router-vlanif2] ip address 192.168.1.1 24  

[Router-vlanif2] quit

[Router] interface vlanif 3

[Router-vlanif3] ip address 192.168.2.1 24 

[Router-vlanif3] quit


# Configure la función DHCP para asignar direcciones IP a usuarios de la intranet y especifique la dirección del servidor DNS.

[Router] dhcp enable

[Router] interface vlanif 2

[Router-Vlanif2] dhcp select interface

[Router-Vlanif2] dhcp server dns-list 8.8.8.8 8.8.4.4

[Router-Vlanif2] quit

 

[Router] interface vlanif 3

[Router-Vlanif3] dhcp select interface

[Router-Vlanif3] dhcp server dns-list 8.8.8.8 8.8.4.4

[Router-Vlanif3] quit

 

# Configure una dirección IP de interfaz de red pública y una ruta estática.

[Router] interface gigabitethernet 0/0/2

[Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0

[Router-GigabitEthernet0/0/2] quit

[Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1  

# Configure la función NAT para admitir que los usuarios de la intranet tengan acceso a Internet.

[Router] acl number 2001

[Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255

[Router] interface gigabitethernet 0/0/2

[Router-GigabitEthernet0/0/2] nat outbound 2001

[Router-GigabitEthernet0/0/2] quit

 

 

Verifique la configuración

Configure una dirección IP como 192.168.1.2/24 y una dirección de Gateway como 192.168.1.1 para PC1.

Configure una dirección IP como 192.168.2.2/24 y una dirección de Gateway como 192.168.2.1 para PC2.

Configure una dirección IP como 200.0.0.1/24 y una dirección de Gateway como 200.0.0.2 para la red externa.




Saludos.


  • x
  • convención:

Jorge
Moderador Publicado 2019-8-27 11:42:46
Solo el autor puede ver esta publicación
  • x
  • convención:

Senior Cybersecurity Engineer

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje