De acuerdo

Configuración de L2TP para la conexión de dos sucursales con IPSec

121 0 0 0 0

Como se muestra en la Imagen, una empresa tiene sucursales ubicadas en otras ciudades.

topo

 

La empresa requiere que la sede proporcione servicios de VPDN para los usuarios de la sucursal, de modo que los usuarios de la sucursal puedan acceder a la red de la sede.

 

Cuando los usuarios de la sucursal acceden a los servidores del intranet en la red de la sede, los datos deben encriptarse para evitar las pérdidas de datos.

 

Para cumplir estos requisitos, puede configurarse el LAC para iniciar una solicitud de conexión de L2TP al LNS. Luego puede configurarse IPSec para proteger los datos intercambiados entre los usuarios de la sucursal y los servidores del intranet.

 

Paso 1 Configure el LAC.

 

#

sysname LAC

 

#

l2tp enable   //Habilite L2TP.

 

#

acl number 3000    //Configure una ACL.

rule 0 permit ip source 10.2.1.0 0.0.0.255 destination 10.3.1.0 0.0.0.255

 

#

ipsec proposal lac    //Cree una propuesta de IPSec.

esp authentication-algorithm sha2-512

esp encryption-algorithm aes-256

 

#

ike peer lac v1   //Los comandos utilizados para configurar IKE peers y el

protocolo de IKE difieren según la versión del software.

pre-shared-key cipher xxxxxxxx

remote-address 10.4.1.1    //Especifique una dirección IP para la interfaz de IPSec remota.

 

#

ipsec policy lac 1 isakmp    //Cree una política de IPSec.

security acl 3000

ike-peer lac

proposal lac

 

#

interface Virtual-Template1 //Cree un túnel virtual.

ppp chap user huawei    

ppp chap password cipher xxxxxxx   //Establezca la contraseña del usuario de PPP virtual en Huawei@1234.

ip address ppp-negotiate    //Configure la negociación de la dirección IP.

l2tp-auto-client enable     //Habilite al usuario de PPP virtual para iniciar una solicitud de conexión de L2TP.

ipsec policy lac    //Aplique una política de IPSec.

 

#

interface GigabitEthernet1/0/0

ip address 1.1.1.1 255.255.255.0

 

#

interface GigabitEthernet2/0/0

ip address 10.2.1.1 255.255.255.0

 

#

l2tp-group 1    //Cree un grupo de L2TP y establezca atributos relacionados.

tunnel password cipher xxxxxx    //Habilite la autenticación de túnel y establezca la contraseña de cifrado de texto en huawei

start l2tp ip 1.1.2.1 fullusername huawei

 

#

ip route-static 10.3.1.0 255.255.255.0 Virtual-Template1 10.1.1.1    //Configure una ruta estática.

ip route-static 10.4.1.0 255.255.255.0 Virtual-Template1

 

Paso 2 Configure el LNS.

 

#

sysname LNS

#

l2tp enable    //Habilite L2TP.

 

#

ip pool 1    //Cree un grupo de direcciones IP.

gateway-list 10.1.1.1

network 10.1.1.0 mask 255.255.255.0

 

#

aaa

local-user huawei password cipher xxxxxx

local-user huawei privilege level 0

local-user huawei service-type ppp

 

#

interface Virtual-Template1

ppp authentication-mode chap

remote address pool 1

ip address 10.1.1.1 255.255.255.0

 

#

interface GigabitEthernet1/0/0

ip address 1.1.2.1 255.255.255.0

 

#

interface GigabitEthernet2/0/0

ip address 10.4.1.2 255.255.255.0

 

#

l2tp-group 1    //Cree un grupo de L2TP y establezca atributos relacionados.

allow l2tp virtual-template 1 remote lac

tunnel password cipher xxxxxx    //Habilite la autenticación de túnel y establezca la contraseña de cifrado de texto en huawei, que es la misma contraseña especificada en el dispositivo remoto.

tunnel name lns

 

#

ip route-static 10.2.1.0 255.255.255.0 Virtual-Template1    //Configure una ruta estática.

ip route-static 10.3.1.0 255.255.255.0 10.4.1.1

 

Paso 3 Configure Router_1.

 

#

sysname Router_1

 

#

acl number 3000    //Configure una ACL.

rule 0 permit ip source 10.3.1.0 0.0.0.255 destination 10.2.1.0 0.0.0.255

 

#

ipsec proposal lac1    //Cree una propuesta de IPSec.

esp authentication-algorithm sha2-512

esp encryption-algorithm aes-256

 

#

ike peer lac1 v1    //Los comandos utilizados para configurar IKE peers y el protocolo de IKE difieren según la versión del software.

 

pre-shared-key cipher xxxxxxxx

 

#

ipsec policy-template temp 1  //Aplique la política de IPSec.

security acl 3000

ike-peer lac1

proposal lac1

 

#

ipsec policy lac1 1 isakmp template temp    //Configure una política de IPSec.

 

#

interface GigabitEthernet1/0/0

ip address 10.4.1.1 255.255.255.0

ipsec policy lac1    //Vincule la política de IPSec a la interfaz.

 

#

interface GigabitEthernet2/0/0

ip address 10.3.1.1 255.255.255.0

 

#

ip route-static 10.1.1.0 255.255.255.0 10.4.1.2    //Configure una ruta estática.

ip route-static 10.2.1.0 255.255.255.0 10.4.1.2

 


  • x
  • convención:

Comentar

Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse
Responder

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.
Recordatorio
Agrega tu número de teléfono para obtener un bono de invitación.