Configuración de IPv6 sobre IPv4 en túnel manual para Routers AR Huawei

63 0 4 0

En esta publicación, se hablara sobre la configuración de IPv6 sobre IPv4 en tuéneles de red IPv4, esto con las configuraciones correspondientes en los Routers AR de Huawei.


Reimpresión autorizada por el autor zhushigeng (Vinsoney) - https://forum.huawei.com/enterprise/thread-523629.html


185631wkk5cqecce5ksk7c.png

Como se muestra en la figura anterior, R1 y R2 están conectados a una red IPv4. R1 y R2 acceden a la red IPv4 utilizando 10.1.1.1 y 10.2.2.2 respectivamente. Las direcciones IPv4 de R1 y R2 son accesibles entre sí.


Además, R1 y R2 están conectados a dos redes IPv6. Debido a que los paquetes IPv6 no se pueden enviar directamente ni enrutarse en la red IPv4, las redes IPv6 están aisladas entre sí y el acceso mutuo no está disponible.

La tecnología de túnel se puede utilizar para establecer un túnel punto a punto entre R1 y R2. En este caso, se establece entre R1 y R2 un túnel manual de IPv6 sobre IPv4, es decir, un túnel manual virtual. La dirección de origen del túnel en R1 es 10.1.1.1 y la dirección de destino es 10.2.2.2. El tráfico de PC1 a PC2 se transmite a través de este túnel. De manera similar, la dirección de origen del túnel en R2 es 10.2.2.2 y la dirección de destino es 10.1.1.1.


Cuando PC1 accede a PC2, PC1 envía un paquete IPv6 a la puerta de enlace predeterminada R1. R1 busca en la tabla de enrutamiento de IPv6 y encuentra que el paquete se envía a una interfaz de túnel. R1 encapsula el paquete IPv6 en un paquete IPv4. En el encabezado de IPv4, la dirección IP de origen es 10.1.1.1, y la dirección IP de destino es 10.2.2.2. Luego, el paquete se envía a la red IPv4. Dado que el encabezado de IPv4 está encapsulado en el paquete, el dispositivo en la red IPv4 solo verifica el encabezado de IPv4. Por lo tanto, el paquete se reenvía a la dirección IP de destino 10.2.2.2, es decir, R2. R2 elimina el encabezado de IPv4 del paquete y reenvía los datos de IPv6 originales a PC2.


1. Topología y requisitos


http://image.hw3static.com/hi/showimage-16783371-432623-025a81849d74ff6d68a4a88de2fdefc0.jpg

· La red que conecta R1, R3 y R2 es una red IPv4.


· PC1 y PC2 residen en islas IPv6 y están aisladas unas de otras.


· R1 y R2 son compatibles con doble pila de IPv4 / IPv6.


· Configure un túnel manual IPv6 sobre IPv4 entre R1 y R2 para que PC1 y PC2 puedan comunicarse entre sí.


2. Configuración e implementación


Configuracion R3.
[R3] interface GigabitEthernet0/0/0
[R3-GigabitEthernet0/0/0] ip address 10.1.1.2 24
[R3] interface GigabitEthernet0/0/1
[R3-GigabitEthernet0/0/1] ip address 10.2.2.1 24


Configuracion R1.
# Configure the IPv4 interface. 
[R1] interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/1] ip address 10.1.1.1 24
[R1] ip route-static 0.0.0.0 0 10.1.1.2                                       
  # Configuracion  de una ruta IPv4 por default.

# Configure the IPv6 interface.
[R1] ipv6                                                                              
   # Hailitar IPv6 globally.
[R1] interface GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0] ipv6 enable                                     
   # Habilitar IPv6 en la interfaz.
[R1-GigabitEthernet0/0/0] ipv6 address 2001:1111::FFFF 64       
  # Configuracion de una direccion IPv6 global unicast.

# Configure an IPv6 over IPv4 manual tunnel. 
[R1] Interface tunnel 0/0/0
[R1-Tunnel0/0/0] tunnel-protocol ipv6-ipv4
[R1-Tunnel0/0/0] ipv6 enable
[R1-Tunnel0/0/0] source 10.1.1.1
[R1-Tunnel0/0/0] destination 10.2.2.2
[R1-Tunnel0/0/0] ipv6 address auto link-local       

# Si no se configura una dirección de unidifusión global para la interfaz del túnel, configure una dirección de enlace local para la interfaz. De lo contrario, el estado de IPv6 de la interfaz se reducirá. Si la dirección de unidifusión global está configurada, el sistema configura automáticamente una dirección de enlace local para la interfaz. Por lo tanto, no es necesario ejecutar este comando.

[R1] Ipv6 route-static 2001:2222:: 64 tunnel 0/0/0


Configuracion R2.
# Configuracion de la IPv4 interfaz
[R2] interface GigabitEthernet0/0/0
[R2-GigabitEthernet0/0/0] ip address 10.2.2.2 24
[R2] ip route-static 0.0.0.0 0 10.2.2.1

# Configure the IPv6 interface.
[R2] ipv6 
[R2] interface GigabitEthernet0/0/1
[R2-GigabitEthernet0/0/1] ipv6 enable 
[R2-GigabitEthernet0/0/1] ipv6 address 2001:2222::FFFF 64

Configure an IPv6 over IPv4 manual tunnel. 
[R2 Interface tunnel 0/0/0
[R2-Tunnel0/0/0] tunnel-protocol ipv6-ipv4
[R2-Tunnel0/0/0] ipv6 enable
[R2-Tunnel0/0/0] source 10.2.2.2
[R2-Tunnel0/0/0] destination 10.1.1.1
[R2-Tunnel0/0/0] ipv6 address auto link-local
[R2] Ipv6 route-static 2001:1111:: 64 tunnel 0/0/0

Preste atención a los siguientes puntos:


· Las direcciones IP de los extremos de origen y destino del túnel: 10.1.1.1 y 10.2.2.2 deben ser accesibles. De lo contrario, el túnel no se puede establecer.


· Al configurar un túnel manual de IPv6 sobre IPv4, debe especificar manualmente las direcciones IP de origen y destino del túnel.


· Los paquetes destinados a la red IPv6 en el otro extremo se reenvían a una interfaz de túnel a través de la ruta Ipv6 route-static 2001: 1111 :: 64 tunnel0 / 0/0. Luego, los paquetes se encapsulan con un encabezado IPv4 y se envían a la red IPv4.


<R1>display ipv6 interface brief 
*down: administratively down
(l): loopback
(s): spoofing
Interface                           Physical              Protocol   
GigabitEthernet0/0/0          up                      up         
[IPv6 Address] 2001:1111::FFFF
Tunnel0/0/0                       up                     up         
[IPv6 Address] FE80::A01:C01


La información anterior muestra el resumen de las interfaces IPv6 en R1. Puede ver la dirección IPv6 configurada para GE0 / 0/0 y la dirección de enlace local de Tunnel0 / 0/0.


PC1>ping 2001:2222::1
Ping 2001:2222::1 32 data bytes, Press Ctrl_C to break
From 2001:2222::1 bytes=32 seq=1 hop limit=64 time<2 ms
From 2001:2222::1: bytes=32 seq=2 hop limit=64 time=2 ms
From 2001:2222::1: bytes=32 seq=3 hop limit=64 time=2 ms
From 2001:2222::1: bytes=32 seq=4 hop limit=64 time<2 ms
From 2001:2222::1: bytes=32 seq=5 hop limit=64 time<2 ms

  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba