[Compartiendo internamente] Resolviendo el conflicto de la dirección IP secundaria a través de VRRP tweak

111 0 0 0

Desea actualizar su infraestructura de red pero, desafortunadamente, esto significa apagar los dispositivos antiguos y reemplazarlos con algunos equipos nuevos. Es consciente de que no puede simplemente decirles a sus clientes que tomen un descanso de un día de los servicios que le pagan, así que, ¿cómo salir de esta situación?

 

Para empeorar las cosas, tiene algunos servicios de atención al cliente en Vlan 100, por lo que es un desastre si, de repente, una de sus puertas de enlace en Vlan 100 se desconecta, incluso durante un par de minutos.

 

Sé que en este momento estás pensando, no hay problema, solo puedo configurar esa puerta de enlace en un equipo redundante como una dirección IP secundaria. Lo que no sabía es que su enrutador AR1200VW no admite la configuración de una dirección IP secundaria del mismo rango en la interfaz Vlanif 100. Lo intenté, así que por favor consulte la salida de CLI a continuación:

#

[AR-Vlanif12]ip add 12.0.0.2 24 sub                                            

Error: The specified address conflicts with another address.

#

 

Tengo la solución perfecta para su problema, pero antes de presentar la solución, para aclarar las cosas, eche un vistazo al diseño de la red a continuación:

 

La configuración de los dispositivos se detalla a continuación:

###################################################

[AR1200]dis curr                                                                

[V200R003C01SPC900]                                                            

#                                                                              

 sysname AR1200                                                                                                                        

#                                                                              

vlan batch 100                                                                                       

#                                                                              

interface Vlanif100                                                            

 ip address 10.0.0.1 255.255.255.0                                              

 vrrp vrid 1 virtual-ip 10.0.0.2                                               

 vrrp vrid 1 timer advertise 255                                               

#

interface Ethernet0/0/1                                                        

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                

#

#                                                                              

ip route-static 192.168.1.0 255.255.255.0 10.0.0.10                            

#                                                                                                                                                                                                                      

return             

 

##########################################################

[S5700-1]dis curr                                                                

!Software Version V200R003C00SPC300                                             

#                                                                              

sysname S5700-1                                                                                                                                                                                                              

#                                                                              

vlan batch 100 200                                                     

#                                                                               

interface Vlanif100                                                            

 ip address 10.0.0.10 255.255.255.0                                            

#                                                                               

interface Vlanif200                                                            

 ip address 192.168.1.1 255.255.255.0                                          

#                                                                               

interface GigabitEthernet0/0/18                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                 

#                                                                              

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                           

 port trunk allow-pass vlan 200                                                

#                                                                          

return        

########################################################         

[S57-2]dis curr                                                                

!Software Version V200R002C00SPC100                                            

#                                                                              

sysname S57-2                                                                                                                                                                                                        

#                                                                              

vlan batch 200                        

#                                                         

interface Vlanif200                                                             

 ip address 192.168.1.2 255.255.255.0                                                                                    

#                                                                              

interface GigabitEthernet0/0/1                                                  

 port link-type trunk                                                          

 port trunk allow-pass vlan 3970                                               

#                                                                               

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 200                                                                                                                                                          

#                                                                              

ip route-static 0.0.0.0 0.0.0.0 192.168.1.1                                                                                            

#                                                                              

return                                                                         

############################################################

 

 

Como puede ver, mi primer paso en esta actualización es deshacerse del viejo AR200 y reemplazarlo con un nuevo dispositivo. Estoy cambiando el AR200 a un AR1200.

 

Ahora para mantener todas las direcciones accesibles, necesito configurar la dirección 10.0.0.2 en AR-1 como una dirección IP secundaria. Como no puedo hacerlo usando el subcomando ip address, usaré VRRP. Al crear una instancia de VRRP puedo configurar 10.0.0.2 como una dirección IP virtual.

 

El CLI para esta operación se enumera a continuación:

#

[S77-1]vrrp vrid 1 virtual-ip 10.0.0.2

#

 

Después de esta configuración, probaré la conectividad de mi nodo S77-1 y, como pueda y verá en las siguientes líneas, todo se verifica:

[S57-2]ping 10.0.0.1                                                            

  PING 10.0.0.1: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.1: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=4 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                                

  --- 10.0.0.1 ping statistics ---                                             

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                        

    0.00% packet loss                                                          

    round-trip min/avg/max = 1/1/1 ms                                          

                                                                                

[S57-2]ping 10.0.0.2                                                            

  PING 10.0.0.2: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.2: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=4 ttl=254 time=1 ms                  

    Reply from 10.0.0.2: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                               

  --- 10.0.0.2 ping statistics ---                                              

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                       

    0.00% packet loss                                                           

round-trip min/avg/max = 1/1/1 ms  

 

En este momento, puede pensar que esta no es una buena solución porque introduce un poco de tráfico de multidifusión no deseado (generado por vrrp - mensajes de publicidad vrrp) en su red. Para reducir este tráfico a un mínimo aceptable, aconsejo configurar el temporizador de publicidad vrrp al valor máximo (255) mediante el siguiente comando:

#

[S77-1] vrrp vrid 1 timer advertise 255

#

Como puede ver ahora, ha reducido el tráfico de multidifusión adicional al mínimo

 

(1 mensaje cada 255 segundos). Por otro lado, ahora tiene una dirección IP secundaria en su interfaz Vlanif 100 y ahora está listo para el intercambio.

¡Espero que esto te ayude tanto como a mí!

  • x
  • convención:

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje