De acuerdo

Cómo puedo configurar un Q and Q

Última respuesta my. 12, 2020 06:16:51 22 1 0 0
Deseo configurar un Q and Q desde un Huawei NE40 y un ASR de cisco
  • x
  • convención:

Publicado 2020-5-12 06:16:51 Útil(0) Útil(0)
Aquí hay algunos ejemplos de tipo 4 y tipo 5

SVC VPWS
Un VPWS SVC es un VPWS estático, que no requiere un protocolo de señalización, sino etiquetas VC configuradas para transmitir información L2VPN.

[*PE1] interface gigabitethernet 2/0/0
[*PE1-GigabitEthernet2/0/0] mpls
[*PE1-GigabitEthernet2/0/0] mpls ldp

[*PE2] interface gigabitethernet 1/0/0
[*PE2-GigabitEthernet1/0/0] mpls
[*PE2-GigabitEthernet1/0/0] mpls ldp

[~PE1] mpls l2vpn
[*PE1-l2vpn] quit
[*PE1] interface gigabitethernet 1/0/0
[*PE1-GigabitEthernet1/0/0] mpls static-l2vc destination 3.3.3.9 transmit-vpn-label 100 receive-vpn-label 200
[*PE1-GigabitEthernet1/0/0] undo shutdown
[*PE1-GigabitEthernet1/0/0] quit
[*PE1] commit


[~PE2] mpls l2vpn
[*PE2-l2vpn] quit
[*PE2] interface gigabitethernet 2/0/0
[*PE2-GigabitEthernet2/0/0] mpls static-l2vc destination 1.1.1.9 transmit-vpn-label 200 receive-vpn-label 100
[*PE2-GigabitEthernet2/0/0] undo shutdown
[*PE2-GigabitEthernet2/0/0] quit
[*PE2] commit

display mpls static-l2vc interface gigabitethernet 1/0/0
display l2vpn ccc-interface vc-type static-vc up

***********************************************************************

CE1 y CE2 se conectan a PE1 y PE2, respectivamente; PE1 y PE2 están conectados en una red troncal MPLS.
Se requiere un LSP para configurar un VPWS SS-PW dinámico entre PE1 y PE2.

<HUAWEI> system-view
[~HUAWEI] sysname CE1
[*HUAWEI] commit
[~CE1] interface gigabitethernet 0/1/0
[*CE1-GigabitEthernet0/1/0] undo shutdown
[*CE1-GigabitEthernet0/1/0] quit
[*CE1] interface gigabitethernet 0/1/0.1
[*CE1-GigabitEthernet0/1/0.1] vlan-type dot1q 1
[*CE1-GigabitEthernet0/1/0.1] ip address 10.10.1.1 24
[*CE1-GigabitEthernet0/1/0.1] undo shutdown
[*CE1-GigabitEthernet0/1/0.1] commit
[~CE1-GigabitEthernet0/1/0.1] quit

<HUAWEI> system-view
[~HUAWEI] sysname CE2
[*HUAWEI] commit
[~CE2] interface gigabitethernet 0/1/0
[*CE2-GigabitEthernet0/1/0] undo shutdown
[*CE2-GigabitEthernet0/1/0] quit
[*CE2] interface gigabitethernet 0/1/0.1
[*CE2-GigabitEthernet0/1/0.1] vlan-type dot1q 2
[*CE2-GigabitEthernet0/1/0.1] ip address 10.10.1.2 24
[*CE2-GigabitEthernet0/1/0.1] undo shutdown
[*CE2-GigabitEthernet0/1/0.1] commit
[~CE2-GigabitEthernet0/1/0.1] quit

display mpls ldp session (Operational)

[~PE1] mpls l2vpn
[*PE1-l2vpn] quit
[*PE1] interface gigabitethernet 0/1/0
[*PE1-GigabitEthernet0/1/0] undo shutdown
[*PE1-GigabitEthernet0/1/0] quit
[*PE1] interface gigabitethernet 0/1/0.1
[*PE1-GigabitEthernet0/1/0.1] vlan-type dot1q 1
[*PE1-GigabitEthernet0/1/0.1] mpls l2vc 192.168.3.3 100
[*PE1-GigabitEthernet0/1/0.1] undo shutdown
[*PE1-GigabitEthernet0/1/0.1] commit
[~PE1-GigabitEthernet0/1/0.1] quit

[~PE2] mpls l2vpn
[*PE2-l2vpn] quit
[*PE2] interface gigabitethernet 0/1/0
[*PE2-GigabitEthernet0/1/0] undo shutdown
[*PE2-GigabitEthernet0/1/0] quit
[*PE2] interface gigabitethernet0/1/0.1
[*PE2-GigabitEthernet0/1/0.1] vlan-type dot1q 2
[*PE2-GigabitEthernet0/1/0.1] mpls l2vc 192.168.2.2 100
[*PE2-GigabitEthernet0/1/0.1] undo shutdown
[*PE2-GigabitEthernet0/1/0.1] commit
[~PE2-GigabitEthernet0/1/0.1] quit

display mpls l2vc interface gigabitethernet 0/1/0.1


*****************************************************************

Ejemplo para configurar la conmutación dinámica VPWS
En ambos extremos de un PW de conmutación, se configuran dos PW dinámicos. Los PW dinámicos usan LDP extendido para transmitir información de capa 2 y etiquetas de VC.

<HUAWEI> system-view
[~HUAWEI] sysname CE1
[*HUAWEI] commit
[~CE1] interface gigabitethernet 0/1/0
[*CE1-GigabitEthernet0/1/0] ip address 10.10.1.1 24
[*CE1-GigabitEthernet0/1/0] undo shutdown
[*CE1-GigabitEthernet0/1/0] commit
[~CE1-GigabitEthernet0/1/0] quit

<HUAWEI> system-view
[~HUAWEI] sysname CE2
[*HUAWEI] commit
[~CE2] interface gigabitethernet 0/1/0
[*CE2-GigabitEthernet0/1/0] ip address 10.10.1.2 24
[*CE2-GigabitEthernet0/1/0] undo shutdown
[*CE2-GigabitEthernet0/1/0] commit
[~CE2-GigabitEthernet0/1/0] quit

[~U-PE1] mpls lsr-id 1.1.1.9
[*U-PE1] mpls
[*U-PE1-mpls] quit
[*U-PE1] mpls ldp
[*U-PE1-mpls-ldp] quit
[*U-PE1] interface gigabitethernet 0/2/0
[*U-PE1-GigabitEthernet0/2/0] mpls
[*U-PE1-GigabitEthernet0/2/0] mpls ldp
[*U-PE1-GigabitEthernet0/2/0] quit
[*U-PE1] mpls ldp remote-peer 3.3.3.9
[*U-PE1-mpls-ldp-remote-3.3.3.9] remote-ip 3.3.3.9
[*U-PE1-mpls-ldp-remote-3.3.3.9] commit
[~U-PE1-mpls-ldp-remote-3.3.3.9] quit

[~P1] mpls lsr-id 2.2.2.9
[*P1] mpls
[*P1-mpls] quit
[*P1] mpls ldp
[*P1-mpls-ldp] quit
[*P1] interface gigabitethernet 1/0/0
[*P1-GigabitEthernet1/0/0] mpls
[*P1-GigabitEthernet1/0/0] mpls ldp
[*P1-GigabitEthernet1/0/0] quit
[*P1] interface gigabitethernet 2/0/0
[*P1-GigabitEthernet2/0/0] mpls
[*P1-GigabitEthernet2/0/0] mpls ldp
[*P1-GigabitEthernet2/0/0] commit
[~P1-GigabitEthernet2/0/0] quit

[~S-PE] mpls lsr-id 3.3.3.9
[*S-PE] mpls
[*S-PE-mpls] quit
[*S-PE] mpls ldp
[*S-PE-mpls-ldp] quit
[*S-PE] interface gigabitethernet 1/0/0
[*S-PE-GigabitEthernet1/0/0] mpls
[*S-PE-GigabitEthernet1/0/0] mpls ldp
[*S-PE-GigabitEthernet1/0/0] quit
[*S-PE] interface gigabitethernet 2/0/0
[*S-PE-GigabitEthernet2/0/0] mpls
[*S-PE-GigabitEthernet2/0/0] mpls ldp
[*S-PE-GigabitEthernet2/0/0] quit
[*S-PE] mpls ldp remote-peer 1.1.1.9
[*S-PE-mpls-ldp-remote-1.1.1.9] remote-ip 1.1.1.9
[*S-PE-mpls-ldp-remote-1.1.1.9] quit
[*S-PE] mpls ldp remote-peer 5.5.5.9
[*S-PE-mpls-ldp-remote-5.5.5.9] remote-ip 5.5.5.9
[*S-PE-mpls-ldp-remote-5.5.5.9] commit
[~S-PE-mpls-ldp-remote-5.5.5.9] quit

[~U-PE2] mpls lsr-id 5.5.5.9
[*U-PE2] mpls
[*U-PE2-mpls] quit
[*U-PE2] mpls ldp
[*U-PE2-mpls-ldp] quit
[*U-PE2] interface gigabitethernet 0/1/0
[*U-PE2-GigabitEthernet0/1/0] mpls
[*U-PE2-GigabitEthernet0/1/0] mpls ldp
[*U-PE2-GigabitEthernet0/1/0] quit
[*U-PE2] mpls ldp remote-peer 3.3.3.9
[*U-PE2-mpls-ldp-remote-3.3.3.9] remote-ip 3.3.3.9
[*U-PE2-mpls-ldp-remote-3.3.3.9] commit
[~U-PE2-mpls-ldp-remote-3.3.3.9] quit

display mpls ldp session
display mpls ldp peer
display mpls lsp

[~U-PE1] mpls l2vpn
[*U-PE1-l2vpn] quit
[*U-PE1] pw-template pwt
[*U-PE1-pw-template-pwt] peer-address 3.3.3.9
[*U-PE1-pw-template-pwt] control-word
[*U-PE1-pw-template-pwt] commit
[~U-PE1-pw-template-pwt] quit

[~U-PE2] mpls l2vpn
[*U-PE2-l2vpn] quit
[*U-PE2] pw-template pwt
[*U-PE2-pw-template-pwt] peer-address 3.3.3.9
[*U-PE2-pw-template-pwt] control-word
[*U-PE2-pw-template-pwt] commit
[~U-PE2-pw-template-pwt] quit

[~U-PE1] interface gigabitethernet 0/1/0
[*U-PE1-GigabitEthernet0/1/0] mpls l2vc pw-template pwt 100
[*U-PE1-GigabitEthernet0/1/0] undo shutdown
[*U-PE1-GigabitEthernet0/1/0] commit
[*U-PE1-GigabitEthernet0/1/0] quit


***************************************************************************

Ejemplo para configurar la encapsulación de paquetes de protocolo de capa 2 en un VPWS PW

CE1 y CE2 son dispositivos que no son de Huawei. Ambas CE admiten el Protocolo de descubrimiento de Cisco (CDP). Para garantizar que estos EC puedan funcionar con NE20E, debe establecer un VPWS PW entre PE1 y PE2. De esta manera, CE1 y CE2 pueden transmitir de manera transparente los paquetes CDP entre ellos a través del PW y usar el CDP para descubrirse entre sí.

Red para la transmisión transparente de paquetes de protocolo de capa de enlace a través de un VPWS PW

PE1
mpls lsr-id 1.1.1.9
mpls
#
mpls l2vpn
mpls l2vpn default martini
#
mpls ldp
#
mpls ldp remote-peer 3.3.3.9
remote-ip 3.3.3.9
#
interface GigabitEthernet0/1/0
undo shutdown
#
interface GigabitEthernet0/1/0.1
undo shutdown
vlan-type dot1q 10
link-protocol transport cdp (Enable transparent transmission of CDP packets on the PEs.)
mpls l2vc 3.3.3.9 101
#
PE2
mpls lsr-id 3.3.3.9
mpls
#
mpls l2vpn
mpls l2vpn default martini
#
mpls ldp
#
mpls ldp remote-peer 1.1.1.9
remote-ip 1.1.1.9
#
interface GigabitEthernet0/1/0
undo shutdown
#
interface GigabitEthernet0/1/0.1
undo shutdown
vlan-type dot1q 20
link-protocol transport cdp (Enable transparent transmission of CDP packets on the PEs.)
mpls l2vc 1.1.1.9 101
#
Ver más
  • x
  • convención:

Profesional%20con%20m%C3%A1s%20de%2010%20a%C3%B1os%20de%20experiencia%20en%20soluci%C3%B3n%20de%20problemas%20%2F%20red%20de%20acceso%2C%20operadores.%3Cbr%2F%3EExperiencia%20en%20configuraci%C3%B3n%20de%20equipos%20y%20resoluci%C3%B3n%20de%20problemas%20(Cisco%20-%207200%2C%20Juniper%20-%20MX%2C%20Alcatel%20%2F%20Nokia%20-%207750%20SR%2C%20Huawei%2C%20Datacom%20y%20Hewlett%20Packard).%20Protocolos%20de%20enrutamiento%3A%20OSPF%20y%20BGP.%20Redes%20MetroEthernet%2C%20Protocolo%20de%20t%C3%BAnel%20GRE%2C%20T%C3%BAnel%20y%20%C3%A1rbol%20de%20expansi%C3%B3n.%20Alta%20disponibilidad%20(HSRP%2C%20VRRP%20y%20GLBP).

Comentar

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

My Followers

¡Ingresa y disfruta de todos los beneficios para los miembros!

Inicia sesión

Comunidad Huawei Enterprise
Comunidad Huawei Enterprise
Bloquear
¿Estás seguro de bloquear a este usuario?
Los usuarios en lista negra no pueden comentar tus publicaciones,no pueden mencionarte,no pueden enviarte mensajes privados.