Cómo cambiar el tipo de enlace de una interfaz

116 0 0 0

Cómo cambiar el tipo de enlace de una interfaz


Descripción del problema

Cómo cambiar el tipo de enlace de una interfaz.


Solución

El tipo de enlace de una interfaz puede ser acceso, troncal, híbrido o Dot1q-tunnel. Los métodos utilizados para cambiar el tipo de enlace de una interfaz en diferentes versiones son diferentes. En V200R005 y versiones posteriores, ejecute el comando:

port link-type {access | trunk | hybrid | dot1q-tunnel}


Ingrese yes o no cuando se le solicite. Cuando la interfaz utiliza la configuración VLAN predeterminada, el sistema no muestra ningún mensaje. El tipo de enlace de la interfaz se cambia directamente. Cuando ingresa y presiona Enter, el dispositivo elimina automáticamente la configuración VLAN no predeterminada de la interfaz y establece el tipo de enlace de la interfaz a la especificada. Cuando ingresa n y presiona Enter, el dispositivo conserva el tipo de enlace actual y la configuración de VLAN de la interfaz.


Para el cambio del tipo de enlace de la interfaz a hybrid.

<HUAWEI> system-view

[HUAWEI] interface GigabitEthernet0/0/1

[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid

Warning: This command will delete VLANs on this port. Continue?[Y/N]:y

Info: This operation may take a few seconds. Please wait for a moment...done

 

En versiones anteriores de V200R005, una interfaz se une a la VLAN 1 de manera predeterminada, y el PVID de una interfaz es VLAN 1. Puede ejecutar el siguiente comando para cambiar el tipo de enlace de la interfaz:

port link-type {access | trunk | hybrid | dot1q-tunnel}

 

Para el cambio del tipo de enlace de la interfaz a access

<HUAWEI> system-view
[HUAWEI] interface GigabitEthernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type access
[HUAWEI-GigabitEthernet0/0/1] port default vlan 10

Para el cambio del tipo de enlace de la interfaz a trunk

<HUAWEI> system-view
[HUAWEI] interface GigabitEthernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type trunk
[HUAWEI-GigabitEthernet0/0/1] port trunk pvid vlan 10
[HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 10 20.

 

Para el cambio del tipo de enlace de la interfaz a hybrid

<HUAWEI> system-view
[HUAWEI] interface GigabitEthernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
[HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 10
[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 10
[HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 20

Para el cambio del tipo de enlace de la interfaz a dot1q-tunnel

<HUAWEI> system-view
[HUAWEI] interface GigabitEthernet0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[HUAWEI-GigabitEthernet0/0/1] port default vlan 10


Cuando cambia el tipo de enlace de una interfaz que no usa la configuración de VLAN predeterminada, el sistema muestra el mensaje " Error: Please renew the default configurations".


Para restaurar a los valores iniciales de la interface siga los siguientes pasos:

Para resturar la configuración de VLAN predeterminada de una interfaz de acceso o Dot1q-tunnel

<HUAWEI> system-view
[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1] undo port default vlan

Para resturar la configuración de VLAN predeterminada de una interfaz de trunk

< HUAWEI> system-view
[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1] undo port trunk pvid vlan
[HUAWEI-GigabitEthernet0/0/1] undo port trunk allow-pass vlan all
[HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 1

Para resturar la configuración de VLAN predeterminada de una interfaz hybrid

< HUAWEI> system-view
[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1] undo port hybrid pvid vlan
[HUAWEI-GigabitEthernet0/0/1] undo port hybrid vlan all
[HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 1


FIN

Comunidad Huawei Enterprise
https://forum.huawei.com/enterprise/es/forums


#OneHuawei



  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesi | Registrarse

Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje
Respuesta rápida Desplácese hasta arriba