¿Cómo transferir paquetes PVST+ sobre una red Huawei QinQ L2TP?

123 0 0 0

 Hola,


 Tuve un caso hace un par de meses sobre esta tecnología de túneles, y quiero compartirlo con ustedes. Si recientemente actualizaste tu red LAN de switches a la versión V200R003, tómate unos minutos para revisar éste caso.

Tenemos un escenario básico de QinQ L2TP, con 2xS5700 V200R003C00SPC300 trabajando como puntas del túnel. El cliente quería pasar transparentemente paquetes de PVST+ sobre la red habilitada Huawei. Por alguna razón, fallaba.


 La topología es la siguiente:

222911d6s2sr2o8y9rr7dz.png

 

 Configuración relacionada:

Software Version V200R003C00SPC300
#
sysname Quidway
#
vlan batch 166
#
l2protocol-tunnel eoam3ah group-mac 0100-0ccd-
cdd0
l2protocol-tunnel gmrp group-mac 0180-e500-0001
l2protocol-tunnel gvrp group-mac 0180-e500-0002
l2protocol-tunnel cdp group-mac 0100-0ccd-cdd0
l2protocol-tunnel dtp group-mac 0100-0ccd-cdd0
l2protocol-tunnel pvst+ group-mac 0100-0ccd-cdd0

interface Vlanif1
ip address 10.10.2.41 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 166
stp disable
#
interface GigabitEthernet0/0/3
port link-type dot1q-tunnel
port default vlan 166
stp disable
l2protocol-tunnel stp cdp pvst+ enable
jumboframe enable 9712
#

 

 La configuración del segundo switch sigue el mismo patrón. Con esta configuración los paquetes PVST+ no pueden pasar a través del túnel y el dominio PVST no puede ser integrado a la red Huawei. Como las estadísticas muestran los paquetes PVST+ no pueden ser enviados por el túnel.

 

 <Quidway>display l2protocol-tunnel statistics GigabitEthernet 0/0/3
 ---------------------------------------------------------------------------------------------
 Port            Protocol            Drop         Input          Output         Drop
                                       Threshold     Packets     Packets     Packets
 -----------------------------------------------------------------------------------------------
 GE0/0/3         stp                   0                 6                 0               0        
                       cdp                  0                 6                 0               0        
                      pvst+               0                 0                 0               0        

 

 Así que decidimos capturar paquetes en la interfaz ge0/0/3. Esto reveló que los paquetes son enviados por la interfaz sin cambiar la dirección de destino.

222900ynmzexew7lylesem.png

  

 Ya que en la configuración del switch insertamos el comando

 “l2protocol-tunnel pvst+ group-mac 0100-0ccd-cdd0" para la definición l2protocol-tunnel group-mac, las tramas entrando por el túnel deben de tener una dirección destino, cambiando de "0100-0ccc-cccd" (valor por defecto) a "0100-0ccd-cdd0". 


 La explicación de este fenómeno es que, en la versión V200R003, por defecto, los frames con dirección MAC destino 0100-0ccc-cccd son reenviados por el hardware como datos. Por esto, los frames no serán transmitidos por el túnel de protocolo capa 2. En esta situación necesitamos forzar al switch a procesar los frames de DA 0100-0ccc como bpdu y no como frames de datos.

 Solo necesitamos ajustar la configuración como se muestra a continuación:
 <HUAWEI> system-view
 [HUAWEI] bpdu mac-address 0100-0ccc-cccd


 Eso es todo; si tiene alguna pregunta, por favor haga un comentario en esta publicación.

 Gracias! 


  • x
  • convención:

Responder

Responder
Debe iniciar sesión para responder la publicación Inicio de sesión | Registrarse

Aviso Aviso: Para garantizar sus legítimos derechos e intereses, la comunidad y los terceros no publicarán contenido que pueda generar riesgos legales a las partes, por ejemplo, pornografía, contenido político, contenido sobre juego, consumo y tráfico de drogas, así como contenido que viole los derechos de propiedad intelectual de terceros, por ejemplo, secretos comerciales, marcas, derechos de autor, patentes y privacidad personal. No comparta su cuenta ni su contraseña con terceros. Todas las operaciones realizadas usando su cuenta se considerarán como sus acciones y todas las consecuencias que estas acciones generen serán responsabilidad suya. Para obtener información detallada, consulte la “ Política de privacidad.”
Si el botón para adjuntar no está disponible, actualice Adobe Flash Player con la versión más reciente
¡Ingresa y disfruta de todos los beneficios para los miembros!

¡Ingresa y disfruta de todos los beneficios para los miembros!

Aterrizaje