Voice Vlan Configuration Between Huawei & Cisco Switch

Created: Aug 12, 2019 14:39:13Latest reply: Aug 16, 2019 07:14:20 190 7 0 0
  Rewarded Hi-coins: 0 (problem resolved)

Hello

I am trying to configure voice vlan on the S5720-28X-PWR-LI-AC which is getting a link from Cisco switch but i can't seem to get it right. My scenario looks more like this, Cisco6500Core---->Cisco2960-------->HuaweiS5720

All the scopes are configured on the 6500 & all the access switches are pulling the vlans from the core, all access switches can ping all the vlans(dat+voice).

Now on the S5720 i have configured Voice Vlan30 & Data Vlan2 as follows

#
interface Vlanif30
dhcp select global
#
#
vlan batch 2 to 3 8 to 9 30 100 240 247 to 254
#
stp mode stp
#
dhcp enable
Lldp enable
#

interface GigabitEthernet0/0/24
description Cisco-IP-Phone
port link-type hybrid
voice-vlan 30 enable
voice-vlan legacy enable
port hybrid pvid vlan 2
port hybrid tagged vlan 30
port hybrid untagged vlan 2
trust 8021p
#

And the link port to Cisco2960 configs below:

#
interface XGigabitEthernet0/0/1
description link to cisco2960-sw1: Trunk
port link-type trunk
port trunk allow-pass vlan 2 to 4094
lldp compliance cdp receive
trust 8021p
#

The pc can get a dhcp ip address successfully but the Cisco IP phone is not getting any ip address, error: PHONE NOT REGISTERED

[Huawei-cctv1]display voice-vlan status
Voice VLAN Configurations:
-----------------------------------------------------------
Voice VLAN ID : 30
Voice VLAN status : Enable
Voice VLAN 8021p remark : 6
Voice VLAN dscp remark : 46
-----------------------------------------------------------
Port Information:
-------------------------------------------------------------------------------
Port Add-Mode Security-Mode Legacy PribyVLAN Untag
-------------------------------------------------------------------------------
GigabitEthernet0/0/24 Manual Normal Enable Disable Disable
[Huawei-cctv1]

On the cisco side i have enable LLDP & i can ping the Huawei & the link configs below
!
interface GigabitEthernet0/2
switchport mode trunk
!

What am i missing here?

  • x
  • convention:

Featured Answers
Popeye_Wang
Admin Created Aug 13, 2019 09:55:25 Helpful(0) Helpful(0)

Posted by VGL639G at 2019-08-13 06:40Yes it does and i have added it but for some reason the phone still can't get an IP#interface Giga ...

Maybe you're right, you can try to add the lldp compliance cdp txrx command to enable the interface to exchange information with CDP-capable devices.

In addition, I found that there is instruction for Interoperation Between Switches and Cisco IP Phones in the product document, which you can refer to.
  • x
  • convention:

All Answers
DDSN
DDSN Admin Created Aug 12, 2019 15:34:24 Helpful(0) Helpful(0)

  • x
  • convention:

Popeye_Wang
Popeye_Wang Admin Created Aug 13, 2019 00:53:05 Helpful(0) Helpful(0)

Does your IP phones send tagged voice packets? If the IP phones send untagged voice packets, you should add the include-untagged parameter: voice-vlan 30 enable include-untagged
  • x
  • convention:

VGL639G
VGL639G Created Aug 13, 2019 06:40:08 Helpful(0) Helpful(0)

Posted by Popeye_Wang at 2019-08-13 00:53 Does your IP phones send tagged voice packets? If the IP phones send untagged voice packets, you s ...
Yes it does and i have added it but for some reason the phone still can't get an IP

#
interface GigabitEthernet0/0/24
port link-type hybrid
voice-vlan 30 enable include-untagged
voice-vlan legacy enable
port hybrid pvid vlan 2
port hybrid untagged vlan 2 30
lldp compliance cdp txrx
port description phone
#

Huawei is using option184 for voice & in my Cisco scope am using option150, now am not 100% sure if this could be the issue since Cisco IP phones usually gets their voice VLAN from CDP right?
  • x
  • convention:

VGL639G
VGL639G Created Aug 13, 2019 06:42:12 Helpful(0) Helpful(0)

Posted by DDSN at 2019-08-12 15:34 For details how to configure voice vlan on Huawei switches, see https://support.huawei.com/hedex/hd ...
I have went thru this link & it doesn't say much about huawei switch getting a dhcp ip addresses from another vendor like cisco & how the configure should look like or what features i should enable
  • x
  • convention:

Popeye_Wang
Popeye_Wang Admin Created Aug 13, 2019 09:55:25 Helpful(0) Helpful(0)

Posted by VGL639G at 2019-08-13 06:40Yes it does and i have added it but for some reason the phone still can't get an IP#interface Giga ...

Maybe you're right, you can try to add the lldp compliance cdp txrx command to enable the interface to exchange information with CDP-capable devices.

In addition, I found that there is instruction for Interoperation Between Switches and Cisco IP Phones in the product document, which you can refer to.
  • x
  • convention:

VGL639G
VGL639G Created Aug 16, 2019 06:24:28 Helpful(0) Helpful(0)

Thank you very much Popeye_Wang, got it working now...
  • x
  • convention:

Yehudi
Yehudi Created Aug 16, 2019 07:14:20 Helpful(0) Helpful(0)

Hi friend,
Can you share how the problem is solved? Thank you very much.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login