Tunnel interface down IPv6 to IPv4 6to4 on S7703

Latest reply: Jul 27, 2018 09:54:54 466 1 0 0
I would like to setup a 6to4 tunnel with a third party software solution and not able. I tried the same settings with other vendors and the solution work except with switch S7703.


The tunnel does not go up and when setting IP address on interface vlan 200, receive error.

<Huawei>display device
S7703's Device status:
Slot  Sub Type         Online    Power      Register       Status     Role  
-------------------------------------------------------------------------------
1     -   ES1D2S08SX1E Present   PowerOn    Registered     Normal     NA    
2     -   ES1D2S08SX1E Present   PowerOn    Registered     Normal     NA    
3     -   ES1D2H02QX2S Present   PowerOn    Registered     Normal     NA    
4     -   ES0D00MCUA00 Present   PowerOn    Registered     Normal     Master
5     -   ES0D00MCUA00 Present   PowerOn    Registered     Normal     Slave 
PWR1  -   -            Present   PowerOn    Registered     Normal     NA    
PWR2  -   -            Present   PowerOn    Registered     Normal     NA    
FAN1  -   -            Present   PowerOn    Registered     Normal     NA    


After applying command below, error is: 

[test-ar1-s7703-Vlanif200] ipv6 address 2001::100/64
Error: The configured IPv6 address conflicted with the IPv6 address or prefix of interface Tunnel94.


1. Checked configuration below:

interface Vlanif200
 description IPv6
 ipv6 enable

#

interface Vlanif94
 description IPv6 tunnel
 ip binding vpn-instance 94
 ipv6 enable
 ip address 2.2.2.2 255.255.255.252
#
interface Eth-Trunk94
 ipv4 statistic enable both
 ipv6 statistic enable both
 service type tunnel
#
interface GigabitEthernet1/1/6
 description ipv4 to RN for IPV6 tunnel
 port link-type hybrid
 port hybrid tagged vlan 94
 loopback-detect enable
#
interface GigabitEthernet2/1/2
 description servicee loopback interface
 eth-trunk 94
#
interface Tunnel94
 description to HE
 ip binding vpn-instance 94
 ipv6 enable
 ipv6 address 2001::2/64
 tunnel-protocol ipv6-ipv4 6to4
 source 2.2.2.2

 eth-trunk 94
#
ipv6 route-static vpn-instance 94 :: 0 Tunnel94
ipv6 route-static vpn-instance 94 2001:: 16 Tunnel94

#


2. Changed the subnet of VLAN 200 and retried. Displaying interface Tunnel 94 shows tunnel still down:

<Huawei>display intnterface tunnel 94
Tunnel94 current state : UP
Line protocol current state : DOWN
Description:to HE tunnebroker
Route Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
Encapsulation is TUNNEL, loopback not set
Tunnel source 85.11.25.102 (Vlanif94), destination unknown
Tunnel protocol/transport IPv6 over IPv4(6to4)
Current system time: 2017-12-18 14:39
    Input bandwidth utilization  : --
    Output bandwidth utilization : --


3. Tried to configure the tunnel protocol to only ipv6-ipv4 as below, then retried.  

#
interface Tunnel94
 description to HE
 ip binding vpn-instance 94
 ipv6 enable
 ipv6 address 2002::2/64
 tunnel-protocol ipv6-ipv4

 source 2.2.2.2

 eth-trunk 94

#


4. Issue solved, interface status became UP!

[Huawei]display intnterface tunnel 94
Tunnel94 current state : UP
Line protocol current state : UP
Description:to HE tunnebroker
Route Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
Encapsulation is TUNNEL, loopback not set
Tunnel source 85.11.25.102 (Vlanif94), destination unknown
Tunnel protocol/transport IPv6 over IPv4(6to4)
Current system time: 2017-12-18 14:39
    Input bandwidth utilization  : --
    Output bandwidth utilization : --


Root cause: Tunnel protocol should have been set to only ipv6-ipv4 instead of ipv6-ipv4 6to4


Solution: Set tunnel interface as below:

interface Tunnel94
 ipv6 address 2002::2/64
 tunnel-protocol ipv6-ipv4

  • x
  • convention:

Created Jul 27, 2018 09:54:54 Helpful(0) Helpful(0)

thanks for sharing.Tunnel interface down IPv6 to IPv4 6to4 on S7703-2708719-1Tunnel interface down IPv6 to IPv4 6to4 on S7703-2708719-2Tunnel interface down IPv6 to IPv4 6to4 on S7703-2708719-3Tunnel interface down IPv6 to IPv4 6to4 on S7703-2708719-4
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top