Got it

Trunk Port Why need to assign PVID

Created: Apr 19, 2020 15:30:28Latest reply: Apr 20, 2020 06:49:22 115 4 0 0
  Rewarded HiCoins: 0 (problem resolved)

Network Diagram

Hi All,


I am new member for this Group.


I would like to ask for switching. Why need to assign trunk port to PVID 5.


[S1]interface Eth-Trunk 1
[S1-Eth-Trunk1]port trunk pvid vlan 5

[S2]intetrface Eth-Trunk 1
[S2-Eth-Trunk1]port turnk pvid vlan 5


Please see the attached Photo.


Thanks.

Attachment: You need to log in to download or view. No account? Register
  • x
  • convention:

Featured Answers

Recommended answer

Popeye_Wang
Admin Created Apr 20, 2020 06:49:22 Helpful(0) Helpful(0)

Hello,
If an interface is configured with the port tunk poid vlan 5 command,after receiving untagged data frames from other interfaces, the interface can add VLAN 5 tags to the frames and forward the frames. And after receiving the frame with the VLAN 5 tag, the interface removes the VLAN 5 tag and forwards the frame to another interface.

port link-type trunk
port trunk pvid vlan 5
port link-type trunk

The function of these commands are similar to that of the following command:

port link-type access
port default vlan 5

View more
  • x
  • convention:

All Answers
Unicef
Unicef MVE Created Apr 20, 2020 01:30:55 Helpful(0) Helpful(0)

Hi friend!

Function
Using the port trunk pvid vlan command, you can specify the default VLAN of a trunk interface.

Using the undo port trunk pvid vlan command, you can restore the original default VLAN of a trunk interface.

By default, VLAN 1 is the default VLAN of a trunk interface.

Format
port trunk pvid vlan vlan-id

undo port trunk pvid vlan

==========

Example
# Specify VLAN 5 as the default VLAN of GigabitEthernet 0/0/15.

<Base> system-view
[Base] interface GigabitEthernet 0/0/15
[Base-GigabitEthernet0/0/15] port link-type trunk
[Base-GigabitEthernet0/0/15] port trunk pvid vlan 5

https://support.huawei.com/enterprise/en/doc/EDOC1000015892/bd411de3/port-trunk-pvid-vlan
View more
  • x
  • convention:

Live%20Lead%20Love%20%3A)
jason_hu
jason_hu Admin Created Apr 20, 2020 03:46:48 Helpful(0) Helpful(0)

Hi,

The port trunk pvid vlan command specifies the default VLAN for a trunk interface.

The undo port trunk pvid vlan command restores the default VLAN of a trunk interface to the default setting.

By default, VLAN 1 is the default VLAN of trunk interfaces.

An interface may receive untagged and tagged frames, but the device processes only tagged frames. Therefore, the device adds a tag to each untagged frame received by an interface. The default VLAN ID of the interface can be added to untagged frames so that these frames are forwarded in the default VLAN.

If the ID of a nonexistent VLAN is configured as the PVID, VLAN 1 is added to the untagged packets. After the PVID is configured globally, the PVID of the interface is changed to the configured one.

The port trunk pvid vlan command only specifies the default VLAN of a trunk interface but does not add the trunk interface to the default VLAN. A trunk interface forwards frames with the default VLAN ID only after it is added to the default VLAN using the port trunk allow-pass vlan command.

If you run the port trunk pvid vlan command multiple times in the same interface view, only the latest configuration takes effect.

This configuration will be deleted automatically if the default VLAN is deleted in system view.

# Specify VLAN 5 as the default VLAN of GE0/0/1.

<HUAWEI> system-view[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1] port link-type trunk
[HUAWEI-GigabitEthernet0/0/1] port trunk pvid vlan 5

Glad to help you! Any further questions, let us know.

View more
  • x
  • convention:

Peterhof
Peterhof MVE Created Apr 20, 2020 06:48:00 Helpful(0) Helpful(0)

Hello!
I think that in your situation, the PVID of the Eth-Trunk should be configured in addition to the routing from the VLAN 3 and 4 to the VLAN 6 and 7 through the VLAN 5. And in this way assigning the VLAN to the interface will let it act the routing interface.
View more
  • x
  • convention:

I%20am%20an%20IT%20engineer%20in%20the%20State%20Museum%20Reserve%20Peterhof.%20My%20job%20is%20keeping%20alive%20our%20network%2C%20servers%20and%20storages%20solutions%20and%20also%20preparing%20for%20purchasing%20new%20equipment%20and%20server%20software.
Popeye_Wang
Popeye_Wang Admin Created Apr 20, 2020 06:49:22 Helpful(0) Helpful(0)

Hello,
If an interface is configured with the port tunk poid vlan 5 command,after receiving untagged data frames from other interfaces, the interface can add VLAN 5 tags to the frames and forward the frames. And after receiving the frame with the VLAN 5 tag, the interface removes the VLAN 5 tag and forwards the frame to another interface.

port link-type trunk
port trunk pvid vlan 5
port link-type trunk

The function of these commands are similar to that of the following command:

port link-type access
port default vlan 5

View more
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

My Followers

Login and enjoy all the member benefits

Login

Huawei Enterprise Support Community
Huawei Enterprise Support Community