[Troubleshooting Series] Case 34 Ping Failure Occurs in the M-LAG Scenarios

593 0 0 0

Physical Network Topology

161823z030eoue6o3ouz7q.png

 

Fault Description

Failed to ping the the IP address of Loopback interface on the SwitchC from the Server.

Configuration Files

l   SwitchA

!Software Version V100R005C10SPC200 

#
dfs-group 1
 source ip 10.1.1.1 
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE2/0/0
#
bgp 10088
 peer 102.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 102.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0   
  network 5.5.5.5 0.0.0.0
  network 102.1.1.0 0.0.0.255

l   SwitchB

[~R4U13-CE12800-SWITCH-B]dis cu
#
dfs-group 1
 source ip 10.1.1.2 
#
traffic classifier test type or
 if-match ipv6 acl 3000
#
traffic behavior test
 redirect interface 10GE3/0/9
#
traffic policy test
 classifier test behavior test precedence 5
#
ospfv3 100
 area 0.0.0.0
#
interface Vlanif100
 ip address 10.1.1.2 255.255.255.0
 pim silent
 pim sm
 igmp enable
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE3/0/9
 eth-trunk 1    
 device transceiver 1000BASE-X
#
interface 10GE3/0/10
 eth-trunk 10
 device transceiver 1000BASE-X
#
interface 10GE3/0/11
#
interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
interface Tunnel1
 ipv6 enable
 ip address 13.13.13.14 255.255.255.0
 ipv6 address 100:100::100/64
 tunnel-protocol gre
 source 107.1.1.2
 destination 107.1.1.1
 ospfv3 100 area 0.0.0.0
#
bgp 10089
 peer 107.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 107.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0
  network 5.5.5.5 0.0.0.0
  network 13.13.13.0 0.0.0.255
  network 107.1.1.0 0.0.0.255 

l   SwitchC

!Software Version V100R005C10SPC200
#
dfs-group 1
 source ip 10.1.1.2 
#
bridge-domain 10
 vxlan vni 5010
#
acl ipv6 number 3000
 rule 1 permit ipv6 destination 100::/64
#
traffic classifier test type or
 if-match ipv6 acl 3000
#
traffic behavior test
 redirect interface 10GE3/0/9
#
traffic policy test
 classifier test behavior test precedence 5
#
ospfv3 100
 area 0.0.0.0
#
interface Vlanif100
 ip address 10.1.1.2 255.255.255.0
 pim silent
 pim sm
 igmp enable
#
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.103 255.255.255.0
 ipv6 address 1000:1000::1/64
 vrrp vrid 1 virtual-ip 100.100.1.101
 vrrp6 vrid 2 virtual-ip FE80::5 link-local
 vrrp6 vrid 2 virtual-ip 1000:1000::1000
 traffic-policy test inbound 
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE3/0/2
 undo portswitch
 mtu 1300
 ipv6 enable
 ip address 107.1.1.2 255.255.255.0
 ipv6 address 100::2/64
 ospfv3 100 area 0.0.0.0
 jumboframe enable 1536
 device transceiver 1000BASE-X
#
 eth-trunk 1    
 device transceiver 1000BASE-X
#
interface 10GE3/0/10
 eth-trunk 10
 device transceiver 1000BASE-X
#
interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
interface Tunnel1
 ipv6 enable
 ip address 13.13.13.14 255.255.255.0
 ipv6 address 100:100::100/64
 tunnel-protocol gre
 source 107.1.1.2
 destination 107.1.1.1
 ospfv3 100 area 0.0.0.0
#
bgp 10089
 peer 107.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 107.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0
  network 5.5.5.5 0.0.0.0
  network 13.13.13.0 0.0.0.255
  network 107.1.1.0 0.0.0.255

l   Server

!Software Version V100R005C10SPC200
#
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.1 255.255.255.0
 ipv6 address 1000:1000::2/64
 ipv6 address auto link-local
#
interface Vlanif4000
 ip address 17.1.1.100 255.255.255.0
#
interface MEth0/0/0
#
interface Eth-Trunk100
 port link-type trunk
 port trunk allow-pass vlan 4000
#
interface 10GE1/0/14
 eth-trunk 100
 device transceiver 1000BASE-X
#
interface 10GE1/0/23
 eth-trunk 100  
 device transceiver 1000BASE-X
#
ip route-static 0.0.0.0 0.0.0.0 100.100.1.101
#
ipv6 route-static :: 0 1000:1000::1000

Troubleshooting Procedure

                               Step 1      According to the test results, the server can sometimes ping through SwitchC, but sometimes it can not ping through SwitchC. When it can not ping normally, it receives a ping request packet from SwitchB, but does not receive this message, it can be concluded that the message is sent to the SwitchB device, and no message is sent out.

161824v0rfyrb8ymlfblbb.png

                               Step 2      Try to ping the SwitchB on the SwitchC and find that it can ping. Therefore, it can be concluded that the packet is discarded when it enters the inbound direction of the SwitchB device:

161825brsuejzrrwsejqul.png

                               Step 3      Check DFS neighbor status on SwitchA and SwitchB devices.

Run the  display dfs-group command to check M-LAG information. We find that the M-LAG status is normal.

161826oty2d1z3lz1jx2c6.png

And then we check the packets received form the server:

161826j3xfl4hgoyp1phnn.png

We find that the destination MAC address is not the MAC address of the VLAN interface on SwitchB, it causes this problem, and the traffic flow is dropped when traffic is sent to SwitchB.

161827gkxm8box83mexob3.png

We check that the traffic works fine when it is sent to SwitchA, and the destination MAC address is the VLAN interface MAC address on SwitchA.

Solution:  Take a reference of the product document, it is recommended to configure the VRRP dual gateway or the same IP address and MAC address on the VLAN interface. Configure the same IP address and MAC address:

# SwitchA
[~SwitchA]    interface vlanif 1000
[*SwitchA-Vlanif1000] ip address 100.100.1.101 24
[*SwitchA-Vlanif1000] mac-address 0000-5e00-0101
[*SwitchA-Vlanif1000] quit
[*SwitchA] commit
# SwitchB

[~SwitchB]    interface vlanif 1000
[*SwitchB-Vlanif1000] ip address 100.100.1.101 24
[*SwitchB-Vlanif1000] mac-address 0000-5e00-0101
[*SwitchB-Vlanif1000] quit
[*SwitchB] commit

 

After doing this configuration, all work fine.

161828tvswt0su5ysbygvs.png

Root Cause

On the M-LAG neighbor, the server accesses two gateways based on the load balancing mode of the Eth-Trunk. Therefore, the two M-LAG-enabled devices are all gateway devices and need to use the same gateway MAC address.

 


  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top