[Troubleshooting Series] Case 13 Switches Connecting to Devices at the Two Ends Cannot Transparently Transmit BPDUs Highlighted

Latest reply: Dec 14, 2018 08:00:20 217 1 2 1

Switches Connecting to Devices at the Two Ends Cannot Transparently Transmit BPDUs


Network Topology

Figure 1-1 Network where a layer2 protocol transparent failure occurs

 084542tzyr2ra7rn72201y.png

Fault Description

A LLDP neighbor relationship cannot be established between SwitchA and SwitrchC for the transparently transmit BPDUs failure of SwitchB.


Configuration Files

l   SwitchA

interface Vlanif20
 ip address 1.1.1.1 255.255.255.0
interface Eth-Trunk100
interface Ethernet0/0/0/0
 ip address 10.220.7.128 255.255.254.0
interface GigabitEthernet1/1/1/23
 port link-type access
 port default vlan 20                                     
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1

l   SwitchB

interface Vlanif20
 ip address 1.1.1.2 255.255.255.0
interface Vlanif220
 ip address 10.220.7.121 255.255.254.0
interface Ethernet0/0/23
 port link-type access
 port default vlan 20
 l2protocol-tunnel lldp enable
interface Ethernet0/0/24
 port link-type access
 port default vlan 20
 l2protocol-tunnel lldp enable
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk pvid vlan 220
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 220           
 ip route-static 0.0.0.0 0.0.0.0 10.220.6.1

l   SwitchC

vlan batch 20 103 220
interface Vlanif20                        
 ip address 2.1.1.1 255.255.255.0
interface MEth0/0/1
 ip address 10.220.7.122 255.255.254.0
interface GigabitEthernet0/0/24
 port link-type access
 port default vlan 20
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1
ip route-static 1.1.1.0 255.255.255.0 2.1.1.2

Troubleshooting Location

Troubleshooting Procedure

                              

Step 1      Check  information about neighbors of the device.

Run the display lldp neighbor brief command to check the current LLDP neighbors between devices.

<SwitchA> display lldp neighbor brief
Local Intf   Neighbor Dev             Neighbor Intf             Exptime(s)
GE1/1/1/23   SwitchB                  Ethernet0/0/24            103

<SwitchB> display lldp neighbor brief
Local Intf       Neighbor Dev             Neighbor Intf             Exptime(s)
Ethernet0/0/23   SwitchA                  GE1/1/1/23                118
Ethernet0/0/24   SwitchC                  GE0/0/24                  103

<SwitchC> display lldp neighbor brief
Local Intf       Neighbor Dev             Neighbor Intf             Exptime(s)
GE0/0/24         SwitchB                  Ethernet0/0/24            113

As a result, the current SwitchB failed to transparently tranmit the LLDP BPDUs as configured.

                              

Step 2      Check the SwitchB anout  Layer 2 protocol packets that are transparently transmitted.

Run the display l2protocol-tunnel statistics command the the statistics about Layer 2 protocol packets that are transparently transmitted on a specified interface.

<SwitchB> display l2protocol-tunnel statistics Ethernet 0/0/23 lldp
--------------------------------------------------------------------------------
Port                Protocol         Drop       Input      Output     Drop
                                     Threshold  Packets    Packets    Packets
--------------------------------------------------------------------------------
Ethernet0/0/23      lldp             0          0          0          0  

<SwitchB> display l2protocol-tunnel statistics Ethernet 0/0/24 lldp
--------------------------------------------------------------------------------
Port                Protocol         Drop       Input      Output     Drop
                                     Threshold  Packets    Packets    Packets
--------------------------------------------------------------------------------
Ethernet0/0/24      lldp             0          0          0          0

The command output does not contain statistics about transparently transmitted LLDP DUs.

                              

Step 3      Check the layer 2 protocol transparent transmission configuration of the SwitchB.

Run the display current-configuration to check the configuration of layer 2 protocol transparent transmission on the specified interfaces based on the chapter Configuring Interface-based Layer 2 Protocol Transparent Transmission:

l   Check whether the group MAC function for transparent transmission of LLDP DUs is enabled globally.

l   Check whether Layer 2 protocol transparent transmission is enabled on the interfaces connecting SwitchB to SwitchA and SwitchC, respectively.

#
interface Ethernet0/0/23
 port link-type access
 port default vlan 20
 l2protocol-tunnel lldp enable
#
interface Ethernet0/0/24
 port link-type access
 port default vlan 20
 l2protocol-tunnel lldp enable

It is found that the group MAC function is disabled globally on SwitchB.

Solution: Enables the SwitchB to replace the multicast destination MAC address of Layer 2 protocol packets with a specified multicast MAC address. When configuring Layer 2 protocol transparent transmission, pay atteition about the following precautions Configuring Layer 2 Protocol Transparent Transmission Mode.

[SwitchB] l2protocol-tunnel lldp group-mac 0100-0100-0100

After this function is enabled, run the display lldp neighbor brief command to check the current LLDP neighbors between devices, you can find that SwitchB can transparently transmit LLDP DUs.

<SwitchA> display lldp neighbor brief
Local Intf   Neighbor Dev             Neighbor Intf             Exptime(s)
GE1/1/1/23   SwitchC                  GE0/0/24                  103

<SwitchC> display lldp neighbor brief
Local Intf   Neighbor Dev             Neighbor Intf             Exptime(s)
GE0/0/24     SwitchA                  GE1/1/1/23                  112


Root Cause

The group MAC function for transparent transmission of Layer 2 protocol packets is disabled globally on SwitchB.


  • x
  • convention:

Finn92
Created Dec 14, 2018 08:00:20 Helpful(0) Helpful(0)

Enables the SwitchB to replace the multicast destination MAC address of Layer 2 protocol packets with a specified multicast MAC address. When configuring Layer 2 protocol transparent transmission, pay atteition about the following precautions Configuring Layer 2 Protocol Transparent Transmission Mode.
hello author ,it's a good sharing , but i have a question ,
if you change the multicast destination MAC address , does it will impact other service ?
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login