[Troubleshooting Series]Case 11 PC of the same network segment cannot Ping Highlighted

Latest reply: Dec 27, 2018 07:52:20 385 4 1 1

PC of the same network segment cannot Ping

Network Topology

Physical Network Topology

090959yt391s8tkdvd55dt.png

Fault Description

SW0 cannot ping the IP of Vlanif101 of SW1. You need solve the issue without changing the IP address, because the customer does not allow to change of the IP address.

Configuration Files

SW0:
#
interface Vlanif100
ip address 10.122.0.184 255.255.254.0
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
#
SW1:
#
interface Vlanif101
ip address 10.122.1.10 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 101
#
Core Switch:
#
interface Vlanif100
ip address 10.122.0.1 255.255.255.0
#
interface Vlanif101
ip address 10.122.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 101
#

Troubleshooting Location

Troubleshooting Procedure

                               Step 1      The IP address of Vlanif101 of SW1 and Vlanif100 of SW0 are in the same network segment. The ARP request message is broadcast and can not be transmitted across the VLAN to the SW1. Therefore, SW1 can not learn ARP, which leads to Ping failure.

                               Step 2      Enable the ARP proxy function.

[CoreSwitch-Vlanif100] arp-proxy enable


Root Cause

The IP address of Vlanif101 of SW1 and Vlanif100 of SW0 are in the same network segment. The ARP request message is broadcast and can not be transmitted across the VLAN to the SW1. Therefore, SW1 can not learn ARP, which leads to Ping failure.


  • x
  • convention:

EdeninRealMadrid
Created Dec 12, 2018 09:29:18 Helpful(0) Helpful(0)

Its useful
  • x
  • convention:

sim_157
Created Dec 18, 2018 03:25:42 Helpful(0) Helpful(0)

I used to encountered the same failure, but with the other fault caused, maybe I should sharing that case .
  • x
  • convention:

Finn92
Created Dec 18, 2018 06:58:23 Helpful(0) Helpful(0)

wow , thank you author , it's a good sharing for ARP proxy .
  • x
  • convention:

dagui
Created Dec 27, 2018 07:52:20 Helpful(0) Helpful(0)

The IP address of Vlanif101 of SW1 and Vlanif100 of SW0 are in the same network segment.How do you understand this sentence?
  • x
  • convention:

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login