Symptom
When an attempt is made to upgrade the LG RESU7H/RESU10H battery of the DC-to-DC converter on the FusionHome app, a message indicating that the upgrade fails is displayed on the app.
Upgrade failure:

The battery ON indicator blinks:

Possible Causes
The FusionHome app version is earlier than 3.1.00.003
The SUN2000L version is earlier than SUN2000L V100R001C00SPC318
Solution
Step 1 Download the latest FusionHome app from Google Play or App Store.
Step 2 Upgrade the software using the SUN2000L upgrade package supplied with the FusionHome app.
Log in to the FusionHome app as installer. Choose HomeàUpgrade device-->Upgrading the inverter. After the upgrade is successful, the SUN2000L restarts.
Upgrading the inverter:

Step 3 Turn off the battery switch and Auxiliary Power ON/OFF switch, and then turn off the AC switch and the DC switch of the SUN2000L in sequence.
Turning off the battery switch and Auxiliary Power ON/OFF switch:

Step 4 Wait for 1 minute. Turn on the battery switch and Auxiliary Power ON/OFF switch, and then turn on the AC switch and the DC switch of the SUN2000L in sequence.
Turning on the battery switch and Auxiliary Power ON/OFF switch:

Step 5 Reconnect the battery to the FusionHome app, and check the software version of the battery DC-to-DC converter on the device upgrade screen. If the version is earlier than V4.7, upgrade the software using the battery upgrade package supplied with the FusionHome app. There are two battery models: RESU7H and RESU10H. Choose the corresponding upgrade package to perform the upgrade.
Upgrading the battery: Choose HomeàUpgrade deviceàUpgrading the battery.
Step 6 Check whether the ON indicator of the LG battery blinks. If so, upgrade the battery again.

(1) Battery ON indicator | (2) Battery model |
Step 7 After the upgrade succeeds, choose Home > Device information > Device status on the FusionHome, and check whether the battery status is normal.
Step 8 If the upgrade fails, try again as prompted. If the failure persists, turn off the battery switch and Auxiliary Power ON/OFF switch, and contact LG after-sales service.
Note:
If you cannot obtain the LG battery software upgrade package, download it from the following link: http://solar.huawei.com/~/media/Solar/attachment/pdf/eu/service/residential/product/software/20170920_RESU7H_6C30_5047.bin
LG after-sales service:
Area | Contact Info | |
HQ (KOR)/Other regions | Address | 29, Gwahaksaneop-3-ro, Oksan-myeon, Heungdeok-gu, Cheongju-si, Chungcheongbuk-do, South Korea |
essservice@lgchem.com | ||
US | Address | 1064 Chicago Rd, Troy, MI 48083, USA |
Telephone | +1 888 375 8044 | |
CSNorthAmeicaESS@lgchen.com | ||
Europe | Address | Otto-Volger Str. 7C 65843 Sulzbach (Taunus), Germany |
Telephone | +49 6196 5719 660 | |
techcentereu@lgchem.com | ||
Australia | Address | Unit 12, 25-37 Dunlop Road, Mulgrave, 3170, Victoria, Australia |
Telephone | +61 1300 178 064 | |
essserviceau@lgchem.com | ||

