Traffic balance tunnel LSP

Created: Jul 13, 2018 20:31:46Latest reply: Jul 18, 2018 08:09:30 883 5 0 0
  Rewarded Hi-coins: 0 (problem resolved)
Hi everyone,

I need to use two or more tunnel to the same destination in the same l2vc/vsi, and the tunnels forward traffic... (Switchs S57xx or S67xx).

Basically, load-balance traffic into two tunnel lsp.
I have the same case in Extreme switchs. But in Huawei, I don't figure out how to work..

The topology of my laboratory example.

Traffic balance tunnel LSP-2696883-1


In this case, RT-01 send a traffic flow of 2gbps for destination RT-02. I need that Huawei Switch using two tunneis LSP (witch are with two explict-path, to-sw04-via-sw01 and to-sw04-via-sw02) for this traffic flow.


Notice:
- Interfaces of RT-01 and RT-02 is 10gbps, all another is 1gbps.
- The traffic flow is for more that one destination ip, where the next-hop is RT-02


It's possible?


Thanks  all



--
Follow configuration of SW_03:


!Software Version V200R010C00SPC600
#
sysname Sw03
#
vlan batch 402 501 to 502 4088 to 4089
#
lnp disable
#
stp disable
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name dot1xmac_authen_profile
authentication-profile name multi_authen_profile
#
telnet server enable
#
diffserv domain default
#
radius-server template default
#
mpls lsr-id 3.3.3.3
mpls
mpls te
mpls rsvp-te
mpls te cspf
#
mpls l2vpn
mpls l2vpn default martini
#
explicit-path any
next hop 4.4.4.4 include loose
#
explicit-path to-sw04-via-sw01
next hop 10.10.10.10
next hop 10.10.10.18
#
explicit-path to-sw04-via-sw02
next hop 10.10.10.5
next hop 10.10.10.14
#
mpls ldp
#
#
mpls ldp remote-peer 4.4.4.4
remote-ip 4.4.4.4
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
drop-profile default
#
#
interface Vlanif1
#
interface Vlanif500
#
interface Vlanif501
ip address 10.10.10.6 255.255.255.252
ospf network-type p2p
ospf dr-priority 0
ospf ldp-sync
mpls
mpls te
mpls rsvp-te
mpls ldp
#
interface Vlanif502
ip address 10.10.10.9 255.255.255.252
ospf network-type p2p
ospf dr-priority 0
ospf ldp-sync
mpls
mpls te
mpls rsvp-te
mpls ldp
#
interface Vlanif4088
#
interface Vlanif4089
mpls l2vc 4.4.4.4 704089 tunnel-policy 1 raw
#
interface MEth0/0/1
ip address 10.8.252.203 255.255.255.0
#
interface GigabitEthernet0/0/26
description to-rt-01
port link-type trunk
port trunk allow-pass vlan 4088 to 4089
jumboframe enable 12288
#
interface GigabitEthernet0/0/27
description to-sw-01
port link-type trunk
port trunk allow-pass vlan 502
jumboframe enable 12288
#
interface GigabitEthernet0/0/28
description to-sw-02
port link-type trunk
port trunk allow-pass vlan 501
jumboframe enable 12288
#
interface NULL0
#
mpls l2vpn load-balance encapsulation ethernet
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
interface Tunnel2
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 101
mpls te path explicit-path to-sw04-via-sw01
mpls te commit
#
interface Tunnel3
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 102
mpls te path explicit-path to-sw04-via-sw02
mpls te commit
#
ospf 1 router-id 3.3.3.3
opaque-capability enable
enable traffic-adjustment
area 0.0.0.0
  network 3.3.3.3 0.0.0.0
  network 10.10.10.4 0.0.0.3
network 10.10.10.8 0.0.0.3
  mpls-te enable
#
tunnel-policy 1
tunnel select-seq cr-lsp load-balance-number 2
#


Attachment: You need to log in to download or view. No account?Register
  • x
  • convention:

Featured Answers
Created Jul 14, 2018 15:14:11 Helpful(0) Helpful(0)

Configuration is right. But load balance is not supported in forwarding plane for l2vpn for S series switches.
  • x
  • convention:

All Answers
ShineBoy1 Created Jul 13, 2018 22:01:43 Helpful(0) Helpful(0)

This is a good question.
  • x
  • convention:

q00244754 Created Jul 14, 2018 15:14:11 Helpful(0) Helpful(0)

Configuration is right. But load balance is not supported in forwarding plane for l2vpn for S series switches.
  • x
  • convention:

alexandre_heidemann Created Jul 14, 2018 20:21:29 Helpful(0) Helpful(0)

Posted by q00244754 at 2018-07-14 04:14 Configuration is right. But load balance is not supported in forwarding plane for l2vpn for S series ...
Thanks for your reply. What's the series switch support that?
  • x
  • convention:

gogo_BBIP Created Jul 17, 2018 06:26:38 Helpful(0) Helpful(0)

Thanks for your reply
  • x
  • convention:

user_2844477 Created Jul 18, 2018 08:09:30 Helpful(0) Helpful(0)

Hi Alexandre.

I have the same scenario and was not able to figure out how to work this out. It looks like a hardware limitation, since other platforms can handle this situation.
  • x
  • convention:

Reply

Reply
You need to log in to reply to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!

Login and enjoy all the member benefits

Login
Fast reply Scroll to top