Got it

sw5731 configuring. Two roles on the port at once

Created: Mar 17, 2020 10:40:43Latest reply: Mar 18, 2020 13:57:30 200 3 0 0 0
  Rewarded HiCoins: 0 (problem resolved)

Hello all!!

It is necessary to do the same as in the example on cisco

"

interface GigabitEthernet0/48 

 switchport access vlan 9

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 3,11

 switchport mode access


"

How to do it on Huawei s5731
Big thanks!


  • x
  • convention:

Featured Answers
chenhui
Admin Created Mar 17, 2020 11:15:14

Hi @CRYINBURG,
For command

switchport access vlan 9
switchport mode access


please refer to the configuration below:

int gx/x/x
port link-t a
port default vlan 9


But for command

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,11

as far as I know, command "switchport trunk" is used when the interface set to trunk mode, but the configuration you pasted indicates the interface is configured as an access interface.


If you persist, the corresponding commands for these two command are listed below:

port trunk all vlan 3 11
undo port trunk all vlan 1   //when the vlan 1 is banned from the interface


As for command "switchport trunk encapsulation dot1q", since the Huawei switch encapsulate the vlan packets with the standard protocol which is 802.1q, so there is no need to add the extra command.


View more
  • x
  • convention:

All Answers
chenhui
chenhui Admin Created Mar 17, 2020 11:15:14

Hi @CRYINBURG,
For command

switchport access vlan 9
switchport mode access


please refer to the configuration below:

int gx/x/x
port link-t a
port default vlan 9


But for command

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,11

as far as I know, command "switchport trunk" is used when the interface set to trunk mode, but the configuration you pasted indicates the interface is configured as an access interface.


If you persist, the corresponding commands for these two command are listed below:

port trunk all vlan 3 11
undo port trunk all vlan 1   //when the vlan 1 is banned from the interface


As for command "switchport trunk encapsulation dot1q", since the Huawei switch encapsulate the vlan packets with the standard protocol which is 802.1q, so there is no need to add the extra command.


View more
  • x
  • convention:

CRYINBURG
CRYINBURG Created Mar 18, 2020 08:05:54

interface GigabitEthernet0/48

switchport access vlan 9

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,11

switchport mode access
___

How much I understand it works like this

  1. Cisco accepts VLAN 3,11 tag 802.1Q on port GigabitEthernet0/48

  2. Then vlan 3,11 turn in vlan 9. I guess I didn 't test

View more
  • x
  • convention:

chenhui
chenhui Admin Created Mar 18, 2020 13:57:30

Posted by CRYINBURG at 2020-03-18 08:05 interface GigabitEthernet0/48 switchport access vlan 9 switchport trunk encapsulation dot1q
Hi,
As far as I know, it's OK to configure the Cisco switch as
interface GigabitEthernet0/48
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,11

Or

interface GigabitEthernet0/48
switchport mode access
switchport access vlan 9

For the first scenario, the corresponding Huawei configuration would be
interface Gx/x/x
port link-type trunk
port trunk allow vlan 3 11

And, for the second scenario, the corresponding Huawei configuration would be:
interface Gx/x/x
port link-type accesss
port default vlan 9

You are kindly advised to check the configuration, if the command "switchport mode access" and "switchport trunk encapsulation dot1q" are configured on the same interface.
View more
  • x
  • convention:

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."

My Followers

Login and enjoy all the member benefits

Login

Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.