Service Interruption between QINQ devices

Latest reply: Dec 30, 2018 07:14:43 418 2 0 0

Service Interruption between QINQ devices


Physical Network Topology

SwitchA sends ping packets carried vlan10 tag; on SwitchB, enable vlan-stacking and vlan-mapping on GE0/0/25, and the inner VLAN tag is 210 and outer WLAN tag is 2010; on switchC,  dot1q-tunnel is enabled on GE2/0/25, which causes SwitchA and SwitchD can ping through each other.

084656vnnnwuh8kfd5n3k5.png


Fault Description

switchA can not ping switchd.


Configuration Files

SwitchA:

#

interface Vlanif10

ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/25

port link-type trunk

port trunk allow-pass vlan 10

#

SwitchB:

#

interface GigabitEthernet0/0/25

port link-type hybrid

qinq vlan-translation enable

undo port hybrid vlan 1

port hybrid tagged vlan 10

port hybrid untagged vlan 2010

port vlan-stacking vlan 210 stack-vlan 2010

port vlan-mapping vlan 10 map-vlan 210

#

interface GigabitEthernet0/0/26

port link-type trunk

port trunk allow-pass vlan 2010

#

SwitchC:

#

interface GigabitEthernet2/0/26

port link-type trunk

port trunk allow-pass vlan 2010

#

interface GigabitEthernet2/0/25

port link-type dot1q-tunnel

port default vlan 2010

#

SwitchD:

#

interface GigabitEthernet0/0/25

port link-type trunk

port trunk allow-pass vlan 210

#

interface Vlanif210

ip address 192.168.1.2 255.255.255.0

#


Troubleshooting Location


Step 1      Check whether to have learned the remote's ARP entry on switchA and switchD.

<switchA>  display arp | in 192.168.1
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE 
                                          VLAN/CEVLAN 
------------------------------------------------------------------------------
192.168.1.1     a08c-f8bb-803b            I -         Vlanif10
------------------------------------------------------------------------------
Total:36        Dynamic:29      Static:0     Interface:7

It shows that switchA have not learn the ARP of switchD.

<switchD> display arp | in 192.168.1  
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE 
                                          VLAN/CEVLAN 
------------------------------------------------------------------------------
192.168.1.2     a08c-f88d-1391            I -         Vlanif210
------------------------------------------------------------------------------
Total:38        Dynamic:36      Static:0     Interface:2

It shows that switchD have not learn the ARP of switchA.


Step 2      After switchA and switchD ping each other, check the MAC address.

<SwitchA> display int Vlanif 10
Vlanif10 current state : UP
Line protocol current state : UP
Last line protocol up time : 2018-09-10 12:29
Description:
Route Port,The Maximum Transmit Unit is 1500
Internet Address is 192.168.1.1/24
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is a08c-f8bb-803b
Current system time: 2018-09-10 12:29
    Input bandwidth utilization  : --
    Output bandwidth utilization : --

<SwitchD> display interface Vlanif 210
Vlanif210 current state : UP
Line protocol current state : UP
Last line protocol up time : 2018-09-10 12:29
Description:
Route Port,The Maximum Transmit Unit is 1500
Internet Address is 192.168.1.2/24
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is a08c-f88d-1391
Current system time: 2018-09-10 12:29
    Input bandwidth utilization  : --
    Output bandwidth utilization : --

<SwitchA> display mac-address GigabitEthernet 1/0/25
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI                          Learned-From        Type      
-------------------------------------------------------------------------------
643e-8c30-9c40 1/-                               GE1/0/25            dynamic   
c80c-c8dc-fec0 1/-                               GE1/0/25            dynamic   
d4c8-b02e-8ec0 1/-                               GE1/0/25            dynamic   
fce3-3c9f-3f70 10/-                              GE1/0/25            dynamic   
 
-------------------------------------------------------------------------------
Total items displayed = 4

<SwitchB> display mac-address GigabitEthernet 0/0/25
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI/BD                       Learned-From        Type      
-------------------------------------------------------------------------------
 
-------------------------------------------------------------------------------
Total items displayed = 0 
 
<SwitchB> display mac-address GigabitEthernet 0/0/26
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI/BD                       Learned-From        Type      
-------------------------------------------------------------------------------
643e-8c30-9c40 2010/-/-                          GE0/0/26            dynamic   
a08c-f88d-1391 2010/-/-                          GE0/0/26            dynamic    
c80c-c8dc-fec0 2010/-/-                          GE0/0/26            dynamic   
d4c8-b02e-8ec0 2010/-/-                          GE0/0/26            dynamic 

<SwitchC> display mac-address GigabitEthernet 2/0/26
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI                          Learned-From        Type      
-------------------------------------------------------------------------------
 
-------------------------------------------------------------------------------
Total items displayed = 0 
 
<SwitchC> display mac-address GigabitEthernet 2/0/25
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI                          Learned-From        Type      
-------------------------------------------------------------------------------
643e-8c30-9c40 2010/-                            GE2/0/25            dynamic   
a08c-f88d-1391 2010/-                            GE2/0/25            dynamic    
c80c-c8dc-fec0 2010/-                            GE2/0/25            dynamic   
d4c8-b02e-8ec0 2010/-                            GE2/0/25            dynamic   
fce3-3c9f-3f70 2010/-                            GE2/0/25            dynamic   
 
-------------------------------------------------------------------------------
Total items displayed = 5

<SwitchD> display mac-address GigabitEthernet 0/0/25
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI                          Learned-From        Type      
-------------------------------------------------------------------------------
fce3-3c9f-3f70 1/-                               GE0/0/25            dynamic   
 
-------------------------------------------------------------------------------
Total items displayed = 1

From the above information, we can know:

After switchA pings switchD, GE0/0/25 on switchB did not learn MAC address of  vlanif10 of switchA.

After switchD pings switchA, GE0/0/26 on switchB have learned the MAC address of vlanif210 of switchD.

It indicates that the ping packet was discarded in GE0/0/25 on switchB.

SwitchB can learn the MAC address of the switchA of vlanif, but the VLAN is 210; indicating that only vlan-mapping takes effect and vlan-stacking does not.


Step 3      Run the port vlan-stacking vlan 10 stack-vlan 2010 map-vlan 210 command, and the service is restored to normal.

[switchA-GigabitEthernet0/0/25] port vlan-stacking vlan 10 stack-vlan 2010 map-vlan 210



Root Cause

For fixed switches running V200R011C10SPC600 and later versions, the port vlan-stacking vlan 10 stack-vlan 2010 map-vlan 210 command is added to configure VLAN mapping and VLAN stacking together. For fixed switches running earlier versions, the VLAN mapping and VLAN stacking functions cannot be configured together.

When the port vlan-stacking vlan 210 stack-vlan 2010 and port vlan-mapping vlan 10 map-vlan 210 commands are run on an interface, only the VLAN mapping function takes effect.


  • x
  • convention:

sim_157
Created Dec 18, 2018 03:19:12 Helpful(0) Helpful(0)

excellent case, but it seems too difficult to me, I need more basic knowledge to improve me.Service Interruption between QINQ devices-2822185-1
  • x
  • convention:

Mysterious.color
MVE Created Dec 30, 2018 07:14:43 Helpful(0) Helpful(0)

excellent man
  • x
  • convention:

Core%20Engineer%2C%20Technical%20Department.%20High%20experience%20in%20Networking

Comment

Reply
You need to log in to reply to the post Login | Register

Notice Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."
If the attachment button is not available, update the Adobe Flash Player to the latest version!
Login and enjoy all the member benefits

Login and enjoy all the member benefits

Login