Got it

Selective QinQ transported by MPLS L2VC simulated on eNSP Highlighted

Latest reply: Jan 18, 2021 00:11:23 1774 32 25 10

        The MPLS brings many facilities to ISP promoting the possibility of delivering transports through VPNs, one of which is the VPWS, which delivers a point to point link that can be configured on a specific VLAN or on a dedicated physical port for a customer.


        When configured on a physical port, the VPWS will transport all data inserted on this port directly to the other side of the tunnel, including all existent VLAN ID.


        But, at some moment, the customer may request that be realized the selection of some VLANs to a specific tunnel and other VLANs to another tunnel. For this is necessary the utilization of a technique called Selective QinQ, where we create transport VLANs to linked the tunnel and insert on these VLANs the selected VLAN ID creating a double TAG.


        To demonstrate the operation, I created a LAB with the following premises:

                · Customer A needs to transport the VLANs 1030 and 2030 to router R1 and the VLAN 530 to router R2.

                · Customer B needs to transport the VLANs 1035 and 2035 to router R1 and the VLAN 535 to router R2.


        With that, we create the VLANs of transport as can you see below:

    · VLAN30   = CLI_A -> R1

    · VLAN35   = CLI_B -> R1

    · VLAN300 = CLI_A -> R2

    · VLAN350 = CLI_B -> R2

 

1


        IPs were placed on the VLANs so that we could realize tests of ping to validate the correct transport work. Following were the configuration of each equipment of this LAB to be replicated by you.


[CLI_A]

vlan batch 530 1030 2030

#

interface Vlanif530

 ip address 50.50.30.1 255.255.255.0

#

interface Vlanif1030

 ip address 10.10.30.1 255.255.255.0

#

interface Vlanif2030

 ip address 20.20.30.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 530 1030 2030

 

[CLI_B]

vlan batch 535 1035 2035

#

interface Vlanif535

 ip address 50.50.35.1 255.255.255.0

#

interface Vlanif1035

 ip address 10.10.35.1 255.255.255.0

#

interface Vlanif2035

 ip address 20.20.35.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 535 1035 2035

 

[PE1]

vlan batch 30 35 100 to 101 300 350

#

mpls lsr-id 1.1.1.1

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif30

 mpls l2vc 2.2.2.2 30

#

interface Vlanif35

 mpls l2vc 2.2.2.2 35

#

interface Vlanif100

 ip address 10.0.0.1 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface Vlanif101

 ip address 10.0.0.5 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface Vlanif300

 mpls l2vc 3.3.3.3 300

#

interface Vlanif350

 mpls l2vc 3.3.3.3 350

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/2

 qinq vlan-translation enable

 port hybrid untagged vlan 30 300

 port vlan-stacking vlan 10 stack-vlan 30

 port vlan-stacking vlan 20 stack-vlan 30

 port vlan-stacking vlan 50 stack-vlan 300

#

interface GigabitEthernet0/0/3

 qinq vlan-translation enable

 port hybrid untagged vlan 35 350

 port vlan-stacking vlan 10 stack-vlan 35

 port vlan-stacking vlan 20 stack-vlan 35

 port vlan-stacking vlan 50 stack-vlan 350

#

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 101

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[PE2]

vlan batch 30 35 100

#

mpls lsr-id 2.2.2.2

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif30

 mpls l2vc 1.1.1.1 30

#

interface Vlanif35

 mpls l2vc 1.1.1.1 35

#

interface Vlanif100

 ip address 10.0.0.2 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 30 35

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[PE3]

vlan batch 300 350 101

#

mpls lsr-id 3.3.3.3

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif300

 mpls l2vc 1.1.1.1 300

#

interface Vlanif350

 mpls l2vc 1.1.1.1 350

#

interface Vlanif101

 ip address 10.0.0.6 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 101

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 300 350

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[R1]

#

interface GigabitEthernet0/0/0.3010

 qinq termination pe-vid 30 ce-vid 1030

 ip address 10.10.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3020

 qinq termination pe-vid 30 ce-vid 2030

 ip address 20.20.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3510

 qinq termination pe-vid 35 ce-vid 1035

 ip address 10.10.35.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3520

 qinq termination pe-vid 35 ce-vid 2035

 ip address 20.20.35.2 255.255.255.0

 arp broadcast enable

#

 

[R2]

#

interface GigabitEthernet0/0/0.3050

 qinq termination pe-vid 300 ce-vid 530

 ip address 50.50.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3550

 qinq termination pe-vid 350 ce-vid 535

 ip address 50.50.35.2 255.255.255.0

 arp broadcast enable

#

 


  • x
  • convention:

Unicef
MVE Created Nov 28, 2020 03:28:27 Helpful(1) Helpful(1)

Good job
View more
  • x
  • convention:

lucian2003
lucian2003 Created Nov 29, 2020 21:24:12
 
Live%20Lead%20Love%20%3A)
wissal
MVE Created Nov 28, 2020 05:17:01 Helpful(1) Helpful(1)

Learning together, never stop!
View more
  • x
  • convention:

Faridrami
Faridrami Created Dec 25, 2020 16:50:25
 
I%20would%20like%20to%20share%20with%20you%20my%20experience%2C%20I'm%20telecommunications%20engineer%2C%20currently%20senior%20project%20manager%20at%20an%20operator%2C%20partner%20of%20Huawei%2C%20in%20the%20radio%20access%20network%20department%2C%20for%2020%20years%20I%20managed%20several%20types%20of%20projects%2C%20for%20the%20different%20nodes%20of%20the%20network.%3Cbr%2F%3EAt%20the%20same%20time%2C%20I%20give%20courses%20in%20universities%20as%20a%20temporary%2C%20to%20bring%20the%20operational%20side%20of%20telecommunication%20technologies%20to%20students%2C%20for%20network%20supervision%20systems%2C%20mobile%20radio%20networks%20and%20access%20networks%20et
user_4049985
Created Nov 28, 2020 11:39:23 Helpful(0) Helpful(0)

very good, excellent work, congratulations
View more
  • x
  • convention:

victorDa
victorDa Created Nov 28, 2020 17:59:25
 
ViniciusOchiro
Created Nov 28, 2020 13:47:21 Helpful(0) Helpful(0)

selective qinq is really useful. very nice work, thanks for sharing!
View more
  • x
  • convention:

albertsilva
albertsilva Created Dec 25, 2020 14:34:23
 
Faridrami
Created Nov 28, 2020 16:10:49 Helpful(0) Helpful(0)

Good job
View more
  • x
  • convention:

albertsilva
albertsilva Created Dec 25, 2020 14:34:30
 
Faridrami
Faridrami Reply albertsilva  Created Dec 25, 2020 16:49:54
 
Faridrami
Faridrami Reply Faridrami  Created Dec 26, 2020 16:10:28
 
Faridrami
Faridrami Reply Faridrami  Created Dec 26, 2020 16:12:46
 
997328688
Created Nov 29, 2020 00:19:13 Helpful(0) Helpful(0)

Works fine! Thanks @LuizPuppin. 


Thinking of a scenario where we need to deliver several vlans in a 

sub-interface of a BRAS of a NE40 with pppoe-server as the image below. 

How would the settings look?

olt


View more
  • x
  • convention:

user_3982663
user_3982663 Created Nov 29, 2020 02:05:41
I think it's possible.  
LuizPuppin
LuizPuppin Created Nov 29, 2020 19:35:18
It is possible and I already do this. On NE40, on sub-interface, you need to configure de command "user-vlan" to open a qinq frame.  
997328688
997328688 Reply LuizPuppin  Created Dec 1, 2020 13:44:45
I am testing this functionality on the Eth-trunk interface and got this feedback by adding the access-type layer2-subsbriber command:
Error: Cannot configure L2 access type on the L3 interface.

interface Eth-Trunk2.250
description Transport L2VC - Qinq
ipv6 enable
ipv6 address 2001:db8::/64 eui-64
ipv6 address auto link-local
statistic enable
user-vlan 400 416 qinq 250
bas  
chenhui
chenhui Reply 997328688  Created Dec 1, 2020 13:53:12
As the error displayed, it's not allowed to add a L2 interface into a L3 eth-trunk.  
lucian2003
MVE Created Nov 29, 2020 21:24:24 Helpful(0) Helpful(0)

good post
View more
  • x
  • convention:

Hello%20friends%2C%20I%20am%20a%20Telecommunications%20and%20electronics%20engineer%20and%20I%20just%20graduated%20as%20a%20master%20in%20telecommunications%20systems.%20I%20am%2036%20years%20old%20and%20I%20attend%20the%20transport%20network%20in%20my%20province%2C%20which%20is%20mainly%20Huawei.
Chenxintao
Admin Created Dec 1, 2020 03:12:10 Helpful(0) Helpful(0)

Very helpful tutorial, thanks for sharing! Selective QinQ transported by MPLS L2VC simulated on eNSP-3600797-1
View more
  • x
  • convention:

Irina
Admin Created Dec 2, 2020 13:05:09 Helpful(0) Helpful(0)

It got Highlighted so quickly!
I think this is a new record. Congrats! Selective QinQ transported by MPLS L2VC simulated on eNSP-3609627-1
View more
  • x
  • convention:

LuizPuppin
LuizPuppin Created Dec 2, 2020 13:10:58
Tks @Irina  
Community%20Manager%20of%20the%20English%20Huawei%20Enterprise%20Community%3Cbr%2F%3ELeading%20the%20MVE%20team
12
Back to list

Comment

You need to log in to comment to the post Login | Register
Comment

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " Privacy."

My Followers

Login and enjoy all the member benefits

Login

Huawei Enterprise Support Community
Huawei Enterprise Support Community
Block
Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Reminder
Please bind your phone number to obtain invitation bonus.