Got it

s9300 - NQA doesn’t seam to work

Latest reply: Oct 30, 2013 20:25:51 3696 3 0 0 0

I tried a few simple nqa tests on the real s9300 switches. None brought any results. I mean, dis nqa res and dis nqa hist  returned empty responses.
Soft : V100R006, V200R002 (no results as well)

Take icmp for a start - comands :
nqa test-instance admin icmp
 test-type icmp
 destination-address ipv4 IP_addr
 source-address ipv4 IP_local_Vlanif /tried also source-interface vlanif 100/
 start now

IP_addr is reachable in the network.

jitter test (in cooperation with another s9300 as a server) doesn't work as well. No trace of running...


Then I checked again with "debug nqa all" turned on.
There was only one response (except for info about config changes) after “start now” :
Oct 18 2013 14:43:02.770.2+01:00 DST sw-PD1-1 NQA/7/debug:
FileNo:LineNo 00:15565 , Type: ICMP AdminName: admin TestName: icmp Icmp test start param is ok.

That’s it. Nothing in logs as well.

On eNSP switch it works as expected.

NQA on AR4945 works well (of course commands are a bit different).

Hope you might have any idea, what’s wrong.


  • x
  • convention:

Created Oct 22, 2013 09:55:43


mayebe  help you



T01-01 NQA

T01-0101 ICMP NQA


To test the function of ICMP NQA.

Test Networking Diagram


The devices are connected according to the networking diagram. The SW is a Layer 2 and Layer 3 switch that supports the function to be tested.


1.         Create VLAN 100 on the S9300 and add GE1/0/1 to VLAN 100 indefault mode.

[Quidway] vlan 100

[Quidway-vlan100] quit

[Quidway] interface GigabitEthernet 1/0/1

[Quidway-GigabitEthernet1/0/1] port link-type access

[Quidway-GigabitEthernet1/0/1] port default vlan 100

2.         Create VLAN 100 on the SW and add GE1/0/1 to VLAN100 indefault mode.

3.         Create VLANIF 100 on the S9300 and the SW. Assign IP addresses that belong to the same network segment to VLANIF 100. Run the ping10.1.1.2 command. Expected result 1 is displayed.

[Quidway-Vlanif100] ip address10.1.1.1 24

4.         Enable the NQA client and create an ICMP NQA test.

<Quidway> system-view

[Quidway] nqa test-instance admin icmp

[Quidway-nqa-admin-icmp] test-type icmp

[Quidway-nqa-admin-icmp] destination-address ipv410.1.1.2

5.         Start the test.

[Quidway-nqa-admin-icmp] start now

6.         Run the display nqa results test-instance admin icmp command on the S9300. Expected result 2 is displayed.

Expected Results

1.         The S9300 can ping10.1.1.2.

[Quidway] ping10.1.1.2

  PING10.1.1.2: 56  data bytes, press CTRL_C to break

    Reply from10.1.1.2: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from10.1.1.2: bytes=56 Sequence=2 ttl=255 time=1 ms

    Reply from10.1.1.2: bytes=56 Sequence=3 ttl=255 time=1 ms

    Reply from10.1.1.2: bytes=56 Sequence=4 ttl=255 time=1 ms

    Reply from10.1.1.2: bytes=56 Sequence=5 ttl=255 time=1 ms

  --- ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max =1/1/1ms

2.         The test is successful.

[Quidway]display nqa results test-instance admin icmp

NQA entry(admin, icmp) :testFlag is inactive ,testtype is icmp

  1 . Test 1 result   The test is finished

   Send operation times: 3              Receive response times: 3

   Completion:success                   RTD OverThresholds number: 0

   Attempts number:1                    Drop operation number:0

   Disconnect operation number:0        Operation timeout number:0

   System busy operation number:0       Connection fail number:0

   Operation sequence errors number:0   RTT Stats errors number:0

   Min Positive Jitter: 0               Min Negative Jitter: 0

   Max Positive Jitter: 0               Max Negative Jitter: 0

   Positive Jitter Num: 0               Negative Jitter Num: 0

   Positive Jitter Sum: 0               Negative Jitter Sum: 0

   PositiveJitter SquareSum:0            Negative Jitter SquareSum: 0

   Packet Loss: 0                       Packet Loss Ratio: 0

   Destination ip address:

   Min/Max/Average Completion Time:1/1/1

   Sum/Square-Sum  Completion Time: 3/3

   Average Single-Way Completion Time: 1

   Last Good Probe Time: 2009-02-13 17:32.7  


1.         The SW should support the NQA function.

2.         To stop the test, you can run the stop command in the NQA view of the S9300.

Internal Number


View more
  • x
  • convention:

Created Oct 29, 2013 17:43:59

Sorry for delay in responding...

Thank you for the excellent doc but unfortunately it didn't solve the problem.

This time I tried some extra debugging on V200R002 and it returned somthing I don't understand. Maybe you might help.

The config was as follows (nothing fancy) :


[sw_PD-nqa-admin-icmp]dis th


nqa test-instance admin icmp

test-type icmp

destination-address ipv4

start now



Than stop/start to trigger reaction... and debugging results.

[sw_PD]nqa test-instance admin icmp


Oct 29 2013 09:59:40.130.1+01:00 sw_PD NQA/7/debug:nqa sch stop


Oct 29 2013 09:59:48+01:00 sw_PD DS/4/DATASYNC_CFGCHANGE:

OID configurations have been changed. The current

change number is 2099, the change loop count is 0, and the maximum number of rec

ords is 4095.

[sw_PD-nqa-admin-icmp]start now

Oct 29 2013 09:59:50.910.1+01:00 sw_PD NQA/7/debug:

FileNo:LineNo 00:16792 , Type: icmp AdminName: admin TestName: icmp Icmp test st

art param is ok.

Oct 29 2013 09:59:50.910.2+01:00 sw_PD NQA/7/debug:

FileNo:LineNo 35:07641  Schedule  The GTL License is not active.


The green-one response is the same as on V100R006, but the red-one appeared on the V200R002 VRP.

The question is : what does  "The GTL License is not active "  mean ? Maybe there is something missing in the system.


And again, neither "display nqa results test-instance admin icmp" nor "display nqa history" returned anything, an empty line only. 

View more
  • x
  • convention:

Created Oct 30, 2013 20:25:51

I suppose I know the reason the NQA doesn't work. I've found the following excerpt in the License Usage Guide :


Features Supporting Licenses on the Device

The S9300&S9300E uses licenses for controlling features such as MPLS, NQA, IPv6, CSSing using service interfaces, and traffic distribution. These features take effect only after the device loads the licenses. If the license is unavailable, the commands can be run on the device, but the function does not take effect.


The thing is, that our switches were supposed to have all the licenses for built-in features. I'm going to check it out with our reseller.


View more
  • x
  • convention:


You need to log in to comment to the post Login | Register

Notice: To protect the legitimate rights and interests of you, the community, and third parties, do not release content that may bring legal risks to all parties, including but are not limited to the following:
  • Politically sensitive content
  • Content concerning pornography, gambling, and drug abuse
  • Content that may disclose or infringe upon others ' commercial secrets, intellectual properties, including trade marks, copyrights, and patents, and personal privacy
Do not share your account and password with others. All operations performed using your account will be regarded as your own actions and all consequences arising therefrom will be borne by you. For details, see " User Agreement."

My Followers

Login and enjoy all the member benefits


Are you sure to block this user?
Users on your blacklist cannot comment on your post,cannot mention you, cannot send you private messages.
Please bind your phone number to obtain invitation bonus.